• Welcome to the largest (sim) racing website in the world!
    Blurring the line between real and virtual motorsports.

Fanatec CSR Elite Pedals - Disconnection Problem - Windows 10 Version 1511

Discussion in 'Sim Racing Hardware' started by Champion Hero, Dec 20, 2015.

  1. Champion Hero

    Champion Hero

    Hi Guys
    After a bit of help here.
    So, up until today, my CSR Elites EU have been working without issue under Windows 10 using the latest available 64bit driver on the Fanatec Site http://www.fanatec.com/download/Fanatec_64_driver_144.msi

    Windows 10 did a length "Upgrade" today (not, not just an update) to what is being touted as Version 1511. All went fine with the upgrade other than having to reset my browser default.

    I booted into AC and ran a couple of laps, no worries. Then installed the latest RFactor2 Demo on Steam, and ran a couple of laps in that. I initially had issues with RF2 detecting my pedals. I quit the game, relaunched and then it detected everything perfectly. Ran a few laps, was happy with everything and then quit the program.

    I went back to AC, and thought I'd have a bit more of a play with the new Brands Hatch circuit so ran my normal apps (DashMeterPro and JoyToKey). It was after quitting this I ran into trouble. As soon as I quit AC and JoyToKey, Windows started playing the 'USB Disconnect' sound every 3-4 seconds. At first I just thought something had crashed, so did a reboot - but upon startup I instantly had the same cycle of sound. Note - there is not 'Connect' sound, just the disconnect sound.

    I spent ages troubleshooting what device was disconnecting and narrowed it down to my pedals - however there are no logs to say why.
    You can see a "USB Device" in device manager appearing/disappearing and in USB Controllers, you can witness the pedals disconnect there constantly. I tried reinstalling everything, deleting JoyToKey and RF2, unplugging ALL USB devices, changing ports, cleaning the pedals/sensor, taking the little box apart under the pedals and ensuring nothing was loose - nothing works.. except if you open either the controller properties page, leave JoyToKey running, or launch a game. Once something is 'using' the pedals, they remain connected without issue. As soon as you quit any of those apps, the issue re-appears. The only thing I haven't done is replace the cable as I don't have one to hand - however, the fact it works when an app is running makes me think it's not that cable...

    It's driving me bonkers and I'm scratching my head why it's suddenly happened and if there is a fix? Could the pedals be faulty? Load cell or controller dying? Windows borked?

    Has anyone else experienced this with CSR Elites?
    • Agree Agree x 1
  2. Champion Hero

    Champion Hero

    OK it seems that for some reason, the latest Windows 10 update may have introduced this:


    However, in my registry I noticed that under my Device ID for the pedals there were a few options referring to different ports. I see now reason why this would cause issues, but perhaps it thought it was being swapped between ports? Either way, I deleted the entries OTHER than the current one, and disabled the power save function for the device and touch wood, it appears to have worked.
    • Like Like x 1
  3. Insert Coin

    Insert Coin

    Upgraded to Windows 10, exactly the same issue: disconnect sound every 3 seconds. I had to edit the registry, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\VID_0EB7&PID_1839\6&26c83871&0&4\Device Parameters and enter a 0 in "EnhancedPowerManagementEnabled". The problem is gone now.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.