Customising Cars

I am baffled by this and looked all over iRacing FAQs etc and can't find the answer!

I was using Google Chrome on a Windows 8.1 Pro PC and it let me customise my helmet and suit fine and has saved them. However, it won't let me do anything with the cars. I click the customise car tab, then the various cars i have pop up and then i select one and nothing happens. I tried a bunch of times.

Here i thought it may be the browser, so tried on Chrome and Safari on my Mac, but exactly the same issue.

Anyone got any solutions to this so i can change them from the stock and bland white cars?
They prioritize support requests so you'll be behind anyone who can't race, but support is really good.

Is iRacing fully updated? Have you tried clearing your cache?
Yep, it is fully installed and fully updateed. How do i clear the cache? Or do you just mean the general browser cache? If so, already tried that.

This is getting rather annoying now. I can edit helmet and suit. But when i click car i get the upper window with my cars in but whichever i choose, i get the blue-ish ring around it to show it is selected and there is nothing more.

Here is an example:

And showing that the customise helmet and suit tabs work fine:

Last edited:
Have you tried Firefox? I seem to remember a few problems with Chrome in the past.

You should also post those screenshots in the Problem Reporting forum. If it's a bug, the web guys tend to look there and could use the info.
I am in touch with iRacing saupport and have emailed them. It actually happens on Chrome, Internet Explorer and Safari on both by Windows 8.1 Pro 64 bit and my Mac 10.9.3 machines. Therefore, more likely to be an issues with my profile rather than a generic bug i think.