• Guest, RaceDepartment is now on Discord!  Join Here

BTB error opening track


Jun 2, 2009
Hi guys, is somebody able to help me?
BTB Version
I saved the wip track yesterday as usual, but today attempting to re-open it the following error appears and there is no way to open the track... I hope somebody can help me to save my work and to open the track...

Attached the error window and the info...

many thanks in advance!



Mar 24, 2009
sorry m8, didn;t understand the error text.have you added texture or object.


Jun 2, 2009
banger, I was adding sobject from vegetation xpacker (palms)...
I exported the wip track as usual to test it, saved it and I went to sleep...
Now it is impossible to re-open the wip track... days and days wasting my time?
I'm not able to manage the venue.bin to solve the mistake... uhmmm


Mar 16, 2009
I copy&paste a possible solution from chub pearson:

Have you checked for backups in the 'Temporary Files' folder in BTB? In it should be many backups of your track Venue.bin file saved using random file names. You can copy files from here to your track folder and rename them Venue.bin. If you're working on more than one track then the backup file size will be the same as your track's Venue.bin

look also at the date and time of files, yours should be the last one. But remember to make a backup of your project directory first!!! If this works you would just lose the most recent modifications


Jun 2, 2009
Thanks eno72... it partially solved the problem...
I found tens and tens of files: I tried to used them one by one but it is really strange!
All files of yesterday give the same error, but I saved the track several times yesterday, because of I made hours and hours of job and I also exported the track several times to try it and everytime I was able to re-open the track!
Now it is impossible!!!!!!
Using instead the last temporary file of the day before yesterday I'm able to open the track...
Maybe Mr. Brendon could be interested in understanding the why and I hope him can help me.
Many many thanks eno!


Jun 2, 2009
No other guy can help me? Can I read the bin file to fix the mistake? What software can I use do do it?

many thanks in advance guys!

Eric Tozer

Mar 16, 2009
I think what has probably happened is that your venue is looking for something in the xpack which is no longer there.
This is why all the backups have the same error.
Try to think what you recently changed in the xpack & hopefully you can repair it back to what it was before.

When updating xpacks I strongly advise everyone to make a backup of the old pack which you know works.
(I just copy mine to the desktop)
Then try to use the updated one & make sure all is well before getting rid of the old one.
Also quit BTB & reload with the new xpack.
Don't just update it while BTB is running.
BTB will check xpacks for errors on loading.
It cannot run these checks if running while xpacks are updated.

Good Luck Marco


Jun 2, 2009
thanks Eric, but I follow a strong procedure just to avoid any problem from XPackers. In this case the last "new" XPacker has dated Oct. 1st and the I gave the error on Oct. 7th while I can open the "temp" venues dated Oct. 6th.
So the problem is another... The thing I know is that I worked hard using "Tree Collection XPacker" and at the same time deleting lots of sObjects "tree backgrounds" from Great Bretain RBR...

Basically the error is the "Index"... translating it means negative value that in less than the total of the dimension... ???

Here more details:

System.ArgumentOutOfRangeException: Index non compreso nell'intervallo. Richiesto valore non negativo e minore della dimensione dell'insieme.
Nome parametro: index
in System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
in System.ThrowHelper.ThrowArgumentOutOfRangeException()
in System.Collections.Generic.List`1.get_Item(Int32 index)
in BobsBits.SObjectPiece.LoadFromBinary(BinReader br)
in BobsBits.SObjectPieces.LoadFromBinary(BinReader br)
in BobsBits.SObject.LoadFromBinary(BinReader br)
in BobsBits.SObjectInstance.LoadFromBinary(BinReader br)
in BobsBits.SObjectInstances.LoadFromBinary(BinReader br)
in BobsBits.Venue.LoadFromBinary(String ProjectFolder, String Filename, Boolean ForAnUndo, String& ErrorMessage)
in BobsTrackBuilder.frmMain.OpenVenueFile(String ProjectFolder, String Filename, Boolean ForAnUndo)
in BobsTrackBuilder.frmMain.mnuFileOpen_Click(Object sender, EventArgs e)
in System.Windows.Forms.MenuItem.OnClick(EventArgs e)
in System.Windows.Forms.MenuItem.MenuItemData.Execute()
in System.Windows.Forms.Command.Invoke()
in System.Windows.Forms.Command.DispatchID(Int32 id)
in System.Windows.Forms.Control.WmCommand(Message& m)
in System.Windows.Forms.Control.WndProc(Message& m)
in System.Windows.Forms.ScrollableControl.WndProc(Message& m)
in System.Windows.Forms.ContainerControl.WndProc(Message& m)
in System.Windows.Forms.Form.WndProc(Message& m)
in System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
in System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
in System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I'm sure you can understand more than me Eric!! Thanks once again!!

Eric Tozer

Mar 16, 2009
I would try making a new track & load all objects from your xpack.
Save the file to a new name.
Try exporting to RF.
Then shut down BTB.
Re open the file you've just saved to see if you can replicate the error.

Do this for each xpack that is in your Venue, saving to a different name each time.

Basically what I'm trying to determine is if the problem is in an xpack or if something else has occurred.


Nov 4, 2009
Fix this problem

I had the same problem, that marcobost wrote.

But, I can fix it int this way:
When this problem occourd, I pressed the "Continue" button on the .Net Framework window, because this is for skip the errors. So, the BTB ran , but all 4 views were blank (gray). Then I Save as... this track to another name, and I closed the BTB, and I restart it, and I able to open the new track, what I saved before.

So I can fix it!

Follow RaceDepartment