Automobilista Awesome Mod - The Audi R8 LMS GT3 with Paul Jeffrey
Available now on the LIVESTREAM page.

Brake & Throttle problems with SideWinder FFB Wheel

Discussion in 'Richard Burns Rally' started by JoG, Jun 16, 2011.

  1. JoG


    After a few years of inactivity, I reinstalled RBR but encountered problems with my Microsoft SideWinder FFB Wheel.

    No matter what I try, brakes and throttles won't work linear and so I have no good control in RBR.

    When I gently push the throttle pedal I can see in the control panel of RBR that the red line moves in 2 steps to the right.
    So when I push the pedals very softly, I have half throttle or full, same for the brakes.

    Nevertheless, with the "sidewinder game controller software 4.0" brakes and throttle move smoothly (linear) up and down as I push my pedals.

    Changing the filter settings in RBR doesn't solve this problem neither.

    I searched the internet whole evening, but found no solution for this problem.

    Anyone encountered the same problems, and if so ... found a solution for this enervating problem?

    Kind regards,

  2. Jeremy Loveland

    Jeremy Loveland

    have u tried reditecting the device in RBR?
  3. JoG


    Yes, I did.
    I did almost everything possible to make it work, but .... no result.
    It' s impossible to drive a car this way.
    I will wait a few days to see if someone has a solution for my problem, otherwise I have to reinstall RBR completely.
  4. John Cunningham

    John Cunningham

    sory cant help
  5. Henry Muller

    Henry Muller

    I tried recently RBR with this wheel, and on Windows XP it worked fine with combined pedals, with separate pedals at first the brake pedal was working like a digital key (jumping from 0 to 100), I solved that by using a software called dxtweak2..

    on Windows 7 x64 the driver control panel from MS (4.0) didn't work, so I'm stuck with default settings of the wheel, but the game works, the problem is, FFB doesn't....

    so try this dxtweak2 software and/or changing to combined or separate pedals


    there you can change some settings, I don't remember exactly what I did, but I think I've just changed some values and reseted to default and it fixed the problem!

    before that almost all the games had the problem, only Grand Prix Legends would work perfectly,
    I think what I did reseted something, like a recalibration... on the software I noticed that the raw input signal was perfect but windows directinput would just jump the slider from nothing to the max almost...
    I think Grand Prix Legends bypass some of this direcinput configuration and that's why it was able to work perfectly, but after fixing it with dxtweak2 it's been working perfectly for a long time! it took me a while to figure out how to fix it.

    I hope it helps!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.