Assetto Corsa not butter smooth whatever i do

Haris1977

75RPM
Oct 30, 2015
87
15
43
Greetings.

I didn't know were to upload this thread and sorry if this is the wrong place.

I have a strange problem with all of the versions of AC (1.14, 1.15, 1.16, 1.16.2, 1.16.3 etc). I know that this is kind odd but i do not have butter smooth gaming experience. I have a very sensitive eye in terms of fps/jerkiness. It is an annoying jitter in the visuals. Note this is separate from stuttering. It is a constant uneven framerate, look at the scenery in a turn to see it.

The only version that i have a butter smooth experience (this sounds very odd i know) is the old 1.7.1 version (!!)

I really can't understand why this is happening. My fps are constantly way above 60 fps (> 120 fps in game with all settings to ultra), so fps is not the problem. Even though i have high fps i do not see butter smooth movement (i can see that "jerkiness"/"jittering" in movement especially in "turns"). Same happens even if i turn sync on/off, sync to 60 fps, sync to 61, sync to 83 fps etc, lowering the graphics, removing steering wheel, etc. Even with graphics to low, same happens.

Truth 1: My eye is very sensitive in fps, that's why i can notice it (my friend didn't notice it at all for example). All statistics show no problem

Truth 2: I have a really old 24 inch Dell monitor, but i m not convinced that the monitor is my problem. In other games (ACC, DR2, Race Room Experience i have butter smooth gameplay). With same monitor, same specs.

Truth 3: The problem does not happen in a) benchmarking b) replays

Truth 4: Lots of users face this problem. I recon it is smth with the in - game inability to keep the frames (frame pacing error). It is irrelevant to low or ultra settings/resolution etc

Any thoughts about that?

My log files here for anyone interested: https://www55.zippyshare.com/v/ywyjMj3t/file.html

My rig: ryzen 5 2600x, rtx 2070, 16 GB Ram, latest gfe and driver (3.19.0.107 and 431.60 as we speak)
 
Last edited:
May 31, 2019
184
45
57
1). ok
2). guess an 60hz monitor try to cap your game also around 60FPS. Some are even going to cap it to 55hz.
3). that is because its playing a video
4). you say it, so who am I to discuss this.

Disable all the mods in your game even CM, gameHub and the cars/tracks, keep the game original. Try again, but now logging ALL your CPU Cores & frametimes. MSI afterburner is a fine piece of software of loggingtool and does have an great OSD. I still think one of your cores is overflowing and so brings in an fluctuating in your frame time. If you are sensitive it is that you are notice.
Another experiment you should consider, is doing a test now disabled the Vsync and experiment with all the different Vsync modes in nVidia CP.
 
Last edited: