Am I on the correct AMS version?

EsxPaul

1000RPM
Original poster
Premium
Feb 17, 2016
1,076
822
I'm a G29 user and haven't played the game for a very long time.

I know there have been lots of recent content updates, so I thought I'd give it another try. I have reinstalled the game and before playing, switched to beta version [v1.4.8_g29]

Would I be right in thinking this version will be the same, content wise as the latest v1.5.01- but with the added G29 rotation fix?

Many thanks
 

EsxPaul

1000RPM
Original poster
Premium
Feb 17, 2016
1,076
822
Thanks, Stephen.

I took the gamble of choosing the Logitech beta branch with the highest number.
Hopefully that doesn't mean I'll be missing out on some of the features in the latest version.
 
  • Like
Reactions: Stephen O'Sullivan

jlnprssnr

500RPM
Jul 23, 2015
577
236
Just to clear up possible confusion, the G29 version is a branch of the release build, not the beta game on Steam.
 

Ami_M3

100RPM
Oct 31, 2017
163
256
Thanks, Stephen.

I took the gamble of choosing the Logitech beta branch with the highest number.
Hopefully that doesn't mean I'll be missing out on some of the features in the latest version.
Just to clarify. You don't choose the Logitech beta branch with the highest number. You update AMS to the newest and simply select logitechg29_ like in the attached image. Current version (see: lower right corner - is 1.5.16r). If you pick lets say v1.4.8_g29 you are going for older version, and there is no reason to do so
ams_logiG29.jpg
 

EsxPaul

1000RPM
Original poster
Premium
Feb 17, 2016
1,076
822
Just to clarify. You don't choose the Logitech beta branch with the highest number. You update AMS to the newest and simply select logitechg29_ like in the attached image. Current version (see: lower right corner - is 1.5.16r). If you pick lets say v1.4.8_g29 you are going for older version, and there is no reason to do so
View attachment 286309
Thank you very much for the explanation. That's a great help :)
Seems I was doing things in the wrong order and keeping myself on an older version. I'll go change it now and get myself up to date!