1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
MINI Challenge - Round 1 - Oulton Park (LIVE)

Steering wheel delay

Discussion in 'Euro Truck Simulator 2' started by Bazooka_Joe, Mar 20, 2014.

  1. Bazooka_Joe

    Bazooka_Joe
    Best of the worst, sometimes worst of the worst. Premium Member

    I wonder if anyone else is experiencing this too:

    After a very fast direction change on my Logitech DF GT the steering wheel of the lorry on screen is delayed (or probably is turning with its maximum allowed speed) - especially annoying when I can rotate my wheel faster than the lorry in game. This causes the issue where my wheel is for example fully straight up, but the lorry is still in the middle of straightening up and not going straight yet because it's still catching up. This only happens during fast changes only, cruising during normal conditions is fine - it happens only during dynamic direction change (even at low speed).

    Is this a game bug or is there a setting I'm missing?

    I'm using latest version (1.8.2.5) with only Realistic Physics Mod enabled. Wheel settings are mirroring those from here: http://www.racedepartment.com/forum/threads/euro-truck-simulator-ets2-logitech-g25-settings.58349/
     
  2. Not a truck driver, but to me that sounds like the correct behaviour for a 20 ton truck with 1620 degrees lock to lock steering.
     
  3. Bazooka_Joe

    Bazooka_Joe
    Best of the worst, sometimes worst of the worst. Premium Member

    That makes perfect sense Senad, thanks, but unfortunately it's really annoying when according to my physical moves lorry should go straight - and it doesn't...

    The other solution would be to reduce the speed I can rotate my wheel then (using FFB). Is this even possible?
     
  4. Bazooka_Joe

    Bazooka_Joe
    Best of the worst, sometimes worst of the worst. Premium Member

    Update: The delayed wheel movement can be fixed by increasing the Steering Sensitivity option. I've moved the slider all the way to the right and the problem is gone.