1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ride2 tracks for MotoGP17 and other experiments 0.4

18 tracks are not enough ? how about having 32 ?

  1. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105
    ReZ submitted a new resource:

    Ride2 tracks for MotoGP17 and other experiments - 18 tracks are not enough ? how about having 36 ?

    Read more about this resource...
     
  2. polerst

    polerst

    Messages:
    172
    Ratings:
    +73
    Wow, great job ReZ, I really appreciate it, this is something the best on our modding section :)
    The only thing is waiting for your next mods!
     
  3. Aernouts

    Aernouts

    Messages:
    14
    Ratings:
    +1
    Hello Rez

    Just tried it and not all tracks are loading. (only imola and nurburg)
    Is your game updated with the latest update ?

    Looking through your data.mix it seems you have not installed latest update.
    Anyway thx for putting time in so far.
    I am gonna see if i can learn myself.
     
  4. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105
    yeah somehow the game just decided to randomly remove tracks from the menu ... i have no idea why and its driving me crazy... i had all 13 ride2 and the 5 vrtg tracks working at the same time ... drove em all and now 5 of em are just gone :/

    hm there has only been one patch for the game so far ? or am i wrong ?
    but you could try to move my modded files into your data.mix and see how it works out.
    from my data.mix you will need : DB_Tracks.bml , DB_Weekends.bml, DB_WeekendSets.bml, DB_Gameentitytracks.bml...and the DATA\TRACKS\ folder.
    from gfxgem.mix : gfxgem_tracks.bml
    and use the mixfiles.lst i made - or copy the additional entries into yours.
     
  5. girlracerTracey

    girlracerTracey

    Messages:
    37
    Ratings:
    +7
    Yes Rez, same problem here also. I think I have ended up with Almeria, Potrero, Imola, Monza & somehow (under the Losail tab) also the NW200..which i have already anyway..?

    Murphy's law but was really keen to race on Vallelunga but that's one of the ones that seems to have been removed by the game.. :(

    Really appreciate your work..! Hope for a solution.

    Love the tracks I do have though. :)
     
  6. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105
    hmm..no Road America, NürburgringGP and Macau showing up for you ? these are the ones that i have in addition to yours... but i miss UlsterGP, Nordschleife, Vallelunga, MagnyCours and Sugo.
    i have let a friend sent me a new data.mix ... still cannot get the tracks back :(
    the crazy thing is ... i tested all tracks if they load and are drivable, quit the game to start new with gamepad plugged in ... since then the tracks were gone ^^
     
  7. girlracerTracey

    girlracerTracey

    Messages:
    37
    Ratings:
    +7
    This will not help much I suspect in any way but I just double-checked and I found Macau and it works fine.. It didn't have a flag so I was stupidly ignoring it. ;) But anyway it is there and it works fine.. Definitely no Nordschleife or Magny Cours for me though. It seems the game has a mind of its own when you offer up your RIDE 2 tracks mod to it???!!!!! Milestone strikes again.. lol!
     
  8. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105
    I restarted from zero and made a data.mix with only the 5 tracks that dissapeared in the mod...so far i could remove and reinstall the mod several times and the tracks stay...i also reinstalled the game before and downgraded bml-editor to older version :/ btw... i really should change Imola, Road America and Sugo to the non-chicane version....
     
  9. Dyego JhOu

    Dyego JhOu

    Messages:
    339
    Ratings:
    +104
    If you think the problem can be at the bml editor, please send a comment there with what you found, so i can fix it :thumbsup:
     
  10. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105
    so it already starts again ... wanted to add Road America as 6th track this morning ... does not show up - at least the other tracks did not disappear in the process.
    still cannot find anything wrong compared to the tracks that work and RA was already working fine in the other mod^^

    @Dyego JhOu would be nice if you could take a look into the bml files...especially DB_Tracks.bml, DB_Weekends.bml and DB_WeekendSets.bml ...maybe you find something broken.
    here are the current files i am using - > http://www.mediafire.com/file/w0894czfhu6d5kw/experimental.zip

    if anybody wanna try, no multiple losails this time - but everything after valencia should be modded track and please make sure to have a MotoGP/500cc/4-stroke bike selected.

    could also be something with remixer or JSGME ... or most probably just broken milestone game logic.

    edit : ooops .. .i made a little mistake in mixfiles.lst ... "tracks\road_america.mix" was "tracks\roadamerica.mix" - but that did not fix it and should not keep anyone from seeing the track in menu, it should just crash the game upon loading the track^^
     
    Last edited: Jul 4, 2017
  11. girlracerTracey

    girlracerTracey

    Messages:
    37
    Ratings:
    +7
    I've got everything but Sugo (in the Motegi slot?) now when I load the "Motegi" track I get the purple page telling me the track is missing..

    Am I right in saying motoegi should load as Sugo?

    Thanks again for your hard work Rez. I just need Sugo somehow..
     
  12. Dyego JhOu

    Dyego JhOu

    Messages:
    339
    Ratings:
    +104
  13. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105
    wtf ... this purple-screen thingy is not supposed to happen ... i just tested both tracks ... but they load fine...any chance you maybe did not overwrite gfxgem.mix with the new one ?
    but having 2x motegi is correct, like extra silverstone = ulsterGP, extra germany = Nordschleife.
     
  14. girlracerTracey

    girlracerTracey

    Messages:
    37
    Ratings:
    +7
    O.K. I just deleted all three files and pasted your files once again into my game folder..it works now. I have Sugo..

    I am really not sure why it didn't the 1st time. I copied and pasted I'm pretty sure exactly as before..

    So your files are correct. Something went wrong my end.. I'm just not sure exactly what..?

    Anyway, it's working fine now.

    Sorry to have troubled you. I'm really happy to have Sugo working though as it's a great track!

    Once again thanks Rez.
     
  15. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105
    no problem, meanwhile i found a way to make the ride2 tracknames work correct without editing menu.mix :p
     
  16. Aernouts

    Aernouts

    Messages:
    14
    Ratings:
    +1
    Ok cool tell me how plzz:)

    BTW:
    I have got *historical* tracks from VRTG running (also track icons)
    and today i got =>Sugo =>Vallenlunga =>Mangy Cours running pretty well.
    And i am almost sure nurburgring will also work (will try tomorow)
    then 1 track on my list ... Indianapolis from MGP15 ....(i will also try tomorow)
    Will this be possible REZ ?
    Till now everything works great... btw i am using my own data.mix because i have some nice home made physics in there
     
  17. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105
    okay , i'll try to explain what i did :)
    extract from Ride2 menu.mix the file "DB.ZTS"
    copy this into your data.mix - i used DATA\TRACKS\...
    rename it to something else from DB.ZTS into maybe RIDE.ZTS
    now locate the file Dictionarieslist.bml :)
    you will see some entries "+Dictionary" there ... do a nice copy / paste of one so you get additional entry at the bottom.
    change the entry into "Data/Tracks/RIDE.xml"

    now open bml editor 2 times with DB_Tracks.bml from Ride2 and MGP17
    the entry you are looking for is "UI_Name_Txt" this need to be same like Ride2 for all tracks:)
     
  18. Aernouts

    Aernouts

    Messages:
    14
    Ratings:
    +1
    Ok thx (once again)
    I got it

    In theory mgp 15 tracks schould also work...... Right ?
    Because i did once read on ride 2 forum, that someone did import ride 2 tracks into mgp 15. With your files.
    So other way around should work too.??
     
  19. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105
    mgp15 tracks should work yes, but you may experience graphical glitches on some.
    look like adding Indianopolis could be easy since so many files already have the entries for it^^



    meep meep ... new version would be ready ... but somehow the flash player always hangs up when i try to upload it.
    anyways, so no hick-ups so far - could restart the game many times with and without mod - restart my PC etc... no track lost on the way :)
    0.2 coming soon i guess
     
    Last edited: Jul 4, 2017
    • Like Like x 1
  20. ReZ

    ReZ

    Messages:
    292
    Ratings:
    +105