• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Have a chance to win a copy of F1 2017 The Game (PC) by following RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and / or YouTube.

FPS Issue

Discussion in 'Formula SimRacing' started by Nick Rowland, Jun 9, 2010.

  1. Nick Rowland

    Nick Rowland

    Messages:
    383
    Ratings:
    +107
    Hi guys,

    I've recently formatted my PC and after re-installing rFactor and copying all the old user files across I've had constant FPS issues.

    Even with a fresh rF install and a new PLR I still have FPS issue. I have the exact same settings I had prior to formatting and yet my FPS is stable but then will just glitch down to 30. I've tried all different tracks and mods and it's the same on every single one.

    I've tried different drivers also and configured different things in graphics properties. Still the same problem...

    This doesn't happen on any other game either. iRacing, Bad Company 2 and Modern Warfare are all fine.

    I've got a Radeon HD4580 Graphics Card. And I know this works cause it worked prior to format.

    Anyone got any ideas on what it may be?

    Cheers,

    Nick
     
  2. Dennis Hirrle

    Dennis Hirrle

    Messages:
    303
    Ratings:
    +1
    I don't know that much in that dept, but check in your Catalyst Center, in 3d options, that you have everything set to "let application choose" or something (don't know what it is in english, basically deactivate all the AA and AF).
    Then put them as you want in the game. Maybe that helps?
     
  3. Nick Rowland

    Nick Rowland

    Messages:
    383
    Ratings:
    +107
    That has actually helped a bit. But I think I found the problem. Looks like when I formatted my PC I installed an old set of Motherboard drivers. I've just found the updated ones released last year. Dropped them on and it seems to be running a bit better now. If anything quicker and a bit cooler also.

    But that graphics thing you've mentioned I will also make sure on that. Cheers.
     
  4. Stefan Kanitz

    Stefan Kanitz
    Premium

    Messages:
    267
    Ratings:
    +48
    Try to delete the d3d9.dll in your rfactor installation, if this file is available.
     
  5. Nick Rowland

    Nick Rowland

    Messages:
    383
    Ratings:
    +107
    My FPS issue has come back.

    I installed all new Motherboard drivers and seemed to be ok but it's back again. My FPS is never stable. Some parts of the track it's over 200 then other parts it's 90. It constantly fluctuates but it's causing jumping and it's getting hard to drive it.

    Like I said previously it worked fine prior to format.

    Any ideas welcome

    Thanks,

    Nick
     
  6. Johannes Kunkel

    Johannes Kunkel

    Messages:
    856
    Ratings:
    +619
    in case you have a dualcore, maybe check if the fullproc command is set
     
  7. Nick Rowland

    Nick Rowland

    Messages:
    383
    Ratings:
    +107
    Where's that mate?
     
  8. David Dominguez

    David Dominguez
    Premium

    Messages:
    2,578
    Ratings:
    +1,564
    [​IMG]
     
  9. Scrambles

    Scrambles
    Mower of Lawns Premium

    Messages:
    753
    Ratings:
    +612
    What exactly does the +fullproc command do? I assume it has something to do with multi-core processors.

    I've had problems with several old games (not rFactor) that don't like running on multiple cores, and I've had to go through a complex process to rig the .exe to only use one core. Is this what the +fullproc command does?
     
  10. Johannes Kunkel

    Johannes Kunkel

    Messages:
    856
    Ratings:
    +619
    it makes the game use both (or all 4) cores, this gives a little fps increase (for me this was about 40-50% more fps). But it can make rF run unstable, so test it before you use it in a race.

    It doesn´t use the full advantages of a multicore CPU though, but always worth a try.
     
  11. Nick Rowland

    Nick Rowland

    Messages:
    383
    Ratings:
    +107
    I don't have a shortcut I just run it directly form the folder...
     
  12. Carlos Hernandez

    Carlos Hernandez

    Messages:
    221
    Ratings:
    +152
    Then ctrl+alt+supr when running the game. go to processes section and right clic on rFactor.exe -> set afinity (or similar, don't know how it's in english, sorry) and select all cores, apply, and keep driving ;)
     
  13. David Greco

    David Greco

    Messages:
    207
    Ratings:
    +82
    or just drive all the time with the fsr manager, there is the option to activate that thru the manager :p but is the least pratical of all the options already said here :D
     
  14. Pedro Melim

    Pedro Melim

    Messages:
    80
    Ratings:
    +0
    If u put this on the target of the shortcut works as well.

    "D:\FSR 2010\rFactor.exe" +fullproc