1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FFB disapearse when game starts

Discussion in 'RACE 07 - Official WTCC Game' started by Nigel Atkins, Nov 11, 2008.

  1. Wheel - G25
    Game - rFactor & EVO
    OS - Vista 64

    Ok last night i was adjusting FFB settings in windows and in rF, when suddenly i had no FFB or any resistance on my wheel.
    I closed down rF and unplugged/reconnected my wheel and FFB was back, but as soon as i start a game (at the opening screens) all the FFB and resistance goes from my wheel.
    I`ve tried reinstalling Logitec drivers but its still the same. & tried it in a different usb port.

    Thanks Nigel
  2. Paulo Ribeiro

    Paulo Ribeiro
    Animals and Racing Lover

    Hi Nigel, don´t know if this will help, but try to go to your controler settings,
    choose the forcefeedback settings, and then click on the litlle arrow (left or right one) beside forcefeedback option, just turn it off and on again. Back to the track
    and see if it worked.
  3. Agreed on this ... and what I said in chat if ya bothered to stick around after askin m8 :p :laugh:

    I get it occasionally with Evo ... prolly got itself reversed somehow - sometimes I have to come right back out of in-game controller settings and then go back in again after en- or disabling ffb.

    Let us know if it works ... :kiss:
  4. yea, i get this in both games occassionally.... leave the game running, rip out the usb cable... wait for the plink... plug it back in and go to the controller test screen in the relevant game and press pedals/turn wheel to wake it up again... works eva-ree-time.... :thumb:
  5. thanks Prib & Lee, but its still the same :(

    i`m thinking because its affecting both games, then its a windows problem?

    how can i completely remove the Logitec drivers and regestry?

    cause at the moment if i uninstal the drivers then reboot reinstal windows still remembers my FFB settings.
  6. woop woop huge thanks m8 :worship:

    sorted :good::handshake:
  7. I was having similar problems, sometimes for no reason would loose ffb resistance, not completely just a really fast wheel with no friction, it used to happen at least once per session in evo, but after playing with the ffb in the .plr file it seems to have stopped. maybe you could try changing a few settings in that file, might help.
  8. ok now i`m realy screwd :(

    after getting FFb by unplugging my wheel while in game, i noticed it cut the connection to my usb headset.

    so i tried a system restore, which fixed my FFB i could start up games and FFB was still there.

    then i tried to run logitec profiler and it didnt work, so i reinstalled the logitec drivers. which just made things worse now i have no FFB at all.

    i did a second system restore and wheel was ok in game but no FFB only resistance on wheel. so i had to try the logitec drivers again. which has resulted in no FFb or resistance on my wheel.

    so it seems to be a driver/windows regestry problem.

    any body got any ideas please

    thanks Nigel :)
  9. which version of drivers do you use and do you have a persistent profile setup with the profiler
  10. 5.02 & not sure what you mean by persistent profile setup ;)
  11. I had the same problem using the latest version of the profiler software. I uninstalled that and made a clean install from the cd that comes with the wheel and it was gone.
    Also i heard that sometimes just closing the profiler software is enough. ( it will still use the software but wont cut your ffb)
    Good luck :)
    Edit: Can you remember that it was all the time ?? if not just put you windows back with restore to the date that it was working fine .
  12. yep that worked a minute ago, but as soon as i go near windows controler settings or the game settings all resistance goes.

    i`ll dig my disc out and try that

  13. It was a while ago that i had that problem and i solved it with the restore point. I had to digg deep in my dusty brain :)
  14. Sent this to you by MSN too m8 but might help to post here too in case it works:

    Try this:

    Unplug the wheel, roll back to save point from prior to problem, uninstall logitech profiler (if it is still installed at this point), then run the logitech clear calibration utility, install logitech profiler, only when asked to do so plug the wheel back in.

    If that doesn't work, leave the wheel plugged in uninstall the profiler, run clear calibration util, then re-install profiler.

    ... seems there is an issue if you plug the wheel in but the profiler is not working properly (windows trying to be too clever and assigning stuff itself??)

    Latest Wingman Gaming Software
    Clear calibration util

    If all else fails, you might wanna rip out the registry values from here:
    HKEY_CURRENT_USER\System\CurrentControlSet\Control \MediaProperties\PrivateProperties\Joystick\OEM

    BUYER BEWARE ... editing registry is dangerous, you mess it up, its your fault :p
  15. thx Lee but its still the same :(
  16. You deleted the registry keys mentioned??
    (would suggest either backing up your registry/exporting 'em first or creating a new system restore point prior to fiddling with these)

    If all else fails - get on to logitech and see what they say - might even be a fault with the wheel??

    A way of testing this could be to check it on a mate's machine?
  17. i backedup my regestry, but after uninstalling the drivers and running the clrcalib tool the enteries were gone anyway.

    am just digging through my old invoices to find out when i got it, although i`m sure it more than 1 yr :(
  18. I'm sure with logitech you get longer than 1 year
  19. G25 has 2 year warranty :)

    I :inlove: Logitech :)
  20. Warren Dawes

    Warren Dawes
    Premium Member

    Actually they changed to a 1 yr warranty now I think.
    I had problems with my first G25 and they replaced it with a new one. However, I noticed on the new box that the warranty was reduced to 1 year now.
    Check the box to see which one you have.