1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error importing SketchUp object into BTB XPacker

Discussion in 'Bob's Track Builder' started by senna4ever, Jan 4, 2010.

  1. I am building a 15km street course through the streets of Buenos Aires, Argentina for which i need a lot of specially designed buildings that I found already built in SketchUp, in the Google 3D archives.

    I tried downloading the *.kmz files, renaming the extension to *.zip, extracting the folders and importing the *.dae file into BTB's XPacker, and also downloading the Collada *.dae file directly from Google and importing into the XPacker.
    Both ways I get this error from the XPacker:

    TODO: mesh parts have different vertex buffer definition

    If someone can please explain what this means and how to fix it so i can import them into BTB. Without these buildings there's no sense in building the track :boohoo:

    Thank you
  2. HI, I did the same long time ago, but i export from Sketch in 3ds format, and worked ok, remember to transform the photo files to power of 2.

  3. Yes, I did everything as the tutorial says, 1 or 2 models made it in, but for the others, when I try to add them to the Xpacker I get that error that I posted.
  4. You can export to 3ds with the pro version if nothing else works. You’re granted 8 hours unlimited use. SU6 doesn’t always work for me either.
  5. I've had the same issue downloading the KMZ sketchup files, but what fixed that part was downloading the Sketchup 6 file, exporting again to KMZ - that solved it and i can now open in Xpacker. HOWEVER, every single texture shows "invalid height and width" and the tutorial doesnt say what to do in this case. I have 96 invalid textures in one...

    Help? :)

    EDIT: further testing, a smaller model, textures ok, zipped to BTB. It shows up as an xpack, but the icon is just a text saying ' default icon, please replace' and clicking it does nothing
  6. Unfortunately many Sketchup Objects are poorly made or poorly converted.
    Its possible that the error is caused by these problems.
    Can you post the object in .dae or .3ds & it's textures & I can take a look?
  7. The icon is designed to be replaced as it says.
    You need to bring the object into BTB, take a snapshot of it,
    resize it & then replace the icon in the xpack with your new one.
  8. I'd have to use like 20 different of these landmark buildings from Buenos Aires, this is just one of them, it's the building of Congress.

  9. This file is probably too complicated for xpacker.
    It has more than 10,000 faces which will destroy your in game frame rates anyway.
    Unfortunately not all sketchup models will be suitable for gaming requirements.
    There is no easy way to make these models suitable.
    Sorry :(

  10. Frame rates aside, would it be possible to import them anyway?
  11. I see where your going, you really need these buildings in your track and your heart is set on it. But unfortunately, you are going to have to accept that it is not worth the effort.

    You can easily make the models yourself. In the time it has taken you to query this issue you could have, made a whole street full of models :)

    All you need to do is find some pictures of the building and make textures out of them, then in sketch up make a few boxes and a dome, put it all together and map the textures and that's it, your all done ;)
  12. I was afraid that this would be the answer. Thanks a lot.
    i'll try to see if I can make the buildings myself with a simpler mesh structure.
  13. If you can get xpacker to accept the file then I can see no reason why not.
    senna4ever was getting an error in xpacker so this particular file I don't think will work unless some optimising is done to it to reduce it's complexity
  14. I have managed to get one gigantic building into BTB, but BTB is now so slow its unusable, i shudder to think how rFactor would handle it with just ONE building like that. The xpack zip file is 8mb, so i wonder if shrinking the textures might help. Some of them are massive. Might give it a shot and report back! :)

    EDIT: It worked! Shrunk the image files : PNG and JPG down to 20%, in BTB now and running smoothly
  15. OMG! I envy u so much!!! LOL

    I need a total of 75 buildings, the funny thing is that according to Google, 99% of these objects are of "simple" complexity and the zip files weight less than 500kb each.

    Could you briefly explain to me how did you shrink the images and if you could post the link to the object in Google Earth so I can take a look at it????
    Thank you!
  16. Here's what i tested it with: http://sketchup.google.com/3dwarehouse/details?mid=6d84529598d1b745fc15c85769a35bc2&prevstart=0

    I downloaded the Sketchup 6 version, opened it and exported it to KMZ. Funny, downloading the KMZ itself wouldnt work, but that did. Then after the rename to .zip, i used irfanview to batch convert the images folder sizes down to 20% of their original, reducing the xpack from 8mb down to 2mb. It still looks pretty good in BTB.
  17. Where did you get the SketchUp 6 downloader??? Everything I find is SketchUp 7...
  18. Well it turns out this didnt work when i exported it to rFactor. I get an error about 'cant load texture road85' (or something similar) and kicks back to the desktop. Once i removed the building it loaded no problem. Not sure what the exact issue is :(