1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AGGHH! Transparancies Textures on Objects problem :(

Discussion in 'Bob's Track Builder' started by ed_jza80, Jun 20, 2010.

  1. This is driving me nuts!...

    Im not a genius at model building, but im not an idiot either. so far ive made a few simple models in sketchup, all painted in simple solid jpg textures, then exported/kmz/zip/xpacker into BTB with no problems. easy!

    so, now i decide to get fancy, and try making simple objects like crowds etc, using transparent images with alpha channels to texture the objects in sketchup, then export/kmz/zip/xpacker and into BTB where the objects look perfect, exactly as planned.

    THEN comes export from BTB to rfactor, and all goes to crap!

    in rfactor (and 3dsimed) the textures for these new objects are randomly replaced with some other texture from some other object in the track.

    so far ive tried using everything from GIF/PNG/TGA as the image source (with alpha channels, all correct 512/256 etc sizing) before building the objects in sketchup. ive tried xpacking them individually, with different names, together, bundled with some other xpack i already had there, etc etc. bascially tried a bunch of different ways to see if importing the objects into BTB would make any difference. NOPE! lol

    so, any suggestions? i dont quite get whats going on. the materials are correctly defined in the xpack xml files, and BTB puts it all together correctly, i cant think where its then going wrong when exporting?? 3dsimed shows the same incorrect textures, so its not something just on therfactor side of things.

    see attached pic and note obviously incorrect textures, which in this instance, are infact a texture from a house window on another object, from another xpack??!! other objects have similarly incorrect textures, from yet other models, such as a wall from my bridge... WTF!?! lol :)


    Attached Files:

  2. and just to add, if i put, say the raw PNG file as a texture applied to an existing material (from within BTB materials menu) and then apply that material to a wall... no problems.

    so what am i doning wrong with my objects?? :confused:


    pic below of PNG image directly applied to a material via BTB and assigned to a wall.

    Attached Files:

  3. The texture should not the problem, unless it is a tex with multiple images on it, and if that's the case the mipmaps could cause an issue. the dark ones could be a normals issue, you can set them to up normals.

    Its hard to get an idea on what's going on here with just pictures, can you zip up the gmt's and the texture's and post them so I or someone can have a look at them? Filefront is a good place to host files.
  4. Hello!
    very intresting this problem.
    I also have the same problem in GTL and GTR2.
    In BTB all looks fine, but the export is corrupted!?
  5. This looks like a uvw mapping problem, mapchannel problem or wrong texture file definition (maybe file was rewrite for 8.3 file regulation).
  6. Lamda has a good point... make sure you're using 8.3 filenames for the textures.
  7. yeah, er, what?? :)
  8. noone managed to have a look at the files above?

    and, yeah, 8.3 protocol explanation outstanding? :)

  9. 8.3 file names - 8 characters for the name, a fullstop, then the file extension, eg FILENAME.TXT
    from what i can tell, the 3ds format from 3dStudio Max only exports textures with (and re-names to) 8.3 format
  10. thanks

    sounds dumb but i had NO IDEA what that was rferring to :)

    ill try something and check back :)

  11. well, that didnt exactly work... :(

    ok, i assume pepole are talking about the texture filename that sketchup exports out? ie, i have a simple object with a single texture, starts off life as say 'cameraman.png' and when i export it out of sketchup as a kmz it gets renamed to 'texture0.png' assigned to 'material0'. correct?

    so pepole are saying that 'texture0.png' is not 8.3 compliant due to 9 symbols before the period?

    ok, so i went and renamed the 'texture0.png' to just 'texture.png' and also altered the material xml file to point o the new .png filename

    still came up in BTB just fine, but again, when exporting, it just adaopted another texture from some other object (but a different texture this time!)

    any ideas?

    someone possibly have a look at the files ive uploaded there?

  12. Kyle Puttifer

    Kyle Puttifer
    @ Simberia @Simberia

    texture0 is 8 characters...

    I can't help with the Sketchup part, as I've only just started with it myself. But I can help with counting characters in a filename. :wink:
  13. if you dont know where i am cus iam in finland atm and dont hawe acces to skype, home on monday....

    ok i could post that in a pm.............

    keep up the work!
  14. blagh, i am retarded. and cannot count

    regardless, changing the file name did SFA to my problems! lol...


    (ps, if anyone wants tips on how to look like a complete amateur on a forum, PM me for details!)
  15. lol, sorry, I will have a look at it soon, I have been real busy this last week.
  16. cheers mate

    fwiw i tried making ANOTHER .png based object again, and yet again on export it stole another objects texture.

    so i went and deleted that object (whose texture was being stolen) and lo and behold it stole a texture froma different object this time

    now i also went and made a dummy track with NOTHING on it, just road and terrain, and the object shows up fine there??


  17. I see the texture is half on, half off and not mapped directly onto the mesh. See first pic. Second pic is fixed and mapped properly.

    Try this fix first and see what happens.
    I changed 2 things, first I remapped the texture and second I gave it an individual material name.

    What you must do here is change the entry in the scn file.
    Open your tracks scn in notepad and search for obj_1184, you will find 2 entries, one will be the instance the other will be the meshfile. Change them both to fmarsh so it looks like this.
    MeshFile=fmarsh.gmt etc=blahh etc=blahh

    then dump fmarsh.gmt into the track folder and fire it up.

    This is just the process of elimination, it might not fix it yet.

    Attached Files:

  18. thanks
    ill try that now.

    and yeah, i know the images wasnt on there properly. i got annoyed playing with it 500 times and was at the stage of 'stick an image on it and just try it'