• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

WorldScene:ReserveRenderBlock

Discussion in 'Racer Problems & Fixes' started by Alexander Knoll, Aug 31, 2011.

  1. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Messages:
    1,417
    Ratings:
    +286
    Hi all,
    can some one help me with this Qlog?

    Code:
    (WARN): [racer/3824] WorldScene:ReserveRenderBlock(); out of render blocks (max=3000)
    THX!
     
  2. boomer541

    boomer541

    Messages:
    1,350
    Ratings:
    +165
    What track/car and sytem info? That's a new one I haven't seen before!
     
  3. Some1

    Some1

    Messages:
    571
    Ratings:
    +259
    Perhaps your track is too big?
     
  4. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Messages:
    1,417
    Ratings:
    +286
    hmm...not realy....less 2k models and not bigger than 2x2km...~500 shaders...
     
  5. Mr Whippy

    Mr Whippy

    Messages:
    2,989
    Ratings:
    +461
    500 shaders sounds like a lot...

    Shouldn't be too many of course. Why not give all objects one shader/texture and see if it works?

    Try single out if it's shaders related or geometry related... hmmmm...

    Dave
     
  6. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Messages:
    1,417
    Ratings:
    +286
    Dave, 500 shaders is nothing^^ The Nürburgring have ~1k+ ^^ and 2k+ models and works well....but i will try it, THX!
     
  7. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Messages:
    1,417
    Ratings:
    +286
    Hi Bob, it doesent matter witch car...it change nothing... the track is a conversion i'm working on...
    I had this QLog with the Nürburgring too, but there where ~3k+ models....^^ and after i reduced it to less 3k it was gone...but with this track it don't work...:(
     
  8. boomer541

    boomer541

    Messages:
    1,350
    Ratings:
    +165
    Could be a problem with the conversion, I've never tried to convert a car/track so it could be dificult to track down.
     
  9. MitchVL

    MitchVL

    Messages:
    150
    Ratings:
    +0
    You have too many visible nodes in your frustum.
    Each render loop Racer will throw all nodes in a list and render them out.

    Make better use of LOD'ing !
     
  10. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Messages:
    1,417
    Ratings:
    +286
    THX Mitch...
    i know i should use LOD's, Dave give me this hint some time agoo...but i'm not verry good with it...