1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Windows 7 when connecting G25 Wheel

Discussion in 'RACE 07 - Official WTCC Game' started by Andreas Lündin, May 16, 2009.

  1. Hi!
    I bought a G25 Wheel to use in my system:
    AMD Phenom 9850
    NVIDIA GeForce GTX 260
    Sounblaster X-Fi
    4GB RAm
    Lots and lots of HD
    Razer Diamondback
    Saitek Eclipse

    Ive got a dualboot system: Windows 7 and Windows XP Pro

    The wheel works flawless in XP but there was some problems installing it in windows 7 (known problem) that I solved.

    Now, the only problem remaining is that GTRE/RACE 07/STCC wont start when the wheel is connected... It hangs with a black screen just before going to the main menu. Got to ctrl-alt- del and start task manager Wich report that GTRE has stopped responding. Ive also tried starting it without the wheel and plugging it in later but as soon as i connect the wheel the game hangs (stops responding).
    Any advice?
     
  2. It worked fine here on build 7000 32bit and now on RC 64-bit. Did you install the latest Logitech Gaming Software V5.04?
     
  3. Yes.
    Maybe ill simply have to reinstall.. either game or win7 (RC this time...) This was what i did not want to do... its soooo boring and timeconsuming...
    Now im trying out different USB-ports... Will report later.
     
  4. Tried to reinstall race07 and all mods, no change. Changed around with USB.ports, no change. Maybe its logitechs drivers or something else that conflicts with something... I dunno.
     
  5. This is a long shot, but I had a few issues when the G25 H-shifter was in gear. Other than that, it works perfect in most versions of the W7 up to an including RC1. Hope you get it sorted.
     
  6. Installed Win7 RC. Hard work of course but now everything is ok. Case closed.
     
  7. Hi all,


    I also had the same problem as you (black screen).

    When I installed Steam, I used the compatibility mode "vista." And the launch of Steam, I remember having a window indicating that I should not run the program with compatibility mode.
    I installed windows 7 RC just to try so I did not search solutions to this problem.
     

  8. I solved this problem.En fact,when installing Steam,you should not use the compatibility mode.