1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

win7: no visible GUI for tracked or modeler

Discussion in 'Racer' started by luthobu, Jan 31, 2010.

  1. After installing win7 on my computer, I cannot seem to use neither tracked or modeler. They start, but I only get a black area where the buttons used to be.. seems like the GUI libs are missing but I know I have them installed.. maybe they are not 64-bit compatible? Anyone know?
     
  2. I've mentioned this before, but apparently they work perfectly.
     
  3. Huh.. ok.. but tracks do not load in tracked, or rather, they look like colorcharts if they even load at all. Is Ruud aware of this perchance?

    EDIT: Screenshots in Racer turn up black as well. Racer v.0.8.8.1, Windows7 Pro. 64-bit.
     
  4. Send a bug report to Racer's bugs email? you never know, it might get something done for you :)

    Can't help with Win 7 (I'm still on XP Pro, reluctant to buy another MS product after Vista..), but everything worked fine on Ubuntu 64 bit, so surely it should do on 64 bit windows?
     
  5. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    hi,
    i'm on win7 x64 too, but for me works all fine....with 0.8.8.1, with the 0.8.7 and the 0.8.8 i had the same problems but all fixed with the patch....
     
  6. What patch? The patch I dl'ed was the 0.8.8.1 exe only, no tracked or modeler.. link please? :)
     
  7. Windows 7 is the mother****ing ****.

    I'd seriously considered Linux after Vista. Not anymore.
     
  8. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    the patch is the exe only....
    The problems from tracked etc... where fixed with the 0.8.8 release........for me.......
     
  9. hm. tried several options. no go. can't really do anything without those apps.. Ruud? Help? ;)
     
  10. A while ago we reported to Ruud that Racer's support applications aren't displayed correctly under Win 7 64-bit with Aero enabled, as there was an obvious issue with the window order hiding input boxes. It turned out to be related to ordering problems with multiple OpenGL windows running simultaneously (ie. pacejka.exe counts as one, the pacejka graph, the input pop ups...). It worked fine when Aero was disabled though. Ruud found a solution that fixed that, at least for me running with Aero on, but it seems this is a case of one step forward one step back. If you can, try to enable Aero to see if it works at all - if that's not an option I suggest contacting Ruud again to let him know.
     
  11. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    hmm...i have Aero enabled and all works fine....
     
  12. Well.. it's been a week since the last reply.. so I guess no one has any suggestions? I use both modeler and tracked alot, so if this is not resolved I really don't feel like doing any modelling.. it is just a pain to work without them.. the way I work at least..

    PS: Maybe there is a workaround? VirualPC or something? Anything? Please? :tongue:
     
  13. Did you try running them with Aero enabled, as suggested in my previous post? It works here, it works for Dream Factory and it works for Ruud as well, after all.
     
  14. So I did, and also I now have aero enabled permanently. I am installing Virtualbox and XP so I at least can get something done until I figure out what is wrong. Thanks for replying anyway. Really apprectiate it. :)
     
  15. You can always use tracked and modeler from a previous version if you still have them around.
     
  16. Indeed a very good thought, but.. both 0.7x and 0.6x seem to have the same problem. They seem to use some Qlib (readable in the upper left corner of modeler and tracked) - might I be missing the qlib that renders the buttons and UI (just a shot in the dark) or is it statically linked? I can see the blue area in modeler, but the rest is black..

    EDIT: Installed Enterprise Edition from scratch (and yeah.. no backup..) and the problem remains..
     
  17. I'll zip up a couple of files and send them to you to try.
     
  18. After trying to run these apps on several DELL computers I have come to the conclusion that the problem must be related to the computers configuration, i.e. DELL with onboard Intel graphics chips. The outcome on all these computers (tested at the University) show the same results: black background, no buttons.
     
  19. It's the intel graphics that I think is the problem. My wife's computer is a $299 Dell with onboard intel graphics and it does have rhat problem with tracked.
     
  20. @boomer541: Thank you very much for verifying.