• Blurring the line between real and virtual motorsports
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why does my Fanatec Porsche Turbo S wheel constantly have 'spikes' in its shaking?

Discussion in 'rFactor' started by Greg Pugliese, Jan 28, 2010.

  1. This is driving me nuts, and I've spent the past week trying to figure out what's going on.

    Using my Fanatec Porsche Turbo S wheel in rFactor, no matter which mod I use - Enduracers, ILMS, etc. - and which FFB I use - RealFeel, rFactor default, the new 'FeelsReal' - and which FFB settings I use - Low, Medium, High, Full - and no matter how many FFB parameters in Controller.ini I drop to zero - steering shake, braking shake, etc. - I can never, ever get rid of an extremely annoying shaking of the wheel that begins from the second I enter the garage. It occurs mostly around the center position. It's a strange "spiking" behavior that throws the wheel left or right very quickly, making it difficult to accurately control the car. I don't see this kind of behavior in any other racing sim/game ... and it seems to happen in every single car I drive in rFactor.

    Has anybody else experienced this? What about those with other kinds of wheels? Do you get a never-ending and random "spiking" of jolts about the center position? Is there any way to get rid of it?
  2. What ffb strength do you have it on ingame? (- or a +)

    If you have Real Feel enabled (Open up the .ini file and change the strength to a - if it's on a +. Vice versa)

    This should solve your real feel
  3. I have that shaking when i have FF effects on full. When i turn it down to high it's gone. :)
  4. I've tried every strength - from 0 (where everything goes away, obviously) right up to 100. Actually I have to use negative strengths, as apparently the Fanatec wheel has the same issue as the G25, where positive numbers make the wheel pull in the wrong direction. Oddly, while the normal FFB does scale with this number, the spikes I'm talking about seem to be almost constant in magnitude regardless of what strength I choose.

    Ivo, you've got a DFGT, right? I'm starting to wonder whether this is a problem specifically with the Fanatec wheel. Even on "low" effects, I still get this spiking, which just doesn't make any sense if I understand correctly that "low" should mean only tire grip and steering force are being simulated, without any extra vibrations.
  5. True. Low gives you only that. :)
    Yeah i have the DFGT. But i don't think it is a problem with the Fanatec wheel, because i didn't heard somebody about it before.
    Wich upgrade do you have installed at the verhicle upgrade section?
  6. It seems to happen no matter what upgrade I choose: for the Enduracers cars, when using RealFeel I choose the RealFeel Mult 0 upgrade; when not using RealFeel, I've tried Mult of 1 through 5. They do seem to lower the overall strength of the normal FFB (as they should, right? I guess I don't understand what effect this setting has that is different from the overall "FFB Strength" setting) but still the spiking remains of pretty consistent magnitude.

    The spiking also occurs even when I'm just sitting in the garage not doing anything. I believe it even occurs when I turn the engine off!

    A related question is: I don't understand the way total FFB gets determined for any specific vehicle and in-game settings choice. For example: using the Enduracer Porsche 997, in the .vdh file there is a line in the [CONTROLS] section that reads:

    SteeringFFBMult=4.0 // vehicle-specific multiplier by steering force feedback

    But they then suggest that with RealFeel you choose the "Real Feel (Mult 0)" upgrade. If I don't use RealFeel, what effect does then choosing, for example, the Mult 2 upgrade, have? Does that somehow combine with the .vdh file line above to yield a resultant FFB mult that is a combination of the two?

    And then how does FFB strength affect that?

    Confusing stuff. :)
  7. Have you tried changing your Real Feel ini?
  8. I haven't, no ... I suppose I should maybe play with the "SmoothingLevel" setting - will try that tonight. But I get this spiking/shaking even when I completely remove RealFeel altogether, i.e. delete the .ini and the plugin, so I don't think it's related to RealFeel.
  9. Bram

    Administrator Staff Member Premium Member

    What did Fanatec say about this problem?
  10. I haven't tried to contact them about it, but after searching through their own forum, I found a possible culprit: their drivers ask you to drop a "PorscheWheelPlugin.dll" into rFactor's Plugins directory, which I did, and apparently one of the things it does is simulate rumble due to the engine; a bunch of people have also found the effect to be way too strong, even when just sitting in the garage - sounds exactly like what I'm experiencing. Removing that dll seems to solve it. Will be trying that as soon as I get home tonight.
  11. Bram

    Administrator Staff Member Premium Member

    Ah great :) Thanks for posting that possible solution, please let us know if it worked for you.
  12. Woo-hoo! YES, that solved it! Man, I have been banging my head against the wall for a WEEK trying to get this thing resolved. Looking back on it, it should have been so obvious ... what could possibly cause a problem ONLY in rFactor, and be completely independent of any in-game settings? Of course it has to be a driver-related thing, and I'd totally forgotten about that plugin.

    I just did some laps in the Enduracers 997, and the for FIRST time, I don't have to fight the damn thing all the way around the track!

    So let this be a warning to all Fanatec wheel owners: avoid that plugin at all costs.
  13. Great news. :)
  14. Bram

    Administrator Staff Member Premium Member

    Glad you got it solved!!
  15. I've been wondering what has caused this for weeks now, can't wait to get home and remove that plugin!!
  16. Yes, it makes a HUGE difference, and actually makes controlling the cars manageable now. :)
  17. My solution was to enter a race, restart the wheel, then change the ffb % in the game and it worked. This will make a huge difference, thanks.