1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Why do i have to load my control set every time?

Discussion in 'Stock Car Extreme' started by Bryan O'Connor, Aug 23, 2014.

  1. Why oh why oh why do i have to load my control set everytime i load the game?
    Why does the wheel rotation not line up most of the time?
    Why does the steering range from my default in Logitech Profiler of 540 not get applied to the game most of the time (it loads as 900 meaning it's pretty unplayable)?

    Anyone any idea how i fix these issues permanently or it's getting deleted. I don't have time to piss around with the Profiler/Game Options/Resetting my PC - just to race!
     
  2. Jeff Huber

    Jeff Huber
    Premium Member

    Hmm? I'm not sure. I think it is something on your end. I use an old DFGT and it sticks with the same settings every time I open the game. I have two separate installs ( one on F drive , one on G drive ) and both have like 4 - 5 mods installed as well. Never had a steering wheel / settings problem. I'll tell ya what though....if I " had to " adjust my wheel for about 1 minute before every time I got to race in GSCE.....it would still be worth it! Love this sim! Good luck man , and I'm sure someone with a lot more knowledge will come along and help you out.
     
    • Agree Agree x 2
    • Like Like x 1
  3. Paul Bennett

    Paul Bennett
    Premium Member

    In game controls set to 540 & in folder userdata\yourname or in the controller config file
    Were it says, Steering Wheel Range=" " // Degrees of rotation of in-game steering wheel. Type 540 in the space between quote makes save the file on exit and it will keep your wheel settings
     
    Last edited: Aug 23, 2014
  4. Thanks Paul but my config file already has these as 540. :(
     
  5. Paul Bennett

    Paul Bennett
    Premium Member

    I have two config files. The main controller folder will have list of all preset controllers and the one showing you name will have one as well. Are you using a preset for the wheel G27 ect, or your own custom settings ?
     
  6. Nox

    Nox
    Staff Premium Member

    Definitely something unusual with your install or wheel, I've had zero problems such as those you are describing. Don't give in though, this sim is absolutely worth the hassle you are going through, trust me.
     
    • Agree Agree x 3
  7. Emerson Meyer

    Emerson Meyer
    Keep Fighting Premium Member

    Bryan, I have a G27...zero problems.

    Do you have the latest Logitech drivers? Have you tried a fresh install of your wheel?
     
  8. Christian Militzer

    Christian Militzer
    Premium Member

    Try setting your global profiler settings (not the game specific ones) to 540. I (and a few other people) had the issue, that the profiler would reset the rotation to the global setting (900 is standard I think) at a random time in the game, which is gamebreaking. Maybe your problem is related to this. I had no further problems with wheel rotation when setting the global setting to 540 degrees.
     
  9. Paul Bennett

    Paul Bennett
    Premium Member

    Is the controller selected when in game "controls screen" mine does n't by default, use < > to select your wheel
     
  10. OK..... deleted the Logitech profile and created a new one. Had a couple of hours on it last night and all was fine.
    Could it be the Updates are somehow messing with the Logi Profiler? I have only had the game for a few weeks and had two big updates recently.
    Will keep an eye on things.

    Oh and yes..... i know this game is great, if it wasnt i would just bin it when it's not going right.... ala NFS Shift :D

    Thanks for all the help guys.
     
  11. Paul Bennett

    Paul Bennett
    Premium Member

    Good to see your sorted Bryan, get some rubber down on track and join the club for some racing :)
     
    • Agree Agree x 1
  12. Something else i have noticed it does...... if i am doing a Championship, between races it will go from 540 to 900 without me doing anything.
    I only notice when i go to leave the pits and crash into pit wall :roflmao:

    No amount of playing with in-game options fixes it. I have to quit the game, close Logi Profiler, load it again, re-select GSCE profile then re-start the game through the Profiler.

    Getting annoying to say the least :cautious:
     
  13. Christian Militzer

    Christian Militzer
    Premium Member

    As mentioned earlier, try setting your global profiler settings to the settings you use for GSC, especially the wheel rotation. It happened to me and some other people, that the game suddenly "looses" the wheel settings and loads the global settings. This happened to me at random moments in the race which was no fun :D Maybe you have the same problem! But strange that it happens when you crash in the pit wall :roflmao:
     
    • Agree Agree x 1
  14. Just to let you know. The steering range in-game that you adjust to 540 degrees, or 900, or whatever, is, I believe, an in-game way of adjusting the following parameter of any of your controller.ini files:

    "Steering Wheel Range="xxx" // Degrees of rotation of in-game steering wheel"

    If that is the case, then all it is adjusting is how much the in-game steering wheel GRAPHICALLY moves. Just the rotation of the graphics of the in-game steering wheel. Doesn't affect physics and/or FFB one bit. It's purely graphical for seeing your wheel on replays, and during gameplay if you even use a moving & visible in-game steering wheel during gameplay.

    To adjust actual physics / FFB lock you adjust the steering lock in the garage menu.
     
  15. Paul Bennett

    Paul Bennett
    Premium Member

    Bryan did you change the steering settings in the control.ini files ? you will need to save the changes which you entered. The Logitech profile should also be saving these settings, I use the DFGT wheel and some times it dose go loose and just re-plug to fix. If you've followed these steps you should not have any issues with this :confused:
     
  16. I just spent about 90 minutes trying to fix this problem until I realized that I'd accidentally turned steering assist (F1) on low. :cool:
     
    • Haha Haha x 1
  17. same issue here (I posted a new thread before realizing this was here, asked the mods to delete the other)

    I have recently reinstalled GSC after not playing for a while and I am having a lot of trouble getting the settings I make in the controls screen to 'stick'. I can change things like ffb type, degrees of the wheel or assignments of the controls, save them (whether a new name or same name) and it seems 50% of the time if I quit and re-enter I have the same controls as before I made any changes, argh!

    I see the new .ini get created with the profile name I choose (I installed in C:\games so it's not a program files permission thing) but for some reason sometimes the file gets created but when I get in game I have the 'old' controls, if I 'load' the profile I saved before things were in fact saved, but somehow sometimes when loading they aren't there anymore automatically.

    Any ideas about what could be going wrong? Currently it *seems* that if I save to a new profile, exit, restart, load the new profile, exit again, restart, it most of the time 'sticks' but it is quite annoying to have to do this all the time I want to reassign something.
     
  18. I have resorted to starting the game through Logitech profiler. Only way it seems to keep the degrees of rotation at 540.
    I have set the default to "me001" as that's where i have mapped the buttons etc. in the profiler and although it's not there on the options screen, when in-game everything is what i want. Just the rotation gets knocked out of kilter if i don't start with the profiler.... It must load something else by default....