1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC wheel not working correctly

Discussion in 'Assetto Corsa' started by Nick Deeley, Nov 15, 2013.

  1. This is more than likely down to my set up.

    Just got a new computer, and have got everything setup and installed. Seeing if I got the wheel settings right at all, and I dont think I have. On my previous system, the wheel and game worked fine without any adjustments.

    Outside the game, wheel seems to work fine, it turns freely and is what i would consider normal.
    Inside the game, in the menus, same thing.
    As soon as I get on track though, the wheel is very heavy, its like the centering spring is set at 500%. There also seems to be a delay in what happens when turning the wheel and also using the pedals.

    G27 wheel and pedals. In the profiler, settings are:

    Overall: 75%
    Spring and dampers on 0%
    Centering spring strength on 10%. Box is currently unticked, but I've tried with it ticked and got the same thing.
    Combined pedals isn't ticked, and 400 degrees of rotation (how i normally have it). Box is ticked to allow the game to adjust settings. Tried it unticked and get the same problem with a very heavy wheel on track.

    I've copied over my previous document settings from the old hard drive for the game itself. I didn't copy the logitech profiler settings, but I'm 90% sure its set up to how it was before.

    I'm also not getting any clutch.

    Any suggestions?
    Last edited: Nov 15, 2013
  2. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

  3. Yeah I have. It's doing the same in rFactor2 as well though. I phoned Logitech earlier today and they're reckon its a wiring fault, so they're going to replace the wheel. Particularly as no game nor the profiler recognises there's a clutch.

    Bit strange though that it's doing it as soon as I get a new system.
  4. if it acts like that with other games then the problem can be:
    . Something wrong with the wheel like Logitech is saying
    . Drivers problem ... be sure you have the right logitech driver installed
    . Motherboard voltage issue on the usb ports (even if they are new) ... i know some wheels malfunction due to voltage problems so try to connect the wheel into a powered usb hub or into a different usb port on the pc ... if it doesnt help just wait for replacement

    It can be something else but those are the ones im aware
  5. I did think the drivers were not installed properly, but I reinstalled them a couple of times without any success. Unless I was not installing the right ones.

    The downloads there I installed. When I plugged it in, the little bubble in the bottom right appeared about installing drivers. No errors on either. Is there a driver I can manually download somewhere?

  6. those drivers are ok ... did you try the powered usb?


    What do you mean by no errors on either? did you install the both drivers 32 bits and 64 bits? you should install only one depending on your windows system
    Last edited: Nov 17, 2013
  7. i mean when setting up the profiler, and when I plugged in the wheel. No errors on either of those.

    Only used the USBs on the PC itself. Not got any external/powered ones (I presume thats what you mean).
  8. I had a similar problem when I tripped over my my pedal cable and snapped the throttle wire, 20 min with a soldering iron and some heat shrink tubing should see you sorted.