1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC Wheel lock option

Discussion in 'Assetto Corsa' started by shardshunt, Dec 26, 2014.

  1. Solved
    Thank you Radu Oros for the help!
    I cannot find the max wheel lock adjuster option within asseto corca can someone help me as my wheel only has 180 deg rotation so the steering is always to sensitive.
    To adjust the wheel lock the value 'scale' has to be changed you can change it with notepad.
    to ajust the setting go to C:\Users\[username]\Documents\Assetto Corsa\cfg and open the file 'controls.ini' then look for the [STEER] section
    first adjust the 'LOCK' setting to match that of your wheel, then change the 'SCALE'. try going round a hairpin with a setting like 0.3 and slowly adjust that number until you can make it (I used 0.6 with my 180 deg wheel). you can alter the 'STEER_GAMMA' to a number above 1 in order to help driving in a straight line.
    don't forget to change your virtual steering wheel lock ingame under view to make your wheel match the in game one.
    Here are my settings for my 'Logitech Driving force EX' 180 deg wheel.
    Code:
    [STEER]
    JOY=0
    AXLE=0
    SCALE=0.6
    LOCK=180
    STEER_GAMMA=1.5
    STEER_FILTER=0
    SPEED_SENSITIVITY=0
    
     
    Last edited: Dec 26, 2014
  2. Steering, top right

    [​IMG]

    If your wheel has physically only 180° of steering, then increase the value above heavilly.
     
  3. I have a DFGT wheel and in logitechs profiler i set wheel rotation to 900 degrees
    Then in AC controller options it might be an idea to run the wizard when you turn the wheel in this it will set your degree of rotation.
     
  4. I tried both ends of the spectrum but it didn't change any thing
    my wheel is a Driving force ex
    in other games such as pcars, raceroom and rfactor 2... the setting is known as 'wheel lock' and it changes the physical max limit that the wheels can be turned and i cant find it in ac but it must be somewhere cause its in every other sim.
     
    Last edited: Dec 26, 2014
  5. Just looked it up, your wheel has physically only 180° of steering - this is preventing you from utalizing the normal 900° needed for a realistic steer rotation.
    Nothing to improve unless a change in wheel unfortunately.
     
    Last edited: Dec 26, 2014
  6. its strange that ac doesn't have basic option present in all other sims ether under car options or general setup i understand not having adjustable wheel lock in a road car but in a race car a team can adjust something like this
     
  7. try wheel gamma to 1.00 and steering rotation to 180°
    You should at least get a 1:1 ratio then
     
  8. thanks for trying but it looks like the option is just not present in ac. if i adjust gamma the steering is only 1:1 when the wheel is not being turned as i turn the wheel the ratio grows until the animation cant keep up
     
  9. video options - view - virtual steering. Put it at 90º (degrees for each side of the physical wheel lock).
     
  10. that doesn't change sensitivity it just changes the animation.
     
  11. since your wheel is 180º, put 180 in controls page and 90 in virtual steering. It will still be more sensitive than 900º. Then keep 1 for gamma, and 0 for filter and 0 for speed sensitivity.

    In C:\Users\QUF\Documents\Assetto Corsa\cfg controls under [STEER] you have scale and lock. Lock is the same as steering degrees number from controls page. After my suggestion from first sentence, you could try 180 / 900 = 0.2 and put that into Scale. Now I think lock should be 900 or 180 after that calculation, try both. Then about virtual steering, use either 0 or 90.
     
    • Like Like x 1
  12. thank you changing the scale helped a lot here are my new settings for my wheel
    Code:
    [STEER]
    JOY=0
    AXLE=0
    SCALE=0.6
    LOCK=180
    STEER_GAMMA=1.5
    STEER_FILTER=0
    SPEED_SENSITIVITY=0
    
    I changed the scale up from 0.2 because i needed more sensitivity to make tight hairpins so i also had to change the gamma to account for that but i have it at a stage where i am comfortable with completing that hillclimb
     
  13. Great you solved your issue, will include the solution in the FAQ ,)
     
    • Like Like x 1