1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Warping AI

Discussion in 'rFactor 2' started by xnorb, Nov 12, 2015.

  1. xnorb

    xnorb
    Premium Member

    Heya,

    so yesterday i took the GT4 Nissan 370Z to a quick race on Montreal.
    All stock content and no 3rd party mods installed.

    AI strength 95%
    AI aggression 25%
    23 AI drivers

    Now what happened during my 5 laps race was that at one point AI cars started warping around as if i was on a server with a bad ping.

    Any ideas?
     
  2. David O'Reilly

    David O'Reilly
    A bad quali means I can go forwards in the race.

    Check you player JSON file.
    It sounds like you may not have multithreading enabled. (not enabled by default and required if you have more than 2 cores).
    This can cause the CPU to overload. To check this press alt C and you will see the purpple bar on screen. If the purple (P for physics, green bar is G for graphics) bar goes over about 80% its too high and if it maxes out you get mini freezes while it drops out of real time. FFB goes light and cars warp and on the replay you will see your car freeze.
    Open player JSON in notepad. Use edit function to search for "sim processor threshold" if it says 255 change it to 3.
    Save.

    I got it bad for fist time in Canada (prob co-incidence) but it continued to other tracks.
     
  3. Correction, search for: Sim Processor Thresh

    Note: I keep it set at 255 (default) as it doesn't appear to make a difference with my rig: AMD Phenom 965 @ 3.4 Ghz, quad core. Purple graph never exceeds 60% with 43 ai on grid.
     
    Last edited: Nov 12, 2015
  4. xnorb

    xnorb
    Premium Member

    Will check it out today.
    Changed the setting just now to 4 and will have a look at the Alt+C graphs.
     
  5. Bez

    Bez
    All the gear, no idea...

    I'm getting this issue, I thought I'd eliminated it yesterday but I'm still getting it on occasion, exactly as you described in the op, as if they are high ping online drivers. I've tried 3 and 255?
     
  6. Without knowing your system specs i would assume that it doesn't meet the recommended requirements and if it does then there is a good possibility of a malfunction in your system or corruption in your rF2 install.
     
  7. Gijs van Elderen

    Gijs van Elderen
    Premium Member

  8. Bez

    Bez
    All the gear, no idea...

    I think my system should be able to handle rf2, i7 CPU with 16gig of ddr3 an ssd drive and gtx 780, I'm not running inspector and its a fresh out the box steam install?
    Edit: I should also add I wasn't getting this issue before moving to steam.
     
    Last edited: Nov 18, 2015
    • Agree Agree x 1
  9. Ok, thanks for letting me know your specs as it's only guess work otherwise. So, you integrated over to Steam and this is exactly why i didn't go with Steam incase of any issues/bugs. I believe the saying "If It's Not Broke". In the future i'll probably be forced to integrate with Steam when they no longer support their Launcher so hopefully by that time everything should be working great on most systems!

    Possibly the Steam Intergration is providing poor results with some systems but the good news is that this will be resolved in an update if this is the case. Hope this happens soon for you and others that had poor results since going with Steam.
     
    Last edited: Nov 18, 2015
    • Like Like x 1
  10. xnorb

    xnorb
    Premium Member

    Had quite some race action going on in the Clios, and it didn't happen there after changing the CPU count to 4.
    Can't check Alt+C tho, as this does nothing for me.
    (Do i need to enable some UI? I drive completely without any UI at the moment)
     
  11. Warren Schembri

    Warren Schembri
    Premium Member

    Its Ctrl+C :)
     
    • Agree Agree x 1
  12. You set “Sim Processor Thresh” to "4" but it needs to be "3". Also, it's "Ctrl+C" and not Alt+C

    Here is ISI's statement: By default, the multithreaded physics are turned off for now. Set the PLR file variable “Sim Processor Thresh” to 3 to turn on, or 255 to turn off (note that we don’t allow them to be turned on for dual cores).
     
    Last edited: Nov 19, 2015
  13. xnorb

    xnorb
    Premium Member

    It also only happened before with the Montreal+Nissan combo.
    Will try today.

    Thought it's the number of cores it will use :D
    Changed it to 3 and will test on Montral+Nissan combo when i come home.
     
  14. xnorb

    xnorb
    Premium Member

    Just had a race under same conditions as before opening that thread and no warping at all. The Ctrl+C overlay seems super useless as i can't read that at all and it doesn't even move (something i would have expected to happen) but no warping, so i'm happy :)
     
  15. jimortality

    jimortality
    Premium Member

    Mt Green line is on full and my purple about 35% is that ok?
     
    • Agree Agree x 1