1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

v0.8.8 on Mac under Wine

Discussion in 'Racer Problems & Fixes' started by Sorbus, Feb 26, 2010.

  1. Hi All,

    Racer loads, shows 3D content in the car selection screen, but can't connect to the local host server when starting a race.

    This is a snippet of the QLOG:

    Fri Feb 26 00:56:15 (WARN): QNClient:Connect(); failed to create enet peer; out of connections
    Fri Feb 26 00:56:19 (ERR): Can't connect to server ''

    Any ideas? I'm quite new to WINE. How do I make sure the app can find the local host?



    PS, nice to find so many familiar faces over here. It's been a while since I was into Racer.
  2. Hi Sorbus, long time no see :smile:. Got your message, I'll try and get into my emails tomorrow (haven't touched that addy for ages now, will see if it's still online :frown:).

    I managed to get 086 working under Wine, but on Linux. Someone (I think it was Bub73) posted some instructions on RSC about installing Racer via Wine on Linux (might help you, even on a Mac?) but alas it's all lost now.
  3. Check your firewall settings first; then on linux I run "sudo xhost +" this gives wine/racer access to the screen and desktop.
    Starting racer form a terminal will give feed back if there is an error, it has to be called correctly under wine on linux I don't know much about a Mac.
    Here is my call for racer under wine on linux, maybe it will help.

    sh -c "cd .wine/drive_c/Program*Files/racer084/&& wine racer.exe" or

    sh -c "cd .wine/drive_c/Program*Files/racer084/Raven/&& wine Raven.exe"
    if you like Raven

  4. Tried it w/o succes


    I've been trying the Mac version of CrossOver Games (Wine app dedicated to games) this week-end without success, and with the same Qlog error described in first post. Using the xhost+ command didn't helped, neither did the sh one : opening racer.exe with Terminal didn't showed me any error report…

    Did someone succeed ?
  5. Can you ping and ping localhost ok?
    Also when/if racer starts see if you can use the lobby function it may give a clue as to what is wrong.

  6. Thanks for the replies!

    Firewall is off. Can launch racer.exe from command line or by double clicking. Same result as before. No feedback in the Terminal nor the Console other than that I've launched wine and racer.exe

    I get "64 bytes from icmp_seq=0 ttl=64 time=0.055 ms" when I ping localhost or

    I can load lobby mode. It's the first time I've used this in Racer, so not quite sure what to do.


  7. when I have LittleSnitch running (a network monitor) it shows that Wine tries to connect to on UDP port 25000

    I even tried adding this to my /private/etc/hosts file with no luck :-(
  8. I don't know if it will help but heres my etc/host file. localhost bub-desktop1

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

  9. Still haven't find a clue to my issues, but it seems cross over v9.0 will be available in a few hours, maybe it solves the compatibility with Racer *hope* :)
  10. Have you configured wine for racer and set the windows version, sound and let it detect all your drives etc ?

    Also have you installed all the required libraries or windows dll's into wine.
    If not just google wine tricks for a script that will make it easy to install them correctly.

  11. Wine on Mac has XP as default. I've installed the Direct 3D dll's using Wine Tricks, and have set the graphic options to a low level in Racer itself. Is there any other way I can check that the dll's are working okay, such as a test program that has similar requirements to Racer?

    Thanks for the help so far!
  12. Have you installed vcredist_x86_vc2008sp1.exe into wine for racer ?

    Also I copied fmodex.dll to my wine system32 folder; you could try setting racer to nosound and test it, sound can cause a lot of trouble under wine sometimes.

  13. Hi,

    Looking deeper into this connection issue, with Ruud's help, we've almost (or kind of) solved the problem (at least on my configuration : Nvidia 9400M and Snow Leopard, MacBook Pro) :
    1. Launch racer.exe, do not select anything in menu
    2. Open racer.ini (in racer's root folder)
    3. Look for the "server=127.0.01" value
    4. Change it for "server=localhost"
    5. Go back to racer, select the menu's "Free driving" or "Quick Racer" entry
    6. Should work now!

    If you don't have anything to change in game settings (car, track, graphic option, etc.), you can change racer.ini file permissions to read only for all users. This will block racer or OS X to re-write the file, and that's what was causing the issue.

    Hope we'll find a more user friendly way to set this, but this trick works fine currently. ;)
  14. Great! Many thanks!

    It works well on my MacBook Pro with 10.5.6

  15. Another thing you can do is to use Raven, un-checking the "Show menu" option (Misc or Display tab, can't remember now), but you still need to set multiplayer.server to localhost in racer.ini
    Using Raven, you don't need to lock the write permissions to your racer.ini file :wink:
  16. Just set that up too. It works like a treat! Thank you :)

    Is the lack of alpha transparency a wider issue, or just my setup?

    Cheers :thumbup:
  17. Great, glad it worked. ;)

    About alpha transparency, as far as I know, it isn't an issue, but something to set right in the graphic options, in racer.ini. Try enable/disable the major graphic features (bloom/motion blur/auto-exposure/etc.), you should be able to find out the right combo! :biggrin:
  18. Should this info go into the Wine app database? It lists such as old version of Racer - I'm sure it would attract more users to the project...