1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unknown Internal error...I have tried everything!!!

Discussion in 'rFactor' started by anthonyl59, May 18, 2011.

  1. I did find the old post about this error and tried everything..but it still gives me this error message.

    Windows 7 64 bit.

    Clean Windows install due to a motherboard and SSD upgrade.

    Have tried to re-install the game several times...every time I have deleted the entire r-factor folder and the trymedia folder as well.

    Have tried to install the complete (full version) and the lite version.

    When I launch the game I get an error message...UNKNOWN INTERNAL ERROR.

    My clock is at the correct setting and have also done an internet clock sync.

    DO NOT HAVE ANY antivirus software running.

    And yes I have tried running as administrator.

    All other games I have installed run fine...

    Please help.


    Tried uninstalling everything r-factor related.....including the r-factor folder and trymedia folders...re-installed game...as soon as I click on the shortcut...UNKNOWN INTERNAL ERROR.

    I tried installing as administrator as well......this is frustrating me no end!!
  2. rFactor exe is set up for Windows XP and older. XP in the C:/(Many Files) has a file called ProgramData. Now though with W7 there are two program files. 1 ProgramData and 1 Program Files. Check to see were rF is in these two files. Trymedia file should be in "ProgramData". rF main directory file should be in "Program Files" If it's not that way just move your rFactor file to Program Files. If it is correct then try this. Create a new file "out side" either of these two file so the path will be C:/NewFile/rFactor You'll need to go into the rF directory and create a new short cut because the path way has change. There's a short cut icon in the directory. Right click on it and create new short cut. You'll need to drag and drop it to your desk top because it will create the new one in the directory.

    If you have a second HD you can put the rFactor directory on that drive if you like. Again you'll need to create a new short cut to that install.

    Try these things and see how you go. Let us know either way what happens.
  3. OK...all files are where they should be...I uninstalled everything and tried to install on a second hard drive in G:Games/r-factor...

    took the shortcut from there and still got the same UNKNOWN INTERNAL ERROR MESSAGE.

    I have even gone as far as locating ALL of the registry entries to do with TRYMEDIA and r-factor and deleting those...re-installing but still get the same problem!!
  4. Okaaaay... I have read a little more about the problem and did the following...

    Set my date and time to 2013 and got the activation screen...YAY....but BOOO..I found out I do not have any activations left...so I have e-mailed and requested some more.

    I did also try to copy an old backup of the trymedia folder that always used to work..but for some reason it does not work now....when I use it it takes me to another error screen that says I am trying to open a web page that no longer exists....

    So I am on the right track...hopefully if and when they get back to me with some more activations I should be right!!!

    A/ Dont see what the date and time have to do with it...

    B/ If I uninstall the game and all its folders AND registry entries..how the hell does dat and time come into it?
  5. is your Directx upto date?

    i know this can cause problems but can`t remeber what error message you get.
  6. When you deleted the Trymedia file it should be in your recycle bin. Just go there and restore it. May work. May not.