1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Thrustmaster TX Strange Button Triggering

Discussion in 'Sim Racing Hardware' started by Mark Krus, Dec 18, 2014.

  1. Ok, so I just got the Thrustmaster TX in the mail yesterday and it's a great wheel. I'm having an enormous problem though that makes it almost unusable in manual. Usually it triggers a look back or to the side for me, but I first ran into a big problem when it started popping up the menu in Project CARS. I tried mapping all of the controls to the keyboard and the wheel still triggers the command somehow. The shift paddles trigger other buttons on the wheel. It doesn't do it every shift but sometimes comes in waves and will be especially bad for up to 30 minutes. Usually it will happen every 15-30 seconds so still very common. It also selects first gear or neutral sometimes on downshift from any gear. Sometimes the paddles shift in the wrong direction and sometimes nothing happens. I thought that this must be Project CARS messing up so I installed iRacing and I get exactly the same error. The firmware update and drivers are installed properly. I've tried everything. It's not just one of the buttons, it's all of them: upshift, downshift ABXY, every button has the possibility to trigger any other button or maybe even a function that's not even mapped to a button at any time with seemingly no logic to it. Probably going to have to send it to Thrustmaster but I'm looking for a solution until I hear back from them.
     
  2. Kurupt CDN

    Kurupt CDN
    Touring car fanatic Premium Member

    I would reinstall the drivers and firmware again if it still happens than contact thrustmaster........is your rim firmly and properly installed?
     
  3. There is a problem with the wheel circuit board or the wheel connector. I have to send it back.
     
    • Love Love x 1
  4. Faulty hardware sucks! Hope you get it sorted asap!
     
  5. jimortality

    jimortality
    Premium Member

    I was gonna say, it sounds like you have automatic gears selected lol but IOf you found the problem then hope you get sorted asap as it is a great wheel imo.