• Racing is not a matter of life and death. It's much more important than that!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

Thrustmaster T500RS Auto-Calibration Problem!

Discussion in 'Sim Racing Hardware' started by Vladimir032, Feb 5, 2015.

  1. Vladimir032

    Vladimir032

    Messages:
    3
    Ratings:
    +0
    A
     
    Last edited: Oct 1, 2015
  2. Martin Bulgin

    Martin Bulgin
    Premium

    Messages:
    2,757
    Ratings:
    +174
    The only thing I can suggest is re-installing the drivers or perhaps rolling back Windows to a time when everything worked ok just to rule out if another installed program is causing a probem, but you might be unlucky and need to return it, I have had mine about 6 months and it has never done that.
     
  3. Vladimir032

    Vladimir032

    Messages:
    3
    Ratings:
    +0
    A
     
    Last edited: Oct 17, 2015
  4. Martin Bulgin

    Martin Bulgin
    Premium

    Messages:
    2,757
    Ratings:
    +174
    I think you need to return it Vladimir, a pain I know but what else can you do.
     
  5. Darius Hayati

    Darius Hayati

    Messages:
    20
    Ratings:
    +3
    You can try their customer support. I've used them twice with mine and they were very helpful.
     
  6. Vladimir032

    Vladimir032

    Messages:
    3
    Ratings:
    +0
    A
     
    Last edited: Oct 17, 2015
    • Agree Agree x 1
  7. Darius Hayati

    Darius Hayati

    Messages:
    20
    Ratings:
    +3
    I would call them. I sent emails first but got bored waiting for a response and ended up calling them both times. They were pretty good on the phone and after a few tests sent out some new parts when one of my paddle shifters stopped working.
     
  8. Von Butters

    Von Butters
    Premium

    Messages:
    2,473
    Ratings:
    +945
    Did your ever get this sorted?
    I had a problem just like this once and found a gaming keyboard was causing a conflict and sending the wheel nuts, just like in your video.
    Just a thought