1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The weirdest thing that's happened to me in BTB....

Discussion in 'Bob's Track Builder' started by ThreeDays, Jun 17, 2009.

  1. I find this very strange, but hopefully someone will have encountered the same problem at some point.

    The story goes like this. I was happily building my track (Kahanahaloo Park, which I included in the WIP thread of this forum) and one day decided to put some trees, some barriers, distance markers and grandstands. Then I exported it and the only thing I can see are the distance markers, the cones at the end of the pit lane and the background image from the sky file. The car seems to be floating in mid-air, but it runs OK and if I lock up and run over the grass (or where I suppose the grass is, because I can't see it!) I do leave skid marks.

    Any ideas? I've never had any problems with my graphic card or with the PC. It's not a defence megacomputer, but it runs OK....
  2. it sounds like you've placed them below the ground ....check to see if their set to grounded in the object editor.
  3. Do you mean all the trees and barriers? I'll double-check that, although I'm pretty sure they were grounded.

    But what about the rest of the terrain? Why can't I see anything at all?:question::question: That's why I find most puzzling. Would the grounding of the trackside objects affect whether you could see the terrain?
  4. only things i can think of;
    - LOD far value is set too low
    - render is set to false
    - incorrect visgroups

    hope that helps ;)
  5. just another thought, i forget the symptom i was having at the time, i have a feeling it was similar to your problem, turned out rfactor (and therefore most likely simbin games as well) don't like long texture/material names, from memory the limit is around 25 or so characters
  6. Thanks a lot. However, I'm not very experienced in programming or in BTB, so I'm not sure I understand where you're getting at. :laugh2:

    The LOD thingie and the render are in the material properties, so no problem with that, but where are the visgroups? I don't expect you to write down a huge explanation, don't worry, just tell me where to find that and I'll mess around.:good::good:
  7. visgroups can be edited under the "rF Visibility" tab in BTB ;)
  8. OK, I tried grounding and rendering everything: it didn't work because it was all already grounded and rendered.
    Then I tried deleting all the trees that I'd made plus a grandstand that was slightly over the edge of the terrain, just in case: still didn't work.
    I renamed the track and exported it with two other names: nothing going.

    What irks me most is that I've run on this track, it was working until not too long ago and when I put all the trees, grandstands and distance markers in everything just disappeared.
  9. what game are you exporting to?

    if you are exporting to gtr evo from btb evo.. do you have the HAT file for your track?
  10. RFactor, I'm afraid.
  11. Hi ThreeDays,

    If you can't see the track or the terrain when you get in the car it's odds on that for some reason your car is being put under the track. Both track and terrain are invisible from below in rFactor.

    One way to check it is to compare the Y axis in the GridIndex=0 Position in the AIW file with the actual height in BTB. Or more simply maybe take the swingarm camera up as far as it will go in rFactor and see if the ground reappears? [If you have the rFactor AIW editor, the swingarm camera has no limitations, you can take it as high as you like or even underground].

    If you can leave skidmarks then the AIW file certainly isn't matching the track/terrain I think. For now, the only way I can think this could happen is if you were to alter the height export settings for the track while leaving the overwrite AIW file option unchecked.
  12. I haven't even got round to doing the AIW yet! I have a kid, so that leaves me about 10 minutes per week of free time! :confused2:

    I tried exporting the track with different height settings (Average-Lowest point-first node) and there was no change. I included a camera pretty high up over the main straight and I couldn't see any terrain. Like I said, the only thing I can see are some cones and distance markers, all floating in mid-air.
  13. There's always an AIW file, BTB generates a basic one when you export the track. It's in the track folder as yourtrackname.aiw. It's the aiw file that determines where your car is placed when you enter the track.

    Probably the best thing to do is to attach the Venue.bin file along with any XPacks that you have made or altered. Or upload them somewhere if it's too big to attach. Then we can have a look in BTB and see what's amiss [hopefully!]
  14. OK, here goes:


    I found the AIW file but I didn't know where to look for the BTB height (erm, I'm a newbie, sorry).

    BTW, I haven't created a .mas file because I figured it wasn't the final version of the track and it wasn't really worth it. I'll do it when I complete it.
  15. You can find the height here in the AIW file [BTB puts most everything on the s/f line initially]:

    So your start/finish line should be approx +0.7 in BTB

    Thanks for the track, tho it was more the venue file I was after.

    There's something very strange going on. I got the same as you, no track or terrain, just one or two objects in the distance.

    I tried opening the track's .scn file in 3dSimEd, it loaded up but the screen stayed blank, much the same thing as in rFactor, although all the textures were listed under edit textures. But I could load up individual .gmt files with no problem, some trees, a bit of terrain, a bridge,etc and they were all around the correct height compared to the s/f line in the AIW file. So I think my 'under the ground' theory was wrong.

    It seems your track and terrain are in the right place but have become invisible for some reason. I tried swinging the camera underground in the rFactor editor hoping the textures were maybe reversed and would appear from underneath, but nothing. All I can suggest right now is repeating what Brendon said in the problems thread:
    5. Try and narrow down the problem. For example, if it is an export-to-game error, trying saving your project as another copy, then removing sections (objects/sobjects) until the project does begin to work. If it's a bug/crash, try to replicate it on a new venue in the smallest number of steps.

    Just a thought, the objects that do show up in rFactor, are they String Objects? Have you tried deleting them and seeing what happens? Or going back to a backup file?

    Sorry I can't be more help, hopefully someone with more knowledge will come along soon . . .
  16. Don't worry, thanks for the effort! I've tried saving the project with other names and it still doesn't work. Anyway, I'll check out all the things you've told me and, as a last resort, remove all the terrain and start again!

    Thanks for the help!