1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Textures Problem - please help.

Discussion in 'Bob's Track Builder' started by FerrariMan96, Jun 30, 2010.

  1. Hi everyone!

    I was just making a few basic rumble strip textures but when I load rfactor they are all grayed-out and have black lines on them. They look fine in BTB Pro. So - what did i do?

    -I made the textures in GIMP (like Photoshop but free) and saved them as a dds using the dds plugin.

    -I imported them into BTB via xpacker (along with a few objects - but that can't be the problem, can it?) and put them under the 'materials' section.

    -Did a bit of tweaking - rf material name etc.

    -Made a basic "test track" in BTB.

    -Exported to rfactor.

    Did I do something wrong?


    BTW Check pics to see problem. I have 1 of BTB and a few of rfactor.

    Attached Files:

  2. I've never had that problem, but I do use gimp, so here are the settings I'd use for saving a kerb texture:
    Compression: DXT1
    Generate mipmaps: True
    Advanced: Mipmap filter: Nearest (helps when the texture can be seen from afar).

    Does your material use bump and/or specular maps? Are they scaled differently to the diffuse map? I can't think of anything else - perhaps you could provide more info?
  3. Did you set the graphic-details to "high" in rfactor?
  4. Maybe the bump or specular map is tiled differently to the texture?
  5. I A lot of this stuff bamboozles me (bit of a noob)
    Would you like me to zip and pm you the track pictured (it's only small - unzipped it's less than 4.5 mb in rfactor).

    I could also pm you the actual project (i.e. before exporting).

    BTW, texture details are set to full, however as i only use a laptop a few things i find 'less important' are set to 'medium'. see attached pic. also, in rf config i am set to dx9
  6. Oh - here's the attachment:

    Attached Files:

  7. Nevermind - i figured it out. Except that i don't know what fixed it!?!?!?!?

    What would be more likely:

    1. I used R Soul's dds export settings (it took me awhile to realise that there was an advanced tab in gimp)

    2. My textures weren't square. They were 128x256 and i assumed that was ok as both were powers of 2. I changed them to a 256x256 square and now they work!

    Does anyone know which of these is more likely? (so i know in the future)

    Thx for all of your help!

  8. There's nothing wrong with rectangular textures, so I think 1 is the most likely. But I'm biased.
  9. Lol. Everyone has to be right :)
  10. Set the circuit details to full and the texture filter higher...!?