1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

T500RS FFB Problem

Discussion in 'Stock Car Extreme' started by Martin Keets, Jul 8, 2012.

  1. My FFB reverses itself after an accident if I reset to pits.
    T500RS +100FFB and low in game.
    It's quite annoying, does anyone know why it does this?
  2. Yes , mine also is doing some weird stuff while using this game.
    I have had ..loss of feedback , and the wheel resetting itself. I use 50 % power in profiler and 90 in game.
  3. same here.....in a race my wheel turn complete to the left....
  4. any updates and fixes on this annoying issue?
    I am in the same boat with my T500 RS which is unpredictably restarting itself!
    after the self-centering process the in-game FFB is lost and needs a restart of the Sim.
    destroyed me several races already and I would love to finally fix this!
    did already de&reinstall all Thrustmaster related drivers and software, tried all available USB-ports and added an active USB repeater cable ... but nothing helped so far : (
    seems to be a common problem and I sincerely hope that somebody has a solution?!?
  5. Niels_at_home

    Reiza Studios

    That is quite annoying, I can't see what would make a TM wheel behave differently than other wheels.

    Does it happen when you set FFB effects to 'low' in game? My guess would lean towards use of medium/high/full, which may enable some effects which might confuse the wheel. I have not had Logitechs or my Bodnar wheel to skip a beat with GSC!
  6. I have never used the Low ffb profile . I will use this and see what happens .
    You may be onto something as when i ride over the kerbs when using the F3 car, It seems to give me mixed ffb signals through the wheel .Not all the time but sometimes.

    But it does seem to effect all TM users :(

    Thanks for responding Niels .
  7. Hi, my t500 works perfect with gsc12. I have lost the ffb one time, used the reset ffb button and the problem was solved. I am using low ffb settings.
  8. THX Niels for sharing a possible solution with us! but I believe it is not Sim related.
    on the internet I found many driver's with the same problem on different Sim's.

    I contacted Thrustmaster customer service and got a reply already with a couple of questions and to do some testing of all the FFB effects in the Game Controllers panel to check if the problem reappears. nope ... so waiting for another mail from TM.

    on the net I read that the circuit-board might be the trouble-maker and that customers got a replacement from TM for it (seems to be a challenging task to change it though).
    or a problem with the power supply is mentioned several times because the T500 draws a lot of it!
    and finally the easiest solution could be a loose USB connection that needs just a little squeezing.
    so it could have many reasons!!! I 'll keep posting any news here in case someone else runs into the same problem.
  9. I had a lot of problems with my T500 when usb 3.0 ports are used. Using 2.0 now and all is fine.
    • Like Like x 1
  10. I have the same problem. Wheel just stops working and my throttle is pushed to the max even though I'm not touching it. Only happens with this game. Using recommended settings on thrustmaster webpage for gsc2012 and full FFB 100% ingame.
  11. I did some testing and the problem seems to be powersupply. With full FFB I can't drive GSC in the same power socket as my computer and screen etc. I haven't encountered any problems at all after I moved the t500 powercable to a wallsocket of it's own.
  12. John Addison

    John Addison
    Premium Member

    Just FYI with the F1 thrustmaster T500RS. After the update to 1.2 my FFB was all messed up and couldn't drive any of the cars. Reading thu this thread I saw i already had the power supplies separate so i went in game and put the FFB from Full to low and left the strength slider bar on 100 % and that did the trick. Nice and strong the way it should be...go figure.