1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Still can't load old projects...

Discussion in 'Bob's Track Builder' started by Davesta, Mar 18, 2009.

  1. I posed this a while back (on the old forum) but it never got answered properly because of the forum being offline. I thought that it might be fixed in V0.6 but it isn't.

    I can't load any projects which I made in 0.4.2.3. They worked for a while in 0.5, but for some reason I can't load them any more. I've tried nearly all of my 38 backups of my project (which all worked before) and NONE of them work, so I know that it is not the track. Brendon, I sent my tracks to you and you reported that they work, so it is obviously only a problem with my PC. I have uninstalled BTB completely about 3 or 4 times, installing a clean version each time and I still can't get it to work.

    Please help, I really don't want to lose what is more than a year's worth of work.

    If you want me to send the track again, I'll be happy to do so.

    My system specifications:
    Windows Vista Ultimate (6.0, Build 6001) SP1 32bit
    AMD Athlon 64 X2 6000+ ~3.1GHz
    3582MB RAM
    ATI Radeon HD 3850 512MB

    This is the Unhandled exception error I get:
    Code:
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
     
    ************** Exception Text **************
    System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
    Parameter name: index
       at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
       at System.ThrowHelper.ThrowArgumentOutOfRangeException()
       at BobsTrackBuilder.frmMain.DrawPanel_TerrainArea(View& v, TerrainArea loTA, Boolean Solid)
       at BobsTrackBuilder.frmMain.DrawPanel_2d(View v)
       at BobsTrackBuilder.frmMain.DrawPanel(View& v)
       at BobsTrackBuilder.frmMain.pnl_Paint(Object sender, PaintEventArgs e)
       at System.Windows.Forms.Control.OnPaint(PaintEventArgs e)
       at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer, Boolean disposeEventArgs)
       at System.Windows.Forms.Control.WmPaint(Message& m)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
     
     
    ************** Loaded Assemblies **************
    .. edit don't need all of this ...
    
     
  2. Brendon Pywell

    Brendon Pywell
    Bob's Track Builder

    Yep they loaded alright.

    I'd be interested to see if others can load your project. Care to send it to a few other people to see if they can open it?
     

    Attached Files:

    • SS.jpg
      SS.jpg
      File size:
      115.5 KB
      Views:
      146
  3. Brendon Pywell

    Brendon Pywell
    Bob's Track Builder

    At a guess I think it is failing to load a texture. Why it happens on your machine and not mine is a mystery. Hopefully other people might try, and post their own PC specs too so we can gather more info.
     
  4. If it is a texture which can't be loaded, is there a way to find out what texture it is so that I can put it in the right place?

    If I remember rightly, if a texture is missing, the error message says so.
     
  5. Hi Davesta,

    Sorry to hear you are having trouble. I have downloaded from the link you posted and can say it works fine here. I am Running:

    Windows 7 Beta 32 bits
    AMD Athlon X2 6000+
    4GB Ram
    Nvidia 9800gt

    Have you tried to reinstall DirectX 9 and .NET and things like that? I can see why you'd be upset to lose your work, as it really looks great what you have achieved. :worship: Good luck with it. Take care,

    Andrew
     
  6. Hi Davesta,

    Loads into BTB V0.6, just fine for me! (yes I know there's a patch)

    Exports to rfactor with no problems!

    Took a test drive too!

    Looks and drives very nicely, I can see you put a lot of work into your track, i hope you can sort things out!

    My PC Specs!
    CPU Intel E6850 / Invidia 8800GTX / 4GB Ram / Service pack 3
     
  7. Thanks for the compliments both of you. I've spent probably more than 2 years on that project (on and off - adding bits occasionally, sometimes waiting for the new BTB release so I can improve it more). It means a lot to me that people like the track I've spent the most time on. :)

    As for loading it - I've had an idea. Since you can all get that to work from the download, I shall try downloading it myself and opening it. It's a long shot because I uploaded it after the problem started, but it could work. I'll do it tomorrow though, it's late here in England...
     
  8. looks great, i too know the frustration of a project crashing. i hope you can get it sorted :)
     
  9. Sorry about your problem Davesta.

    I can open your BTB proyect on my Vista 32 ultimate.

    Hope you can solve it nearly.... ;)

    My Pc spec:

    P5K pro - intel E6750 - 2Gb DDR2 800 - Asus EN8800Gt
    runing on vista 32

    acctually I can´t load any BTB proyect on Richard burns... i do every and nothing changes, we are in troubles... hope we can laugh about this soon.
     
  10. I have tried using the version that I uploaded, this doesn't work either. It has to be something to do with my PC rather than the project itself.

    Could someone with an ATi card test it? Mine is a new card - I was using NVidia before. Again, it's a long shot, but I remember there were some problems with ATi cards a while back...
     
  11. Loads fine here, and looks great btw.
    NVidia card though, sorry.

    AMD Athlon 64 X2 5000
    4Gb Ram
    Geforce 8400GS
     
  12. Out of interest, what Firewall/AntiVirus are you running?

    A while back, I had errors everywhere with BTB that neither me nor Piddy could figure out for ages (and he sent me tens of new EXEs to try).

    It turned out to be a service that the firewall left running even when disabled/uninstalled, that somehow blocked BTB from being able to use the graphics card (or something to that effect) and when disabled, BTB went back to it's brilliant self. :dance2:. The software was Comodo Internet Security/Comodo Firewall (was free, but got the boot when it broke BTB :rotfl:).

    Just throwing this out there, just in case something similiar might be happening at your end. Take care,


    Andrew
     
  13. At the moment I'm not actually using any antivirus software. It makes my computer run slower than is necessary. This being a gaming PC, I don't want that. I prefer to simply back everything up regularly and not click on things that are likely to be viruses. I find that reinstalling windows occasionally is less hassle than running resource-hogging antivirus programmes.
     
  14. Loaded ok for me too. I'm nvidia as well though.

    If it's any consolation the venue is really impressive.
     
  15. Are there any ATI users out there? Surely there has to be some!
     
  16. If it's of any help to you I'm useing an ATI HD3870 here with Omega Drivers and it loads just fine....
     
  17. Well, that's another theory out the window. Thanks for confirming that.

    I'm completely stumped.
     
  18. If the problem is not hardware based, it must be software.
    My next steps would be uninstall and reinstall the .Net framework.
    If that still didn't fix it, reinstall windows?
    It seems quite drastic but if it solves your problem its worth it.
    I have a separate partition on my hard drive just for windows.
    My documents is elsewhere as are any programs I install.
    Makes the dreaded format - reinstall slightly less painful.
     
  19. Direct X might be another one to try re-installing, there appear to be several flavours of 9c and some seem to be better than others, some even containing differently named dll's. [You say it is a gaming machine, so if you've installed new games recently this could have resulted in a different version being put on]