1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

Setting up Oculus Rift DK2?... help needed!

Discussion in 'RaceRoom Racing Experience' started by Thomas Friedrich, Dec 2, 2014.

  1. Thomas Friedrich

    Thomas Friedrich

    Messages:
    37
    Ratings:
    +8
    Hi guys,
    I got my OR last weekend and tried out some demos and casual games from the Oculus Share webpage. I also managed to get Assetto Corsa running, with extended mode and OBS to mirror the OR (primary screen) on my monitor for the menu. For R3E I looked up some forums to help me get it started, but I haven't found a real guide or something that could solve my problems. I have added the startoption '-vr' in Steam (also tried to start .exe file with this extension from the explorer), but in most cases R3E freezes in the loading screen (the one with the changing advertisements) or if I get it started, the track loads up an just shows me a circling 'helicopter view' from the track, with all the cars standing in the starting grid. No menu is displayed and no key or button gets the race started... what am I doing wrong? Hope that someone here can help me...
     
  2. Peter

    Peter
    who cares Premium

    Messages:
    1,725
    Ratings:
    +666
    • Like Like x 1
  3. Thomas Friedrich

    Thomas Friedrich

    Messages:
    37
    Ratings:
    +8
    Thank you Peter for the quick response! I will look it up and try it out right after work!:thumbsup:
     
    • Like Like x 1
  4. Thomas Friedrich

    Thomas Friedrich

    Messages:
    37
    Ratings:
    +8
    I've done everything as described, no more crashes, but still I have the problem that the camera keeps cycling round the track and there is no menu... I just can't start the race...
     

    Attached Files:

  5. Cosmic

    Cosmic

    Messages:
    78
    Ratings:
    +20
    Unless it has changed, only practice is supported. If you are trying to run a race you will get the wonky camera issue.
     
  6. Peter

    Peter
    who cares Premium

    Messages:
    1,725
    Ratings:
    +666
    Practice, Apex Hunt or online
     
  7. Jotape

    Jotape

    Messages:
    7
    Ratings:
    +0
    I wish they looked at this in the next build. I love the game but i just can't go back and play with a monitor.
     
  8. RaceNut

    RaceNut

    Messages:
    1,182
    Ratings:
    +544
    I have tried following various How-to's to get the DK2 working with RRRE but, it always shows 2 different images within the rift - probably the typical 2D image with the middle section missing. There is something stopping the DK2 from rendering it in 3D and the camera does not work either. No such problem with other titles.
     
  9. museumsteve

    museumsteve

    Messages:
    461
    Ratings:
    +169
    Never had toruble getting working for me, although I should say everytime I go from normal viewing playing and make changes to play in the Rift, the first time I find myself in the car in pits ready to go, I cannot see anything just some images on the screen, with game audio in the background, so I have to exit out the game and go back in at which point it's fine. I wont guess what it is but happens everytime for me so I'm used to it.

    I'm trying to envisage what you mean..unless you mean what I'm describing?
     
  10. RaceNut

    RaceNut

    Messages:
    1,182
    Ratings:
    +544
    What I get is each eye seems to be looking in two different directions - left eye seeing left, right eye seeing right of center. The middle section is missing. Test this (when you get the wrong image) by closing one eye at a time and you'll see what I mean.
     
  11. museumsteve

    museumsteve

    Messages:
    461
    Ratings:
    +169
    Have you added -vr to the game properties in steam?
     
  12. RaceNut

    RaceNut

    Messages:
    1,182
    Ratings:
    +544
    Most definitely, it just doesn't seem to render in Stereo and the camera doesn't light up at all - only in RRRE though. Every other game I've tried works fine.
     
  13. museumsteve

    museumsteve

    Messages:
    461
    Ratings:
    +169
    I didn't think you'd missed any obvious things mate but always worth asking. I replied after starting it last night and I actually forgot to add -vr and I think I saw what you're seeing.
    I can't think of anything really. I was playing last night in the Rift and same as always for me.
     
  14. RaceNut

    RaceNut

    Messages:
    1,182
    Ratings:
    +544
    Thanks for suggesting - no worries. I'll keep an eye out for solutions and re-trying occasionally. Someone on the Oculus forums found a fix by editing some game config files for another unfamiliar title so there is that but, I don't know where to look at this point. I may try a whole new game profile too in case there is something in there causing the issue.
     
  15. museumsteve

    museumsteve

    Messages:
    461
    Ratings:
    +169
    I meant to ask..at what point are you talking about? The game only goes into rift mode once you get to the DRIVE orb in the pits, everything before that is not rift ready so to speak.
     
  16. Joe Moore

    Joe Moore
    Premium

    Messages:
    321
    Ratings:
    +106
    Is the menu in game still hard to navigate also what setting are you guys using .