1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Set the GSC.exe to use a single CPU core

Discussion in 'Stock Car Extreme' started by Gringo, Feb 16, 2015.

  1. Hello RD,

    I notice some users having problems with “stuttering” in GSCE and I wanted to give my opinion on the issue.

    What I would propose is people with stuttering give this a try… Via the windows task manager, set the GSC.exe to use only one CPU core.

    Now the thing is after you switch to one CPU core you may lose some FPS depending on your hardware, but you should gain smooth game play even if you have less than a vsync frame rate (60fps).

    If you have stutters you probably have vsync disabled all ready. I recommend vsync is turned off unless your hardware can hit a consistent +60 fps (on a single CPU core or otherwise).

    for AA / AF and shadows follow Alex’s setup guide on Steam (Optimizing Graphics in Game Stock Car Extreme) http://steamcommunity.com/sharedfiles/filedetails/?id=391492364

    Its worth at least trying to turn off replays as many have report improvement, as an alternative you can find a flag in your PLR file Record To Memory="1" // record replays to memory rather than disk

    Test from the cockpit view only to look for stuttering. If you have track cameras that stutter then just accept that is a part of the engine. I hate to say it but that is the reality of the system used. Often you will find track cameras that just don’t work smoothly; it’s been an issue for 10 years at least. Anyhow the track cameras have no impact on your racing even if it is an annoying issue.

    Give the single CPU core thing a try, I tried it with an Core i7 laptop at 2.4GHz and the CPU was running 50 -75% CPU load (some peaks at 100%). Jacarapague GP, 20 car F_V12’s, 33 laps, rolling start at the back of the grid. I fix my frame rate to 66 fps to keep my laptop from overheating, but during the start and the race the frames came silky smooth, my frame rate would drop to 55 fps at times and I never noticed any stuttering. (from the cockpit view). From the track cameras I lost 20 – 25 fps with the occasional stutter here and there, but more or less very smooth graphics.

    I tested the Formula Vee, this car is much more load on my laptop test system with FULL everything except, shadows at MAX and NO shadow blur settings . With a 20 car field at the short "Jacarapague" layout, rolling start back of the pack... I saw my FPS drop from the normal 66 fps to a min 37 fps and an average I would say 45 fps. The FPS recovered as the race developed and by lap 3 I was seeing 66 fps again. The neat thing is that I did not notice any stutters. Of course there was some lag detected during the minimum frame rate periods but that is to be expected on this mid power computer.

    Have a go let me know your results.

    Warning! More ramblings follow

    The heart of rFactor was developed a long time ago… when cell phones had button keypads, before the time of multicore CPUs. Due to the low power mainstream hardware of the time getting 36 fps from 1280x1024 was pretty awesome and games from that time depended a lot on “sharing resources” and “synchronization” to get smooth gaming from limited hardware. When multicore did come along rF was able to take advantage of the extra power but as many people discovered the end result was unpredictable and thus the “micro stutter” was born. Now remember at the time CPU power was at a premium and multicore (for those that it worked for) was really great. But many people could never solve the micro stuttering on some hardware.

    My point is that the rF engine… graphics and physics and input are (originally) designed to run with a single CPU to manage all the threads (sound, graphics, physics, network, whatever) and in the end the result will be a “smooth delivery” of the available frames that the hardware can render. Keep in mind that we can have smooth game play without getting vsync or +60fps.

    Today’s hardware is more than enough (in most cases imo) that GSCE with all the details should run smoothly.

    PS Oh yes... if this single core thing works for you, there is a great windows tool called "PRIO" that will remember custom CPU affinity and process priority settings and reload them on demand.
    Last edited: Feb 16, 2015
    • Like Like x 2
    • Beer Beer x 1
  2. Can confirm it works well for me too, on a I5 @4.4GHz,.
    28 Vee's at Interlargos. Locked to 60 hz with Max frame rate ="-60" in plr file.
    Everything on max except Shadow blur.
    Dropped to 58 hz for 2-3 sec in first corner then back to solid 60-61 hz the remaining race.
    On all 4 cores it will drop to 45-47 fps for 10-15 sec with massive lag.
    Thanks for the tip.
  3. An ISI developer said rF was essentially single threaded. What happens when you run a single threaded application on more than one core is that the application runs on one core for a short time, then switches to the next core for a short time then switches again. The switching is very fast so I can't be sure its the cause of micro-stuttering.
  4. LOL. I think you mean ALWAYS turn off Vsync, as it induces input lag, which even I can notice.

    Also, if using multiple cores was the cause, all of us would have it, and I haven't had stuttery gameplay in either rFactor or GSC since I set "Record to memory" for replays to 1 in my .plr file.

    Maybe this is what you're actually looking for.

    EDIT: That, and turn off Auto Detail FPS.
  5. Msportdan

    @ Simberia @Simberia

    i7 here, doesnt make any difference still stuttering with the vees.
  6. Did you try setting "Time Scale" to none in game options or "Record to memory" for replays to 1 in your .plr file?

  7. I need some help guys.. I have laptop with a i7-4500u dual core, in the windows task manager in set affinity it shows me cpu0 cpu1 cpu2 cpu3..?? how to I set it to run only core?
  8. Uncheck cpu1 to 3 or 0, 2 and 3.
    0 and 1 should be the physical cores since this i7 is a dual core, the others are virtual because this processor has hyper threading, I could be mistaken about the the exact numbers but should be this
    • Beer Beer x 1
  9. Thank you very much:thumbsup: i was not understanding why it was showing 4 cpu´s
  10. is it possible to lock the settings? every time I launch the game it starts to using all cores again..
  11. Never tried it, but if I did I'd start with CFF Explorer since it can change the amount of memory a program will use (if more or less than 2GB) there could be an option to make GSC.exe to start with only one core, but I'm not sure
    • Like Like x 1
  12. thank you Will im going to googlit
    • Beer Beer x 1