1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Screen Tearing

Discussion in 'Sim Racing Hardware' started by Joao Borges, Aug 18, 2013.

  1. Hopefully someone can help me out as I am losing my mind. :)

    I play PC on my TV that has a refresh rate of 60Hz and I am experiencing a lot of screen tearing in many different games. On Race 07 and rFactor, I run without vsync and I end up having over 100 FPS WITHOUT any screen tearing.When I play better looking games such as Bioshock Infinite, Medal of Honor or Dead Space, with frame rate above 60FPS as well, I have a lot of screen tearing. Why do I experience screen tearing on these games and not on Race 07 or rFactor?!

    What confuses me even more is when I also try to play BF3. I run on average 30-40 FPS and somehow, I also get screen tearing. Shouldn't screen tearing only occur when you go over the refresh rate?! Why is it happening UNDER the refresh rate?

    I tried to use in game vsync, for example, on Dead Space, but somehow the game was running at 30FPS instead of 60FPS and with massive input lag. It was unplayable but the screen tearing was gone. I tried enforcing vsync through the AMD Catalyst and nothing happened. I was getting over 100 FPS as if vsync was still OFF. I created an application profile with the game's .exe and no changes as well.
    On the other hand, on Medal of Honor, vsync capped the game to 60FPS instead of Dead Space's 30 and no screen tearing. I had little input lag but nothing serious and I could play the game just fine. Totally different results. Bioshock Infinite gives similar results to Dead Space, massive input lag as well.

    Are these odd results happening because of software issues, hardware issues or what? It's just so confusing to me. It really takes away the fun in gaming. My specs aren't that great but I wasn't expecting to experience these issues :(. Would upgrading to a 120Hz monitor help?

    Here are my specs:

    MSI 770-G45
    AMD Phenom II X4 925 @2.8 Ghz 4 cores
    4GB RAM (2GB x2)
    AMD Radeon HD 5750 1GB
    1TB HDD
    800watts PSU
    Windows 7 Ultimate
    1920x1080 @60Hz - 32" LCD TV (LG)
     
  2. It seems nobody can help me, so if you don't mind any moderator can close this thread if they wish to do so. Thanks.