1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RRE and windows 10 preview.

Discussion in 'RaceRoom Racing Experience' started by Steve Bird, Jun 28, 2015.

  1. Steve Bird

    Steve Bird
    Racing Since 1978 Premium Member

    I've tried my best to get RRE working on Windows 10 preview but it keeps crashing on startup.

    Has any of the RD community managed to get it running okay on Win 10?
  2. Kjell Eilertsen

    Kjell Eilertsen
    Premium Member

    I had it running just fine on Windows 10 but that was several builds ago, something may have broken it in later builds.
  3. Steve Bird

    Steve Bird
    Racing Since 1978 Premium Member

    Yer, not sure. It just crashes after the small' 'starting' pop up comes up. Grrrrr.
  4. It does not run well on W10. I had to revert back to 8.1 to play it. It worked fine until the last Windows 10 update. You are not alone.
  5. James Cook

    James Cook
    Marcas fan

    I'm running an older build (10074) and it works fine. Build 10130 gave me resolution issues (couldn't select 1080p) but that may have been a Nvidia Win10 driver problem. A new driver came out recently so maybe that's fixed it.

    At this point my system runs well with 10074 so I'm just going to wait for the full release now.
  6. Frank

    Administrator Staff Premium Member

    Runs perfectly on my Windows 10 machine, with all updates. Things to check when you play on Windows 10:

    • If you run AMD, don't download drivers from their website but get them via Windows updates.
    • If you run Nvidia, get your newest drivers from their website.
    • Be sure to be on a clean install, not an upgraded one.
    If you still have crashes, post your crash logs or explain better what is happening :).
  7. Frank, just because it doesn't happen to you, it doesn't mean it isn't happening. I won't get into a drawn out debate. Fresh install didn't work. Period. However, I'm really glad it all worked for you.
    It could be a plethora of things involved. Mine went south "right" after windows updated. Latest NVidia driver didn't make a difference, then. :thumbsup: Windows 10 Preview has it's niggles anyway. I was just curious, so I tried it. Back on 8.1. Happy.

  8. That's the problem I had. I was wanting to revert to 8.1 anyway.
  9. Frank

    Administrator Staff Premium Member

    I think I clicked disagree on your post without noticing.

    Anyway, I tried it at 4 PC's now, all running Windows 10, with both Nvidia and AMD. With 1 of the AMD's and 1 of the Nvidia's I had to run it in windowed mode and I used the app Borderless Gaming to get it full screen again. If I didn't do that, it crashed on startup.

    Also, when you upgrade from build to build, you need to remove all drivers of your GPU, including all software. Then reboot and reinstall it, otherwise you get issues.
    • Beer Beer x 1
  10. Steve Bird

    Steve Bird
    Racing Since 1978 Premium Member

  11. This fix/workaround is from Alex/FunkyChickenSector3 Beta Tester

    Change the "graphics_options.xml" manually. It can be found under /documents/my games/simbin/Raceroom/userdata. Open it with the text editor.

    Change to your desired resolution and edit the line for the refresh rate from 60 to 59:
    <custom type="uint32">3840</custom> <- x-resolution
    <custom type="uint32">2160</custom> <- y-resolution
    <custom type="int32">32</custom> <- color bit depth
    <custom type="int32">59</custom> <- refresh rate
    <custom type="bool">true</custom> <- fullscreen

    Its Works perfect now!
    • Like Like x 2
    • Love Love x 1
  12. Thanks for sharing.
  13. Steve Bird

    Steve Bird
    Racing Since 1978 Premium Member

    Worked perfectly. Thanks for the help.
  14. Updated to W10 earlier today, I go to play RR and all seems ok, I go from menu's to a race weekend and still all is well, I get into a race weekend then I get put back to desktop and I get an error that my nvidia drivers have crashed and recovered but worst of all, while on desktop, as I click the RR logo at the bottom to get back to my game but it is not loading back up atall from deksop and the only thing I can do is manually shut the game down through task manager. Tried re-installing nvidia but still no luck, still the same problem and RR is not the only game which is not working at the moment.
  15. Phil Davies

    Phil Davies
    Premium Member

    Go to the Steam Folder in program files,Delete "appcache",the whole folder,restart windows,that did the trick for me,hope it helps.
    • Winner Winner x 1