• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

rFactor Problems With Vista

Discussion in 'rFactor' started by Kyle Evers, Apr 17, 2009.

Thread Status:
Not open for further replies.
  1. Kyle Evers

    Kyle Evers

    Ratings:
    +0
    Hey all. I recently turned off my UAC (User Account Control) and now when I open rFactor I only get like half of my tracks. Plus when I look at my folder half of them are gone. But then if I turn UAC on again, they will all be there. Does anybody know why?
     
  2. Mario Rocha

    Mario Rocha

    Messages:
    62
    Ratings:
    +1
    Dont need to turn off UAC.
    Run EVERY game in administrator. If you do, all the saves, set, etc are saved in the game folder.
    Your lost files are in your docs folder, maybe.
    When you dont run in Adm mode, you files goes to you personal folders.
     
  3. Dietmar

    Dietmar

    Messages:
    1,323
    Ratings:
    +43
    If I would have to run rfactor as an admin, the copy that I just ordered might go directly to the dust bin!

    But I tried to Demo and all seemed fine, also installed the MMG F1 mod.
     
  4. Ben Tusting

    Ben Tusting

    Messages:
    5,764
    Ratings:
    +133
    I have no problems with R Facto, and i'm running it on vista 64
     
  5. Kyle Evers

    Kyle Evers

    Ratings:
    +0
    Well see when I don't have UAC on and I run as Admin, half of my tracks or cars don't show up (like when I have UAC turned on and don't run as Admin - only some of the downloaded cars and tracks are there, not all). But when I have UAC on and I run it regularly, all my cars and tracks show up, but then anything I edited in my .plr doesn't work...

    Last option is run as Admin with UAC off.
     
  6. Abdul Al-Amry

    Abdul Al-Amry
    2011 RD Indy 500 Winner

    Messages:
    2,298
    Ratings:
    +19
    Kyle turn UAC on login with admin rights and in the properties of rFactor under compartibility tick "Run with Administrator" or something to those words.
     
  7. Kyle Evers

    Kyle Evers

    Ratings:
    +0
    Okay.

    I always login as Admin. Before when I had UAC on, and I just normally ran rFactor, all of the tracks and cars show up (specifically referring to downloaded content). When I ran it as Admin, only a portion of my downloaded cars and tracks showed up.

    Now that I have UAC off and I normally run it (logged in as Admin), the same portion of downloaded cars and tracks don't show up when I run it normally. When I look at my files, those unappearing tracks and cars aren't in my files either.
     
  8. Abdul Al-Amry

    Abdul Al-Amry
    2011 RD Indy 500 Winner

    Messages:
    2,298
    Ratings:
    +19
    Kyle so you are missing the files which are for the missing cars and missing tracks in rFactor. Have you tried to install the mods again? Dont forget to tick the option in the properties of the rfactor exe.
     
  9. Kyle Evers

    Kyle Evers

    Ratings:
    +0
    Well I turned UAC back on and so now all of the files are there like before and if I run rFactor normally they will all show up, but if I run it as Admin, the cars that were not there when I had UAC of won't be there again.

    And yes the missing cars are also the missing files and such, you get it.
     
  10. Abdul Al-Amry

    Abdul Al-Amry
    2011 RD Indy 500 Winner

    Messages:
    2,298
    Ratings:
    +19
    Ok try this then,

    Turn UAC on install the missing mods again and run rFactor normally.
     
  11. Kyle Evers

    Kyle Evers

    Ratings:
    +0
    Well when I have UAC on, all of the files are there. When I run it normally, all of the cars and tracks will be there. But if I were to run as Admin, the same downloads that weren't showing up when I had UAC off would be missing again.

    So if I run rFactor normally with UAC, all of the tracks and cars are there.
     
  12. Dietmar

    Dietmar

    Messages:
    1,323
    Ratings:
    +43
    Ok, just installed it myself completely new.

    Installed as Admin, I also had to installed the Mod as Admin (not possible as non-admin), tried a Nordschleife and a Caterham Mod and run it as regular user without any flaw.

    I am not using UAC as it was causing problems for me, but am only working / gaming with a user without admin rights.

    If somebody is missing a comfortable 'Run-As' under Vista, there is a small Add-On you can install to have a similar function as under XP.
     
  13. Ramon van Rijn

    Ramon van Rijn

    Messages:
    5,399
    Ratings:
    +235
    Here is why:

    UAC is used to temporary elevate your user rights, acting like an admin. With your normal, non-admin account you and UAC off you will never get the question to elevate rights.

    You might have installed a few mods/tracks by extracting them to a temp folder (with only read permission for normal users/full control for admins). Then you probably moved it on this same partition to the rFactor\GameData\Locations. THen WIndows will move the permissions also resulting in readonly on those particular tracks/mods and then most likely not working correctly while starting the game.

    You could try to login as Admin, change rights for the rFactor folder (and all subfolders) to the Users Group as Change rights.
    But you need to do this everytime you move a new track again.

    Easy solution is to make your normal user-account member of the local Administrators group. Of course this is a bit against Microsoft's policy in security. Its like XP was working :)
     
  14. Dietmar

    Dietmar

    Messages:
    1,323
    Ratings:
    +43
    Not a problem for me (am not sure whether you were addressing this to me), I am aware of this, but I prefer this over working with a admin account :D.
     
  15. Kyle Evers

    Kyle Evers

    Ratings:
    +0
    Oh. My account is the admin account.
     
  16. David Thompson

    David Thompson

    Messages:
    98
    Ratings:
    +0
    This is what I have found out as a recent convert to vista 64 and the pleasures of UAC.

    Run as Administrator UAC On - If you install a game you can select the folder it will be in, so you can install it in D:\Games\... for example but the files relating to your profile will be in your documents folder. So my recently reinstalled GTR2 has this setup

    Documents\GTR2\Gamedata
    Documents\GTR2\ReplayData
    Documents\GTR2\TimeTrial
    Documents\GTR2\UserData
    Documents\GTR2\Config.ini
    Documents\GTR2\Sysinfo.txt

    Run as Administrator UAC off

    D:\Games\GTR2\Gamedata
    D:\Games\GTR2\ReplayData
    D:\Games\GTR2\TimeTrial
    D:\Games\GTR2\UserData
    D:\Games\GTR2\Config.ini
    D:\Games\GTR2\Sysinfo.txt

    So if you want to have all your files in the same folder then run as administrator with UAC off when installing.
     
  17. Kyle Evers

    Kyle Evers

    Ratings:
    +0
    Okay. It's just strange though why some would be there and some not as I had never logged in on anything other than Admin and had never turned UAC off.
     
Thread Status:
Not open for further replies.