• "Bwoah." - Generic Kimi Quotes.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

rFactor on Windows 7

Discussion in 'rFactor' started by Abdul Al-Amry, Mar 9, 2009.

Thread Status:
Not open for further replies.
  1. Abdul Al-Amry

    Abdul Al-Amry
    2011 RD Indy 500 Winner

    Messages:
    2,298
    Ratings:
    +19
    rFactor related, if anyone makes this game run in Windows 7 I'll say thank you.
     
  2. Ramon van Rijn

    Ramon van Rijn

    Messages:
    5,398
    Ratings:
    +233
    I've moved your question to a seperate thread to stay on topic.

    I have not yet tried win7, but in Vista you can set a game shortcut/exe to compatibility mode; XP SP2. Check if the option is available.
    Also, have you installed DirectX 9? In Vista DirectX 9 is not available by default. You have to download it separately from Microsoft.

    It would also help if you post the error and/or some screenshots of the error you get.
     
  3. Nils Wijk

    Nils Wijk

    Messages:
    423
    Ratings:
    +2
    Will DX9 actually install on vista? Some games ask for it to install on setup but nothing is changed afterwards. I also never had to install dx9 to run rFactor on Vista.

    Abdul have you had any luck installing it on W7? If not what goes wrong?
     
  4. John Bergqvist

    John Bergqvist

    Messages:
    352
    Ratings:
    +1
    with the experience ive had with rfactor, it barely runs on XP, so good luck running it on win7
     
  5. Ben Tusting

    Ben Tusting

    Messages:
    5,764
    Ratings:
    +133
  6. Abdul Al-Amry

    Abdul Al-Amry
    2011 RD Indy 500 Winner

    Messages:
    2,298
    Ratings:
    +19
    Wohoooo. Thanks Ben. Will get this working hopefully today.
     
  7. Ramon van Rijn

    Ramon van Rijn

    Messages:
    5,398
    Ratings:
    +233
    LOL, indeed as said; just install DirectX 9 exactly as you have to do with Vista.
     
  8. Robert McColl

    Robert McColl

    Messages:
    371
    Ratings:
    +0
    i have used Windows 7 quiet extensively on one of my test PC's Rfactor works fine but i however found a few other issues that made uninstall it.about 3 times iv tried and been happy for a while until something creeps in.I infact have tried differant Windows 7 and do remember one of them not wanting to start rfactor.
     
  9. Robert McColl

    Robert McColl

    Messages:
    371
    Ratings:
    +0
    well igot a few XP's too and have worked my Racing simm installs down to 2 version of XP that work very very well
     
  10. Rob Every

    Rob Every

    Messages:
    480
    Ratings:
    +70
    Ok guys am haing huge issues with running the game

    Gotta be honest and admit I ahvent played it for ages while playing Race 07 and its mods

    I spent all day today downloading the touring car legends

    I am running 32 bit vista and ahve played the game before

    But now, I can enter a track, sit and watch but when I g on track teh lap takes about 30 secs then the entire program closes down

    I presume they are sitll running 1.255? Could it be that?
     
  11. Robert McColl

    Robert McColl

    Messages:
    371
    Ratings:
    +0
    Rob hi Rob here LOL................. i remember rfactor having a few issues with some of the Anti virus programs....which AV you using ....symantec was a problem i know
     
  12. Rob Every

    Rob Every

    Messages:
    480
    Ratings:
    +70
    I dont use any AV at all and only Windws Firewall

    Am very careful

    I should say it only happens in online games on a server

    I ahve just been hotlapping the same track I was having issues with Midd Ohio and it was fine

    So might be an online thing? As I say I could enter server but as soon as I ran the thing just dumped entire game

    Drivers are up to date aswell
     
  13. Wesley Woolley

    Wesley Woolley

    Messages:
    79
    Ratings:
    +0
    I have managed to install RFactor on Windows 7 and direct X9 installed with it but booting the game is very slow then hangs on a black screen :(
     
Thread Status:
Not open for further replies.