1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Rfactor doesn't work anymore

Discussion in 'rFactor' started by Chris Heller, Jul 18, 2010.

  1. Hey guys,

    my rFactor won't start after I had to quit the .exe via task manager before :(
    It just gets to the 'boot screen' (the little one when loading rFactor) till my comp tells me that the game doesn't work anymore and closes the screen.
    Is it possible that some files are corrupted now?

    I already tried to run the config.exe again and deleted all .cch files from my profile. I'm running rFactor as an administrator and on Windows XP compatibility mode.

    If there's any solution to fix it without re-installing rFactor, I would gladly appreciate that.


    Cheers
     
  2. Chris Butcher

    Chris Butcher
    Red Bull Gridsters 2012 Champion

    Are you using all of your mods in one install or separate installs for different mods?
     
  3. All mods are in one install.
    Unfortunately, I deleted most of the mods (.rar files) from my HDD, that's why I would like to find a solution without re-installing rFactor.
     
  4. Chris Butcher

    Chris Butcher
    Red Bull Gridsters 2012 Champion

    What changes, apart from those made above, have you made (updates, new mods etc)
     
  5. Well, I installed F1 1971 and Bathurst Legends 72, but both should work fine.
     
  6. Chris Butcher

    Chris Butcher
    Red Bull Gridsters 2012 Champion

    Have you tried removing these, could be a problem with one of these mods missing files, perhaps UI issue if it's crashing after the rFactor splash.
     
  7. Tried that but it still doesn't work :(

    Also tried to get a trace but that's all I got:

    TRACE LEVEL = 1000
    NetComm.cpp 11193: NetComm checking command line: "-trace=1000"
    game.cpp 1211: Entered Game::Enter()
    osman.cpp 540: Entered OSMan::Enter()
    plrfile.cpp 2314: Entered PlayerFile::Enter()
     
  8. Chris Butcher

    Chris Butcher
    Red Bull Gridsters 2012 Champion

    What I'd try doing is backing up all your setups and controller settings, then deleting the entire user folder (not UserData, just the "Chris Heller" folder within that, providing that is what you use). On the trace the last action is Entered PlayerFile, perhaps this would be worth a try?

    If you do, rFactor will ask you to create a new profile. If it works you should be able to import your setups and controller settings
     
  9. It still doesn't work :( Seems like they're really some corrupted files which doesn't let rFactor start properly.
     
  10. Wich mod where you playing when you used the Task Manager?
     
  11. Actually,I used the Task Manager when rFactor was loading, so at the loading screen in fact.
    Nothing special though, I did that several times before and it worked like a charm.
     
  12. It seems some kind of UIData is missing in this case. It would be best to reinstall really. Keep your UserData folder. You can install via rFactor Lite - I use it and it is much easier. Once installed, copy your UserData folder across.
     
  13. Reinstalled rFactor, deleting actually took more time than installing the game :D
    Right, gotta get some mods now.

    Thanks for your help guys!
     
  14. Sorry for double-posting

    I figured out what caused the problem, it was Xfire
    Not sure why as it always worked fine before but well, problem's fixed :)
     
  15. rfactor Problem

    Chris did you get your Rfactor working ?