1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rFactor 2 wont start!

Discussion in 'rFactor 2' started by Dylan Hember, Jun 8, 2015.

  1. Hi, I have done a lot of searching high and wide but have been unable to find and answer.
    I have paid for rFactor 2, as I played rFactor one and enjoyed it very much, so went ahead and bought rFactor 2.
    However, unlike rFactor 1, it fails to start up. I open up the launcher, click a helmet, the rFactor logo appears, but nothing happens, and returns to the launcher.

    I don't know what is possibly wrong, not really into the tech side of things.
    My system requirements are all there, did many checks and even used a website they took my laptops details and said they were fine.

    Thanks in advance.
     
  2. Andrew

    Andrew
    Global Moderator Staff Premium Member

    - Run the launcher with Admin privileges

    If you do not have the DirectX runtimes installed, rF2 will not start. To test this is the problem you can run the rfactor2.exe in the core directory, and an error will popup.

    Quite often, there could also be a mis-configuration with a third party mod. You should try rFactor 2 without any third party content before coming to us for support with this issue.

    You should make a trace of the rfactor2 startup.
    1. In rF2 Lauchner go to "Advanced" tab
    2. write trace=100 in "Additioncal Single Player Command Line Interface Parameters" input field under "Single Player"
    3. lauch rF2 Single Player from "Simulate" tab
    4. open explorer and go to ..../rfactor2/userdata/log
    5. open the logfile trace.txt
     
    • Beer Beer x 1
  3. Thanks for your help, to run launch rfactor in the core directory is it Bin32 or Bin64 folder? If so I can't run rfactor through this.

    Will try the second step, looks a bit confusing for me :roflmao: Will give it a go!

    Edit: I can't get the second part to work either.
     
    Last edited: Jun 8, 2015
  4. Dylan, I've had this same issue when connecting the sim rig with another PC. It can't handle the resolution. Now I'm sure you are not connecting via any other PCs but the symptoms being the same, it may be struggling to set the display based on what you set in the video options.

    Click the cog and then video settings and see if you can get it to match or be close to rF1.
     
    • Beer Beer x 1
  5. Gijs van Elderen

    Gijs van Elderen
    Premium Member

    You'll need to start the rFactor2 via the launcher. Starting it by clicking on the .exe file in the BIN32 or BIN64 folder won't work.

    Try to install a new rFactor2 "lite" install. But not in the C:/programs/.... folder.
    But in C:/rFactor2 or on a other HHD D:/rFactor2 if you want.
    That way you'll bypass the "run as administrator" problems.

    If that install is working, delete the other one. Tip: Don't use the un-installer. :whistling:

    - Download the rFactor2 lite install: click here

    To run rFactor2 in single player mode, you 'll need to install content first.
    - Download ISI content: click here
    - Put the .rfcmp files in your packages and install them in the launcher.

    To run rFactor2 in multiplayer you don't need any content installed. :geek:
    If the server is setup correctly ==> all content you need for that server will download upon server login. :) But entering a correctly setup server is a hit and mis... :sick:
     
    • Beer Beer x 1
  6. I tried this unfortunately to no luck, I ran rF1 on Max
     
  7. Tried this still no luck on my end. As soon as I click single player or muliplayer, the rfactor logo pops up, then quickly reverts back to the launcher with no loading of the sim.
     
  8. I've seen many problems with laptops, rF2 isn't really software that runs well on laptop unless it's a fairly new gaming laptop. New laptops usually have 2 GPU's: one integrated with CPU and one external. Most games lets you choose which one to run by right clicking icon. This is probably what causes the problem for you, rF2 getting confused by these 2 GPU's. Check the video settings from settings tab of rF2 launcher and see which GPU name is detected.
     
    • Beer Beer x 2
  9. I'll have a look when I go home, so look at the video settings in the launcher?
     
  10. I changed the default GPU to Nvidia, still no luck

    Edit: This is my log
    Code:
    TRACE LEVEL = 100
    tracelog.cpp  139: Command line: "+path=".." +hash=####HIDDEN#### trace=100"
    main.cpp      365: Version=1.946 Build=946
    main.cpp      366: FPU=0x0008001f
    game.cpp     1375: Setting Mod Path "Packages" 1 0
    game.cpp     1765: Entered Game::Enter()
    osman.cpp     901: Entered OSMan::Enter()
    osman.cpp     963: exe is 64-bit
    hwinput.cpp  7629: Entered HWInput::Enter()
    hwinput.cpp  7630: HKL=0x08090809
    plrfile.cpp  2927: Entered PlayerFile::Enter()
    game.cpp     1017: Setting RFM "ALL_TRACKS_AND_CARS_10.RFM"
    plrfile.cpp  2084: Attempting to save to C:\Rfactor 2\UserData\player\player.TMP
    plrfile.cpp  2108: Retcode: 0 for renaming to C:\Rfactor 2\UserData\player\player.JSON
    PluginManage  317: Analyzing plugin "TrackIR_rF2_Plugin_x64.dll"
    PluginManage  356: Successfully loaded plugin "TrackIR_rF2_Plugin_x64.dll"
    vidman.cpp   1876: Entered VidMan::Enter()
    game.cpp     2599: Entered Game::Exit()
    sound.cpp    1694: Entered Sound::Exit()
    specialfx.cp 4529: Entered SpecialFX::Exit()
    hwinput.cpp  7924: Entered HWInput::Exit()
    dynman.cpp   3031: Entered DynMan::Exit()
    render.cpp   2858: Entered Render::Exit()
    onscreen.cpp 3720: Entered OnScreen::Exit()
    vidman.cpp   2865: Entered VidMan::Exit()
    osman.cpp     971: Entered OSMan::Exit()
     
    Last edited: Jun 9, 2015
  11. What about windowed mode instead of fullscreen?

    You can get a more detailed log with the switch trace=3 instead of 100
    The next part in my log is the controllers setup.

    Also Dylan, can you show us a screenshot of the config screen, that will save a bit of back and forth.
     
  12. Setting trace to 100 is overdoing it a bit. There are not that many trace levels in rFactor. Retail versions only go up to 3. :)
     
    • Beer Beer x 1
  13. That's not entirely true either, since 100 > 3 you will see all messages at trace levels 1 to 3. It's a bit overkill because there are no higher level messages though.
     
  14. Judging from the trace log the last thing rFactor 2 does before it stops is to initialize the video related code (VidMan::Enter()). I agree with some of the other posters here to try different video settings, and try running it in a window. A lot of errors when initializing the video will display a dialog message, but there are a few that silently fail.
     
  15. This is my config
    Code:
    //[[gMa1.002f (c)2015    ]] [[            ]]
    [COMPONENTS]
    LanguagesFile=GAME.DIC
    CPURating=1
    SystemRAM=0
    VideoRAM=0
    ObjDetail=1
    TexDetail=1
    VideoGUID=GAME.DIC
    VideoDriver=0
    VideoMode=0
    VideoRefresh=0
    WindowedMode=0
    Borderless=0
    RunBenchmarks=1
    FSAA=0
    VSync=0
    UsePostFX=0
    UseHDRProcess=1
    ShaderLevel=0
    SubViews=0
    WidescreenUI=0
    WidescreenUIWidth=-1
    WidescreenHUD=1
    CustomVidRes=(0, 0)
    MinimumVidRes=(800, 600)
    MaximumVidRes=(8000, 6000)
    
    [INSTALL]
    InstallFrom=
    InstallTo=
    
    [AUTOLAUNCH]
    Mode=Off
    LaunchTime=600
    
    [VERSION]
    Version=-1.000000
    I have tried all the video settings bad sadly the same issue occurs.
    Maybe I should just go out and buy a computer.
     
    Last edited: Jun 10, 2015
  16. I can confirm that the game now runs fine, rookie error, the nvidia drivers were not up to date.
    Thanks to everyone that helped, now looking to get up to speeds and get in some races!
     
    • Winner Winner x 3
    • Like Like x 1
  17. Oh mate, I forgot to revisit this thread yesterday. Happy you now have it sorted.
     
    • Like Like x 1
  18. David O'Reilly

    David O'Reilly
    A bad quali means I can go forwards in the race.

    I'm looking forward to it too buddy!
     
    • Like Like x 1
  19. Hello
    I bought yesterday this sim(1008), but no way to start 64bit (default). No way....
    tried everything uninstalled, deleted all the reg keys, reinstalled ... nothing
    updated graphics driver, nothing
    no way..
    All other running programs are fine
    AC, Pcars, DyrtR, SCE, LFS, and many programs ...
    no way
     
  20. What do you mean by "no way" exactly?
    Have you run the launcher?
    Does it not get to the loading screen?
    Does it not get to the Menu screen?

    more information needed please