1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RBR Controller Config Problem

Discussion in 'Richard Burns Rally' started by David Lavenhagen, Dec 15, 2014.

  1. I just bought RBR yesterday and have run into a fairly significant problem.

    Wheel: CSW V2
    Pedals: HE Pro Pedals

    When I go to assign controls, the steering axis defaults to the X-Axis (my clutch) when both the wheel and pedals are plugged in. If I try to reassign the steering axis, it does not recognize my wheel by turning it.

    If I unplug the pedals and assign controls, the steering axis is assigned to my wheel and works but then I cannot assign pedals (as they are unplugged). If I back out and "discover devices" after plugging the pedals back in, the steering axis is once again assigned to the X-Axis (my clutch) and I have no way to assign the wheel to the steering axis.

    Anyone have any ideas for this one? I have tried lifting up on all pedals before entering the assign controls area thinking the load cell was registering something and even assigned a dead zone in the clutch pedals through the Windows Controller app but that did not work.

    Any help would be appreciated. Anyone using the same setup (CSW V2 and HE Pro Pedals)?
  2. Michael Nelson

    Michael Nelson
    Premium Member

    Hmm, that's a strange one. It seems like RBR is only recognizing one device at a time, but I've successfully used two separate devices with it in the past. A couple of things to try:
    1) If you have any other controllers plugged in, remove them and see if it works now.
    2) Try inserting your devices into different USB ports, sometimes they can glitch up.

    I assume the wheel + pedals works fine with other games?

    Oh, and also try installing both the patches for RBR, I wouldn't think it would help, but it wouldn't hurt to try.
  3. OK. I will try this weekend. I had bought RBR and then downloaded and installed RSRBR 2015 so I think the patches were also installed.

    It recognizes both controllers when they are plugged in because I can map wheel buttons as well as pedals. I just cannot map the wheel when I try to reassign the steering axis (that defaults to the clutch travel with both the wheel and pedals plugged in). If try to reassign, and turn the wheel so RBR can recognize the wheel movement, nothing happens. BUT, if I unplug the pedals and start over, the steering axis is assigned automatically and is correct (I can see the steering axis bar move while turning the wheel).

    I am stumped. I will try different USB ports. I do have a wireless mouse/keyboard receiver but I need that plugged in to make the adjustments...
  4. Tried fresh install. Tried unplugging only the clutch. Tried different USB ports. I can get the wheel to work when the pedals are not connected but cannot get the RBR to reassign the wheel axis if both pedals and wheel are plugged in at the same time. Really don't see a solution to this. It's really a shame as I would LOVE to play this.

    Please if anyone has any other ideas I would appreciate it.
  5. I am having the same issue! I am using a CSW V2 with MPPC pedals and Fanatec handbrake. The wheel and the handbrake want to occupy the same x-axis when both are plugged in. The wheel is properly recognized when I unplug the handbrake. Arrrrggggghhhh!