1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

RBR and CSW

Discussion in 'Richard Burns Rally' started by Simon Hodge, Sep 16, 2012.

  1. Hi Guys,

    I've just re-installed RBR on my new computer and get no FFB from my CSW. I have install in a different location i.e. no x86 directory. Also installed the update but have no luck.

    Any ideas??

    Smudge
     
  2. Warren Dawes

    Warren Dawes
    Premium Member

    I assume you are referring to the Official Patch 1.02 ?
     
  3. Yes.

    My CSW has now died so plugged in my old g25 and all works fine. Will have to try again when my new CSW base arrives
     
  4. Still the same - works perfect with my g25, received y replacement CSW base and tried RBR no FFB, mmmm really stumped on this one!!!!

    Ideas??
     
  5. Warren Dawes

    Warren Dawes
    Premium Member

    Very strange one. :confused:
    I know it probably doesn't help you, but I use a Fanatec GT3 Wheel and it works ok with RBR.
     
  6. Yes, GT3 RS is fine here too. With CSW FFB doesn't work though on PC mode. I noticed that if you delete the Steering mapping (Wheel Axis), you can't remap it with the CSW steering axis, the mini joystick Ry or Rx can be mapped to it though. If you reset to defaults, the wheel axis is mapped again and you can steer the car, still no FFB however.
     
  7. Warren Dawes

    Warren Dawes
    Premium Member

    If true, that is a huge deficiency for such a new Wheel. :(
    Has anyone contacted Fanatec about this, I know RBR is fairly old now, but being such a popular "classic", surely their new wheels should support FFB in RBR?

    Has anyone tried any of the "new" Drivers and / or Firmware with the CSW to see if it helps?

    http://www.911wheel.de/?q=blogs/thomas

    EDIT: Did some searching through the Fanatec websites, all I found was this post which is very recent but not answered yet:

    http://www.911wheel.de/?q=node/9070
     
  8. I've used 32 firmware and 132 & 140 drivers. These are really the only ones publicly available since CSW launched. The firmware the wheel base shipped with can't be reverted back to therefor.

    Now that I've personally tested it, I can say FFB works if you use Logitech drivers in PS3 mode. For this to work you need to uninstall Fanatec driver. For other games you can reinstall Fanatec driver and leave the Logitech driver installed as it won't be used unless you try switch to PS3 mode (and you can't with Fanatec driver installed).

    Might contact the official support at some point, but I'd guess they already know about it.
     
  9. Little follow up. I remapped all the controls when I went PS3 mode, didn't redetect devices on RBR. Now I installed Fanatec drivers back while keeping the Logitech ones as well (shouldn't matter though). FFB now works with Fanatec driver and PC mode. I still can't remap the Steering Axis, but there's no real need as it works. All my mappings were recalled from the time I used the Fanatec driver the last time. On PS3 mode you have limited number of buttons, so it was bit different there.

    [HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_0EB7&PID_038E]
    "OEMData"=hex:03,00,88,11,7c,00,00,00

    Has now changed to
    "OEMData"=hex:43,00,88,10,13,00,00,00

    Last 4 bytes is amount of buttons, 0x7c = 124 which around what CSW supports in theory. 0x13 = 19 which matches to button amount I have in PS3 mode. Not sure what the first 4 bytes are, likely axis flags, but I didn't see recent information on my quick search. The whole OEMData entry matches to G25 one now, don't think it's a coincidence. Same reg location on HKLM still has the old data, but I think RBR only reads from HKCU. All the buttons (>19) still work on the wheel in RBR, so it's bit of a mystery right now though.

    Edit: No point triple posting, so I'll just small edit here. Seems it's enough to just change the first byte, ie. "03" to "43"

    Had DX 8.1 SDK installed, so looked a bit on dinput. Seems to be this flag which you need for RBR. Shouldn't be issue with other games as Logitech devices already have it set by default.

    Code:
    #define JOY_HWS_ISCARCTRL      0x00000040l    /* joystick is a car controller */
    
     
  10. I appreciate the time and trouble you went through to post that. I'm running a 911 Turbo wheel (not "S") with latest everything. Win 7 Pro 64 bit. My OEMData is exactly the same as yours...

    "OEMData"=hex:43,00,88,10,13,00,00,00
    And FFB is still VERY weak in RBR/RSRBR. It IS there though... I can feel it a bit especially if I go off the road but the road surfaces themselves, jumps, crashes, etc. are like there is no FFB at all.

    Wheel works beautifully with RF1, RF2, GTR2, RACE (all of them), pCARS... hard hits will just about rip the wheel out of my hands in Rally World (rfactor 1 mod with realfeel). Wish there was a way to fix this...

    I REALLY want to like RBR. :(