1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Race On - Help with start lights!

Discussion in 'Bob's Track Builder' started by Chris Mackenzie, May 10, 2010.

  1. Hi all,

    I'm currently building a fantasy track and seem to be well into the later stages of creating the track (adding objects etc etc) however during my testing sessions, after adding start lights I've noticed that they dont actually "Start" the race.....the lights go green and there is a slight delay (maybe 2-3 seconds) before the opposition cars start moving......

    Quite frustrating, using the lights to start (like you should) you will end up rear-ending the car in front as they sit there......wait for them to move and youll be left behind or even shunted from behind.....

    Any advice on how to rectify this issue?

    Cheers,
    Kiwidemon
     
  2. I didn't write this, I'm not sure who did but this fixed my lights in GTR2.
    Not sure if it will work in Race/Evo but worth a try.

    -------------------------------------------
    Copy all 6 of the start and pit light files and there textures to a temp folder.
    copy all the new textures to the same folder.
    -------------------------------------------

    rename .gmt's to GTL format as follows

    rFactor - GTL/GTR2
    ===========================================
    STARTLIGHT.GMT - OBJ_STARTLIGHT.GMT
    STARTGLOW.GMT - STLITE.GMT
    PITLIGHTOUT.GMT - OBJ_PITLANELIGHTS01.GMT
    PITGLOWOUT.GMT - PTLIT01.GMT
    PITLIGHTIN.GMT - OBJ_PITLANELIGHTS02.GMT
    PITGLOWIN.GMT - PTLIT02.GMT

    -------------------------------------------

    Change material settings as follows

    -------------------------------------------

    OBJ_STARTLIGHT.GMT

    Material names grlta, rdlta, rdltb, rdltc & rdltd
    In "Cube Map" box untick "Enabled" (Unless you have a cube map in the ~Maps.GTL/GTR)
    In "Animation" box Delete numbers in "Sequence" & change "Event" to "None

    -------------------------------------------

    OBJ_PITLANELIGHTS01.GMT

    Material names grpitlta & rdpitlta
    In "Cube Map" box untick "Enabled" (Unless you have a cube map in the ~Maps.GTL/GTR)
    In "Animation" box Delete numbers in "Sequence" & change "Event" to "None

    Material name ylpitlta
    Change Material name to blpitlta (not really needed but looks neater)
    In "Cube Map" box untick "Enabled" (Unless you have a cube map in the ~Maps.GTL/GTR)
    In "Animation" box Delete numbers in "Sequence" & change "Event" to "None
    In "Texture" box click ylolt.dds and choose blolt.dds

    --------------------------------------------

    OBJ_PITLANELIGHTS02.GMT

    Material names grpitlta & rdpitlta
    In "Cube Map" box untick "Enabled" (Unless you have a cube map in the ~Maps.GTL/GTR)
    In "Animation" box Delete numbers in "Sequence" & change "Event" to "None

    ---------------------------------------------

    STLITE.GMT

    Material names rdltglowa change to stlita
    In "Animation" box change "Sequence" to 0011110

    Material names rdltglowb change to stlitb
    In "Animation" box change "Sequence" to 0001110

    Material names rdltglowc change to stlitc
    In "Animation" box change "Sequence" to 0000110

    Material names rdltglowd change to stlitd
    In "Animation" box change "Sequence" to 0000010

    Material names grltglowd change to stlite
    In "Animation" box change "Sequence" to 0000001

    ----------------------------------------------

    PTLIT01.GMT

    Material names gpitglowa change to ptglit
    In "Animation" box change "Sequence" to 01234
    In "Texture" box click grnglow.dds and choose ptglit.dds

    Material names rdpitglowa change to ptrlit
    In "Animation" box change "Sequence" to 43210
    In "Texture" box click rdglow.dds and choose ptrlit.dds

    Material names ylopitglowa change to ptblit
    In "Animation" box change "Sequence" to 43210
    In "Texture" box click yloglow.dds and choose ptblit.dds

    -------------------------------------------------

    PTLIT02.GMT

    Material names gpitglowa change to ptglit
    In "Animation" box change "Sequence" to 01234
    In "Texture" box click grnglow.dds and choose ptglit.dds

    Material names rdpitglowa change to ptrlit
    In "Animation" box change "Sequence" to 43210
    In "Texture" box click rdglow.dds and choose ptrlit.dds

    -------------------------------------------------

    In the .TRK delete all the entries for the original start/pit lights and there glows and replace with


    Instance=obj_startlight
    {
    VisGroups=(32)
    MeshFile=obj_startlight.gmt CollTarget=False HATTarget=False
    }
    Instance=stlite
    {
    VisGroups=(32)
    MeshFile=stlite.gmt CollTarget=False HATTarget=False
    }
    Instance=OBJ_PITLANELIGHTS01
    {
    VisGroups=(32)
    MeshFile=OBJ_PITLANELIGHTS01.GMT CollTarget=False HATTarget=False
    }
    Instance=ptlit01
    {
    VisGroups=(32)
    MeshFile=ptlit01.gmt CollTarget=False HATTarget=False
    }
    Instance=OBJ_PITLANELIGHTS02
    {
    VisGroups=(32)
    MeshFile=OBJ_PITLANELIGHTS02.GMT CollTarget=False HATTarget=False
    }
    Instance=ptlit02
    {
    VisGroups=(32)
    MeshFile=ptlit02.gmt CollTarget=False HATTarget=False
    }

    ---------------------------------------------------
     
  3. Hi Eric,

    mmh, maybe I'm stupid, but how can I modify a gmt-file?
     
  4. I have had very good luck with 3DSimEd http://www.sim-garage.co.uk/

    Dave Noonan keeps it up-to-date & relevant and many excellent tutorials are available. Highly recommended!

    Good luck :)
     
  5. You can use 3d simed as gwaldock has suggested.
    Otherwise you need to import it into 3ds Max & modify it there & re-export.
    There is a thread about importing to max on this forum somewhere.

    Simed is probably your best bet.
    Try the demo.
     
  6. stevem

    stevem
    GearGrinder

    To just fix the BTB default start light:
    After exporting track to GTR2, open trk file in 3dsimed, open material editor and add an extra 0 to the beginning of the red lights a,b,c,d and red light glow a,b,c,d and green light and green light glow sequences. then save to mas folder and replace "trackname".gtr file
     
  7. I'm using BTB Evo and the lights don't export correctly - I was having the same issue where the green lights would turn on too soon.

    I have been able, however, to get all of them working correctly except the yellow flashing PIT out lights. All I had to do was, in BTB, open up the "Edit Materials" and change the "Frame Rate" from "1" to ".02" on all the GLOW properties. Works perfect now. I'll post again when I get the Pit Out yellow light to flash.
     
  8. There is an Xpack for BTB Evo, the sequencing for the lights are different to the Pro (rFactor) & so Evo Default Xpack has had them fixed by Kennett...
    Try deleting current lights & add new ones from Evo Default Xpack;)