• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Problems detecting TS PC RACER, but only with Dirt Rally

Discussion in 'Sim Racing Hardware' started by Elaphe, Nov 4, 2017.

  1. Elaphe

    Elaphe

    Messages:
    123
    Ratings:
    +24
    I have Windows 7 and the wheel in installed and detected correctly. One thing that is a bit weird is that when you run Gaming Devices and double click (or click properties), the control panel takes 15 seconds to open. Does this happens to you? Apart from that the wheel works like a charm in Assetto Corsa. With Dirt Rally the problem is not that it works bad; the problem is getting the game to detect it. After many tests, the only way to make it work with this game is to reset my computer. I think this has something to do with USBs. If the wheel is detected, when I enter controls, I can see my settings saved and I know everthing will work. However, most of the times, when I enter controls I see the default keyboard preset. Then I know the game has not detected my wheel and I need to reset. When the wheel is detected, in the presets section I can see LNG_TM_PCRACER together with other direct input devices, all configured as wheels (Fanatec pedals, HE shifter, analog handbrake and button box). Do you have any idea how to fix this and make my wheel work always with this game? I don't know if this has to do with hardware, software, drivers, usb, the game itself, configuration... I've tried using different ports and different USB hubs. It seems that when I change it from port and it's re-redected by Windows, then it's detected by Dirt Rally too.
     
  2. Elaphe

    Elaphe

    Messages:
    123
    Ratings:
    +24
    I have found a way to make the game always detect my wheel: plug all my devices into my USB hubs before starting my computer. That way the TS PC Racer is detected, as well as the rest of peripherals, and the stored input config is automatically loaded. If any of the control devices is not connected, the game will not load the stored config. I'm not sure if the steering wheel has to be joy1, but I'm using a utility called JoyIDs to be able to control de gaming devices numbers. Be also aware of mods that prevent the game from saving configs.
     
  3. Gaudin

    Gaudin
    Premium

    Messages:
    86
    Ratings:
    +64
    Similar setup here: TS PC-Racer, g27 shifter, g27 pedals, fanatec handbreak - everything works as it should, once the wheel is calibrated and the buttons assigned (its a new game with this wheel, the forces that occur if you get it wrong, holla, nearly snapped my thumb off)

    But: everytime I take the Wheel from the power supply (via WIFI-Switch) next time Dirt Rally starts up, no wheel detected - manually I can then recalibrate it and sign the buttons - then it's fine again.
    As I'm not often shutting down my pc, not the exact same problem, but kind of! It's a bit annoying, because DR with this wheel ist just nuts, so much more feeling for the car now.
    An USB hub will probably not solve my problem, I hope to find a solution otherwise, elsewhere...