1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Problem with Track Texture

Discussion in 'Bob's Track Builder' started by GandalF, Apr 3, 2011.

  1. Hi,
    I've a problem on my Track.. After I exported my track from BTB to rFactor, I've a another black texture (I don't know what it is..^^) on the right side of the track.. Anyone know what it is / can help?

    Here's a picture: http://img821.imageshack.us/i/grab000z.jpg/

    Sorry for my bad english!
     
  2. Looks like you've got two textures on your track. Did you make a copy of the track previously? Sometimes if you copy a track, you can turn its visibility off in BTB but it will still export to RF.
     
  3. I don't have make a copy of the track.. In BTB I see the "normal" street texture not the black texture on the right side of the track, but I see it in rFactor, I don't know why.. Thanks for the reply, any other ideas?
     
  4. I have similar problems,black squares with objects,i was think that i solved problem, but from time to time black problems returns
    Try this,in xpacker go to texture button,in section Path / Name add some letter to turn on save button, save and export your xpack to btb.With this i solved my problem for now,with ground textures,but if someone knows what happens with object ,please write somethyng.
    I was discover that when i change name of texture that can create problems,but im not sure for anything now
     
  5. Try to set these suspect materials as Double Sided (in XPacker or in btb's 'Edit Materials') - maybe some polygons are back faced. Also - check textures for transparency - you don't need any for roads, if there is an alpha channel - delete it and export files again. DDS format always works the best. One more thing is texture names - btb is case sensitive...
     
  6. Another material setting worth looking at is the Emissive colour. Anything other than pure black will override normal lighting conditions, so it could have been set to 'almost black but not quite'.
     
  7. It's probably caused by the texture dimensions. Height and width must both be powers of 2.
    2, 4, 8, ... 256, 512, 1024 etc
     
  8. Now I've switched the height and width to 256x512 , but I've the same error when I'll loading the track..
     
  9. Great thanks!!
    Now it works fine, no problems. I also downloaded your DDS Batch Converter, but I see this is for 32 bit systems, do you think it work on 64 bit systems?
     
  10. Hi everyone !

    I'm new in the modding world and I just exported my first track from BTB to rFactor. But whenever I want to load the track I get a gMotor 2 error : Error loading texture texture31 for material roada12.

    I'm a real beginner, I searched on the internet and on forums to find out what's my problem but I can't find anything.

    Any help would be appreciated, thank you :)
     
  11. This more than likely means that 'texture31', whatever that may be, is missing from your track folder and therefore rFactor can't locate it.

    Or your SCn file is not pointing to the correct folder(s) :)
     
  12. How many mips did it have though? Sometimes with too many mips the game tries to load a 0x0 texture.
     
  13. Hmm, yeh, would go down to 2x4.

    For DDS exporting I can't recommend Photoshop with the plugin enough. I see many problems with other programs, but experience none with PS.
     
  14. The DDS plugin for PS is very good - making bump maps needs some experience and I suggest to save the default profile somewhere - if I was making bump maps, all diffuse maps were broken. So, in that case I had to reload initial plugin settings to save them correctly.
    By the way - how to check the number of mip-maps - I switched off the first pop-up window (when opening some .dds in PS) with the option "Load mips" - can't load them anymore (e.g. to see how many of them are inside) ;)
     
  15. Hmmm I have no problem making bump maps with the Normal Map Filter.
     
  16. Kyle Puttifer

    Kyle Puttifer
    @ Simberia @Simberia

    You can use CrazyBump to generate bump and specular maps.
     
  17. I mean when I make some bump map and after this I want to create some other diffuse (any other, or the same), the diffuse looks very bad - the only solution for me is to load (saved earlier) default profile - the very first I had after installing the plugin. I have PS2, maybe on other versions there are no such problems.
    I will try that Crazy Bump, thanks Kyle :)