1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Placed Pit Garages - Rfactor Crashes... Please Help!

Discussion in 'Bob's Track Builder' started by Drummer, Aug 29, 2012.

  1. Hi again folks,

    It seems I keep coming here and pestering people for help with this circuit project; sooo many things keep going wrong and I'm losing tons of hair! X-(

    Ok, to the point: I've made a pit garage prop in AC3D and placed a couple of very basic texture files on it (one plain red, the other plain grey) just to check that everything fits nicely in Rfactor. My circuit begins to load and then crashes, every single time! To begin with, I was using really high-res textures and I thought this was what was causing the crash, so I switched to tiny files to check this and, while it's still crashing, it appears to have changed something, because the progress bar doesn't reach nearly as far as it did with the large textures.

    If anyone can shed a little light on this one, I'd be very grateful! Could it be the meshes? They're not overly detailed yet, but I'm hoping to make them so if their basic structures fit well with the rest of the venue's style.

    Thankyou for reading!

    Glen.
     
  2. Richard Hessels

    Richard Hessels
    Premium Member

    Your textures have the power of 2 size and are saved as DDS or TGA ?
    Random examples of texture sizes that are compatible.
    16x16
    32x32
    64x256
    128x128
    256x512
    1024x1024
    512x2048

    They will load fine in bobs when the size is not valid, but not in rFactor.
     
  3. Hey, thanks for your reply, Richard! :)

    Originally, I was using enormous textures, which weren't square, weren't to the power of two and weren't very ideal for what I needed, so I replaced all textures with 512x512 blank colour ones, but it's still having none of it. Also, I doubt it'll be the poly count of my garage models as it even crashes with just one garage there. Although, having said that, a lot of my terrain is fairly well up there with regards to poly, but it always has been and I've not had this issue before.

    Also, because I wanted to get on with things and see what the general idea of the circuit being well furnished would look like, I used some Xpacks that are available here; being pit garages with grandstands, normal grandstands, chain link fences, cones, block barriers, wooden fences and portable 'marshal' railings. I also used the pit in/out lights and start light on gantry that's default in BTB. What's happening now is that I'm able to drive the circuit, both alone and with AI, but at the very end of my out lap, Rf appears to minimise and won't re-open, forcing me to ctrl+alt+del and end the process tree, as even ending just the process or task does nothing; it completely freezes my system up.

    I stress that the only new things I've used this time have been Xpacks from other people, which are available here. Here are the links to the only new things I'm using (anything else on my circuit has already been successfully tested before...)

    http://www.racedepartment.com/forum/microdownloads/grandstand.48/viewfile

    http://www.racedepartment.com/forum/microdownloads/ennis_objects.50/viewfile

    http://www.racedepartment.com/forum/microdownloads/great-britain.52/viewfile

    http://www.racedepartment.com/forum/microdownloads/haywood.54/viewfile

    http://www.racedepartment.com/forum/microdownloads/chainlink-fence.64/viewfile

    http://www.racedepartment.com/forum/microdownloads/crowds.66/viewfile

    http://www.racedepartment.com/forum/microdownloads/haywood_club.77/viewfile

    NOTE: I tried out the Haywood curbs, but decided to go with my original ones, so I'm not sure if perhaps they have left something behind after replacing them, so I've included those in the list anyway. Maybe I could send the project to someone and have them take a look? I might start a WIP topic today, with some BTB screenies, so as to raise some awareness and hopefully get a helper on board, as this is proving to be a lot of work for just little old me. If anyone fancies taking up a fictional Donington/Knockhill/Oulton-themed park circuit that is to have tons of detail, please let me know; I'd be thrilled to have a skilled person to work with!

    Many thanks,

    Glen.
     
  4. Hmmmm, I might need to eat a bit of humble pie here... It seems that it's my light gantry after all, which is surprising, as I've tested it day and night, with other cars and without and it's been fine, it just lags the bum off the game now and it crashes! I guess it was working ok when I didn't have all that other stuff cluttering up my pits straight, but the game is struggling now with all the surfaces. :( Right, well, back to the drawing board with my garages and gantry then, as if there's much else there that I've made myself. :(

    Tankyou!

    Glen.
     
  5. textures do not need to be 2x2, they can be any of the above as long as you use the proper values.. 1024 x 256, 512 x 128, 256 x 512, and so on.. as long as you have the right size.
    it starts at 32 and doubles every time you increase the size. never tried to use 16, 8, 4, or 2, but ya never know.? for a solid color, i would go as small as i could, as long as it didn't use a bump or spec map.
     
  6. Ok, thankyou for the advice, I'll copy it to a document so I can refer back to it later; numbers mean completely nothing to me at the best of times, lol. I still think it's something to do with the mesh though, because I've used these exact materials in other objects and they've worked fine. I don't know, I'll have to try and work it out, or just start all over again with the garage models. :(
     
  7. if you remove the mesh from the .scn file, will the track load fine.?
    if the track loads without the mesh added to the .scn the only thing i can think of is,
    if the texture is a .dds file, it might not have been saved properly, i have had a dds file cause this before, i opened it up in photoshop and save it and then it worked fine.
    or something may be wrong in that line in the .scn file.
    Never heard of a mesh not loading because it's too big.
    i have a 1 gmt of a building that is over 27,227 faces, and it loads fine in rF.

    when the track stops loading, you can Alt + Tab to bring rF to the task bar,
    then click on rF to open it again you will get the error message.
    the only time this does not work, is when your in the game and it locks up.
     
  8. I've never done this, so I don't know... How would I go about doing this, please? I've never messed with the .scn files.

    It seems to kill Rfactor completely with the garages. With the light gantry, it was different, it just minimised Rf and wouldn't let me reopen it, but with the garages it begins to load the track, then *POOF* disappears in a puff of smoke, as though I never had it there in the first place, lol!

    Thankyou for your help.

    N.B. Maybe you'd like to try my garages out? I'd be happy to send the files to you, if that's something you could do? I'm also looking for a partner to work with me on this project, if you know of anyone? :)
     
  9. if you like, pack up 1 garage with textures and post me a link here,
    and i'll see if there is a problem. don't send the track, just the garage.
     
  10. Thankyou very much. I've posted a link to your profile. :)
     
  11. i'm getting a dead link, error file not found.
    try Mediafire, i think it's the best for small files. free for anything under 200mb
     
  12. Ah, yes, it does that because it puts spaces in the link, which is weird. The whole link is there, it's just it needs to be highlighted and either copy/pasted into the address bar or right click and 'go to:' Make sure you highlight the whole link, along with "Wheldon Park Modern Garages.zip" I'm sorry for that, it's weird like that sometimes.
     
  13. i'm sorry.. i wanted the mesh in gmt format, not in a xpack.
    send me the mesh your having trouble with.
     
  14. Hi, sorry for the late reply. I've no way of creating a GMT file I'm afraid. Don't worry, I'll start again, from scratch.

    Thankyou anyway! :)
     
  15. I think he means he wants the .gmt from your track's folder :p.
     
  16. Gotcha! Ok, thankyou. Well, actually, someone's already managed to get them loading fine, so I guess that's not the issue... Oh, I don't know, all this 3D and computer malarky is confuzzling! :-/ Let's just see where we end up, I guess!

    Thankyou all for your help and replies! We'll get there in the end, I'm sure! :)