1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Objects to BTB terrain - zaxxon method

Discussion in 'Bob's Track Builder' started by ehrlec, Feb 5, 2011.

  1. link
  2. Thank you very much! I salute to Zaxxon before I even think to start trying the method. And one more salute to you for making a big picture how it works, great! You guys are magicians :)
  3. wonderful stuff.. looks quite a job, but ill do my best.
    thanks so much for this, and the detail you have gone into.
  4. i must have messed up somewhere along the line :/

    also noticed while on this step:
    "Check Swap Y-Z axis Apply"
    it flipped the whole mesh (terrain piece) on its side. (was that meant to happen? . On your subsequent screenshots the mesh still looks like its orientated correctly)
  5. sup, yea for convenience of following the tutorial i did put that folder in d root
    the paths are correct

    I just tried it all again, but skipping the ""Check Swap Y-Z axis Apply""
    still same error, but i continued appling the scripts anyway.
    here is the log



    perhaps its something to do with the mesh itself.. ill make another later and re-test
  6. heya thanks for the help on this.. im sure ill get their in the end

    "hmm, I see the folder name as BG_Project(s) in the first image. Is it Project or Projects? "
    sorry i should have explained that. the very first screenshot i typed in an s by mistake .. i realised and corrected the mistake in that screenshot (as you can see) and the last 2 screenshots.

    The folder is how i extracted it into d:/ ie: D:/BG_Project.

    Something just occured to me regarding the mesh itself. I have been used to importing .3ds terrain pieces, that have optimized the mesh in 3ds not taking too much attention to the large polys. I relised btb mesh fills in polys that are at a certain size. Could it be that the mesh I am creating in max (and optimised so it has huge polys in low detailed areas) is un-btb compaitable? Do I have to make sure my original mesh (obj) has small enough polys so btb can import/display. Peraps btb on importing meshes (btb editable mesh) fills in the polys auto (like it dose on export). Or perhaps the script fills big polys, not sure, but perhaps thats my problem.

    I shall go ahead and pm you my .ply anyway.

    Have to go out for the rest of the day, so ill catch up with this as soon as im back this evening

    Thanks again for everything, and also zaxxon :)

  7. /heya :)

    well, the terrain piece is just an experiment on importing mesh this way, its not made to fit anything , and i wont be using it. It was simply a test. Regarding the scale.. as far as i remember i did scale it up to well beyond 1k within max, but I had to export it as a wavefront object (not 3ds since you mentioned meshlab has problems with that).. so perhaps the scale messed up on export to wavefront .obj

    Ill do it all again from scratch and take extra care this time hopefully i can get it into btb like youve done there.

    By the way.. im really surprised how well that mesh looks in btb... in max it looks really bad compared to btb.. its almost like btb is using some mesh smooth procedure.. looks amazing. I simply cant wait to get into this.. as in, making real nice realistic looking terrain mesh for btb.

    top job ehrlec & zaxxon!

    EDIT, will btb fill in polys (on this sort of imported mesh) that are too big when exporting to game?
  8. Kyle Puttifer

    Kyle Puttifer
    @ Simberia @Simberia

    This would be good to put in Simtrackipedia as well.
  9. heh, well, unfortunately im still getting those same errors with octave.. even after making a fresh terrain piece.

    One thing im a little confused by in meshlab is where the object is in 3dspace.. there dose not seem to be any coords displayed..
    Also is it possible to scale the object in meshlab? i did a search for help, cant find any reference to scaling objects in meshlab.
    I attempted to hold shift, ctrl, alt..things like that, but beacuse there are no coords to use as reference im not sure whether im simply zooming the view in or scaling the object. I saw the measuring tool, so I drew a line.. but when i then held shift the distance on the measuring tool didnt change, so i assume holding shift is zooming in on the object and not scaling it.

    anyway, im not even sure if the scale of the object is the problem.

    When you mentioned about the scale thing.. were you getting the same errors in octave? .. or did you scale the object larger in meshlab to get it thru the octave scripts

    EDIT: found the scale tools..
    EDIT2: Success! ..

    must have been something with the scale of the object.. there is one thing that is concerning me tho.. when i opened the btb project, the terrain (i used the same terrain as you).. is EXACTLY the same size as the screenshot you made.. even tho i scaled it in meshlab 10x on all 3 axis..
    Did you happen to scale the object the same as me?

    at least I can do it now.. i guess experimenting with scale and stuff is next

    I cant thank you enough for this... this method has so much potential..
    thats to both ehrlec and zaxxon.

    Im sure ill have some more questions regarding this in the future, but for now ill keep experimenting and hopefully soon ill have some interesting tracks for rbr ... (rf also, when i get around to getting it)
  10. Nice one for the info again ehrlec

    Yea perhaps the mesh was a bit over the top in terms of poly count
    I was originally trying to process a terrain piece with over half a million faces.
    The sctipt process "juntar_mallas" was showing me a processing sequence of numbers (pic i linked you to on my last post).. i was concerned that conversion of that half a million face + mesh would take days.

    I did stop the process in the end, and applied some more filters in mesh lab, managed to get it down to just over 110,000 faces, with out too much noticeable loss of quality.

    I started the scripts on that and, it only took about 5 mins to convert. I did notice tho the number sequence (juntat_mallas) completed at number 1000 ( or something) .. So i can only assume that thoses number are not an display of "faces/polys processed"

    I should have left the original "half a million face" terrain process, since i stopped it at around 900 thinking the script would take days. (i hope you understand what im trying to say :) )

    anyway, this optimized terrain looks fantastic. It did come in far smaller then i expected but I have identified what im doing wrong with scale. Heres a short vid to demonstrate the really nice realistic terrain. This is still only raw terrain, nothing as been done with it other then making a track go around it (for viewing reasons).. and also the terrain should have been about 2miles squared.. but came in at 1.3k .. (i will still use it tho, to make a short dirt track stage)

    anyway thanks so much again for everything, Im just amazed at the potential of this.

  11. I've been trying to get this to work, but there is a strange problem. The terrain I end up with is yours, rather than mine. The terrain in Meshlab is the right shape, so I think the N.ply file is okay. I put it in the s4_terrain\salida folder and then pasted in the code from the first post. I remembered to change the path on the first two lines, so I guess there's some other file in there that needs to be updated.
  12. you mean the mesh after u import into btb is the one i used?.. um odd indeed
  13. No, it's the one ehrlec used.
  14. ah right, tho that .ply i did send to ehrlec ... still strange tho... not sure where that reference is coming from... bizarre
  15. It's working now, but I'm not sure what I did. Now I keep trying to break it again to find out exactly what the cause was, but it insists on doing things properly.
  16. Pretty interesting stuff.

    However, is there a way to use Google Earth as a 1st step for creating the terrain?
  17. Thanks a lot!!
    Now on with experimenting :)
  18. Small update on this thread, pikes peak thread is here now:http://www.racedepartment.com/forum/threads/pikes-peak-climb-track-how-to.6573

    Tutorials that Zaxxon linked ion that thread: http://btbtracks-rbr.foroactivo.com/tutoriales-f31/zaxxon-s-method-tutorial-t131.htm

    Bad news is, this method is now very fragmented, a lot of info all around and some links are missing.. All Mediafire links are gone :(... Tried to start experimenting this but can't even think where to start... I declare this as dead until someone can update it.