1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New GT3RS V2 wheel is now completely unusable

Discussion in 'Sim Racing Hardware' started by David Mack, Dec 6, 2010.

  1. I have a GT3RS V2 wheel that I started using about a week ago (including the Clubsport pedals). I updated the firmware a few days ago with the 681 revision and followed the installation instructions, and the installation was successful on the first try.

    The first problem after the firmware update was the apparently very common problem of the wheel losing its centering very quickly. It got so bad that when I used the wheel in GTR Evolution and GTR2, it would lose its centering in less than a minute after getting on track. I followed all calibration instructions many times but this did not help.

    And yesterday, another serious problem started. After it goes through its power-on self calibration, if you turn the wheel at all it physically pulls itself back to the center. This happens immediately after powering the wheel up, without even loading any racing sim software. If you turn the power off the wheel seems to turn as it should.

    I've uploaded a video showing this problem, here:

    * http://www.flickr.com/photos/24899245@N07/5232312452/

    I'm posting this problem here because I'm not sure how to even proceed. The wheel is obviously malfunctioning and needs to be returned and replaced.

    I'm hoping that Brian, who is very helpful with Fanatec issues, can contact me here or via email at david_mack@charter.net as quickly as possible, it will be appreciated (I have also posted about this problem on the Porsche 911 Wheel Fan Club forums to see if Fanatec support replies). The wheel is completely unusable at this point.
     
  2. Kevin Ascher

    Kevin Ascher
    #47 Roaring Pipes Maniacs

    I had similiar problems with my GT3RS V1 wheel and solved it by buying a new PCI USB card for my computer which I only put the wheel's USB plug in.
    These cards should be a vailable for about 10€ at your local pc shop.
     
  3. Thanks, but I have about 8 USB ports which include two add-on ports so I wouldn't say that is the problem...I've plugged the wheel into every one of them, both the on-board and add-on USB ports, with the same result.

    btw, a few minutes ago I started up the wheel (it did the same auto-calibration behavior as in the above video) and set the drift function to 5 for the easiest steering force, set the FF on the wheel to 20, set the Shock to 20, loaded up GTR2 and set the in-game FF to "low" and FF strength at 20.

    Not only was the wheel very hard to turn, there's now a grinding feeling around the center, and it snaps back to the center if I don't hold the wheel tightly. Within 30 seconds I had to keep the wheel turned about 30 degrees to the left to go straight, and a minute later the shifter paddles stopped working completely.
     
  4. ReDi

    ReDi
    Slightly Mad Studios

    Is the auto-centering spring option turned on in the Porsche Wheel Properties?
     
  5. ReDi, do you mean the "SPr" setting on the wheel itself?
    fanatec_wheel_spr.jpg

    If so, it is set at 0.

    If you mean the wheel's Properties that are shown in the Windows 7 Game Controllers window, I don't see any listing for the auto-centering spring option.

    But again, please note that the paddle shifters are no longer working or being recognized in either GTR2 or GTR Evolution. In fact, as of now the wheel itself isn't being recognized in either program anymore. For example, I cannot assign Steering Left or Steering Right anymore...the controller assignment screens don't respond when I turn the wheel right or left, or if I try to assign Shift Up and Shift Down to the paddles.
     
  6. ReDi

    ReDi
    Slightly Mad Studios

    Strange! The wheel update went fine all the way, i.e. both steps finished successfully with a finalwheel re-initialization?

    Is it possible for you to revert to an older firmware version?
     
  7. Yes, I followed the steps exactly as provided in the firmware download, and the wheel was working fine afterwards. It's only been in the past two days that the wheel has basically died.

    I can try installing an older firmware revision if you can point me to a download link. However, I very seriously doubt this is a firmware-related problem, because the wheel was ok for several days after I did the update to the 681 firmware version. To me it seems much more like the wheel has mechanical as well as electrical problems, but I don't know the details on how the wheels work.
     
  8. Earlier today, I rolled back and installed the older firmware rev. 678, which seems to have fixed the auto-centering issue in the video shown in the original post (btw, having to search through a blog to find this firmware download link, and not having it on the main Fanatec Support page is completely absurd). All installation instructions were followed exactly. I then uninstalled and reinstalled the latest drivers, ver. 104. The auto-centering spring feature is unchecked in the wheel's property page and the "SPr" setting on the wheel is set to the default of 0.

    I loaded GTR Evolution and configured the wheel there. The GTR Evo FFB settings were all set to very minimal values. The wheel's FFB and Shock settings were set down to 20, Drift was set to Off, Deadzone at 0%, Linear set to 000.

    Within one minute after starting to drive in GTR Evo, the wheel lost its centering by about 20 degrees to the left. Even after recalibrating/recentering the wheel using the base button and bottom buttons on the left spoke, this problem continued to happen.

    I then successfully installed firmware version 681. All instructions were followed exactly. I once again uninstalled and reinstalled the latest drivers, ver. 104. The auto-centering spring feature is unchecked in the wheel's property page and the "SPr" setting on the wheel is set to the default of 0. All the wheel's settings are the same as above. I then tried a number of different settings in GTR Evo, including FFB and wheel sensitivity. I also tried a number of different settings on the wheel itself.

    None of this has made any difference in fixing the "loss of the centering" issue. I've repeatedly recalibrated the wheel as above, but the same centering loss problem persists. The only improvement is that the paddle shifters are working again.

    I am really tired of spending hours trying to get this wheel to work as it is supposed to. I bought this wheel because I didn't like the Logitech G27 wheel's notchy feeling, and the GT3RS V2 belt drive sounded like the way to go. But one thing I'll say about the G27...at least it worked correctly right out of the box.

    So, Fanatec...what's next? I don't know what else can be done to fix this one, apart from replacing it (with a wheel that can actually achieve the miracle of not losing its calibrated center), or giving me a refund. A wheel that loses its centering consistently and constantly is completely unacceptable.
     
  9. ReDi

    ReDi
    Slightly Mad Studios

    Thanks for following up on this. To me it's clear that the wheel is broken, which means that either it should be repaired (I have a pretty good idea what's wrong with the wheel) or you need to get a new wheel. Unfortunately I am not in the position to be able to help you with either option right now, so please contact Fanatec Support (if you haven't already done so) through this page.
     
  10. ReDi, thanks for your help in reviewing this, and for your suggestion about using the Tech Support contact form. I've completed it and submitted it today. I will post back here with any updates, in case anyone is interested.
     
  11. ReDi

    ReDi
    Slightly Mad Studios

    Most welcome! Do keep the thread updated, and myself as well, you never know where I might be able to help :)
     
  12. Kevin Ascher

    Kevin Ascher
    #47 Roaring Pipes Maniacs

    If I was you, I would still think about trying that thing with the PCI card out. I also had more than enough USB slots and it did the trick..
    BTW: What Windows do you use?
     
  13. Actually, it's not a PCI card. There are two connectors on the motherboard for adding USB slots and I'm using the manufacturer's two-port USB "extender" from the connector to the back panel. And even if unplugging that extender solves the centering issue, that's not acceptable imo. No other USB peripherals, mice, keyboards or game controllers I use show any unwanted behavior, so why should I accept it from the Fanatec wheel, especially when it's such a basic problem?

    I'm using Windows 7 64-bit.
     
  14. Hi,

    I've had my gt3 rs v2 for about 3 weeks now and have been trying very hard to upgrade the firmware from 669 to 681. So far all I got is a whole lot of frustration, but no working upgrade.

    I'm using Windows 7 Ultimate x64, a brand-new computer with 2 USB3.0 ports and 4 USB 2.0 ports, and have the Clubsport Pedals plugged into the wheel.

    No matter which forum suggestion I try things always stop dead at the "Please install the usb driver" line from the Updater. Tried to do that but Windows insists that I already have the latest driver. Right-clicking on the driver and than clicking on "Install" doesn't work.

    Right now I'm looking at the wheel's display which shows a whole lot of nothing apart from a tiny little red dot. In "Devices and Printers" the wheel shows up as the "Porsche 911 Turbo" wheel. I don't know if it will actually work in, like, F1 2010 or rFactor; I will try again tomorrow after I've had some sleep.

    Ok, I think I need to go back to some basics to see if I'm getting things right.
    To get the wheel into this infamous bootloader mode I do... what?
    And when I get that done the display will show... what?

    No good mentioning Windows XP as it's no option; I don't have it available (not to mention that I find it absurd that in 2010 we have to install firmware via a version of Windows 2 steps back).

    Sigh...
     
  15. I tried to upgrade my pedals on a Win 7 64 computer. It doesn't work.

    You need to borrow someone's Windows 32 bit operating system computer for it to work.

    I used my wife's laptop and it worked fine.

    I agree they should have a 64 bit version of the firmware that works, but they don't.
     
  16. i installed the 669F/W on a windows 7 64bit pc no problem. but the instructions are different on the newer F/W`s.

    with 699 it would fail 1st time at step 2 (the pc would not recognise the wheel) so then reinstall drivers and start F/W update again and it worked. i posted this info on the Fanatec forum thread for 681F/W and someone posted that it worked that way.

    lets hope ReDi will read this thread soon and give his advice on updating F/W on W7 64 as i would like to update mine but am very nervous and am even thinking of conecting an old Dell to do the update as that is on XP.
     
  17. ReDi

    ReDi
    Slightly Mad Studios

    Well last week I updated two PWTS wheels on Vista 64bit without a hitch. Not even a USB driver installation hickup.

    If I remember correctly then indeed there is a posting on www.911wheel.de where the steps of updating the firmware are described accurately. I'll look it up.

    As said, on Vista I had no problems at all, not even a retry after installation of the USB driver. On my XP machine, something seems to have been corrupted because I cannot get the update to finish successfully (yet), it fails every time on the USB driver bit so I think I have to fix that manually first.

    I'll get back to you guys soon about this.

    Hence, it seems to depend on (to me) unknown quirks of the OS whether it will work smoothly or not.

    UPDATE: Here's one procedure I found if the USB driver install fails:

    Start the update process as per the instructions.
    * After running the ‘pw1’ file, Windows will no longer recognise the wheel
    and will not be able to find the relevant driver.
    * Open the Devices and Printers window – the wheel should be the Unknown
    Device at the bottom.
    * Open its Properties window and select Install
    Driver.
    * Select the driver location manually – Browse, and select the folder
    containing; (it's in the 'PWTS_UE_Bootloader_rev669\usb driver' folder).
    * Windows will panic that it cannot verify the author; confirm that you
    want to continue.
    * After the installation has completed you will have to restart the wheel
    (in bootloader mode), and restart the update from step 1. But this time
    you should be able to complete the process.


    UPDATE 2: here's another trick someone posted to get around the USB driver problem:

    Win7 > no luck
    XP SP3 Compatibility mode > stuck after step 2, but it said "update complete" (but no log.txt)

    Here comes the trick:
    At this point (update manager in XP-SP3-Mode still running) i started cmd.exe and went into the folder with the firmware and executed the command by hand:
    C:\GT3>fp.exe -i \\.\COM4 "C:\GT3\GT3RSV2_Base_boot_rev681.pw2" > log.txt
    (COM4 is variable, could also be COM3, etc. look in device manager or updatemanager log)

    After that, the logging in the update-prog went on and finished just fine! : )
     
  18. Thank for the instructions, ReDi. Here's how I went.

    #1. Extracted the contents of the 681 firmware zip to C:.
    #2. Set the UpdateTool to Windows XP SP3 Compatibility Mode.
    #3. Turned off the GT3 RS V2 wheel.
    #4. Run the Updater.
    #5. Restarted the wheel while holding the big shiny button until the Updater said that the device is attached.
    #6. Started Step 1, resulted in the Updater stating that the device was removed.

    Windows: Unknown Device

    #7. Went via Devices and Printers to: Unknown Device / Properties / Hardware / Properties / Change Settings / Driver / Update Driver / "Browse my computer...".
    Windows went to C:
    Next / "Install this driver anyway" / "Windows has finished installing the driver software for this device. FANATEC UPDATE PORT" / Close.
    Devices and Printers now showed down the bottom a FANATEC UPDATE PORT (COM3).
    Closed that window.

    Was now tempted to do Step 2 in the Updater but stuck with Redi's instructions so closed the Updater and turned off the wheel. Restarted the procedure from #4.

    #8. Did #6 with the same results.
    #9. Did Step 2.

    DOS: "Assertion failed: bDeviceFound == TRUE, file e:\svnfiles\pwts\trunk\boot33fuart\x86 host\16-bit flash programmer\16-bit flash programmer.cpp. line 486"
    Windows: "fp.exe has stopped working"
    Updater: "update complete"

    Now I continued with the 2nd set of instructions.

    #10. Started cmd.exe, then entered C:\fp.exe -i \\. \COM3 "C:\GT3RSV2_Base_boot_rev681.pw2" > log.txt

    DOS: Assertion failed: SetCommTimeouts<*pComDev. &CommTimeouts> -- TRUE, file e:\snfiles\pwts\trunk\boot33fuart\x86 host\16-bit flash programmer\16-bit flash programmer.cpp, line 715
    This application has requested the Runtime to terminate it in a unusual way. Please contact the application's support team for more information.
    Windows: fp.exe has stopped working
    Windows: UpdateTool.exe has stopped working

    Closed all the windows and am back at square one.

    Time for more hot black coffee and Round 2 :pcbeat:

    Edit: Rebooted, restarted the wheel, grabbed it before it fully centered, pressed and held 2,4,6,8 while centering the wheel. It still says 669. Let go of the buttons and I still look at the little red dot on the display. Will kick-start F1 2010 to see if the wheel works or not.
     
  19. ReDi

    ReDi
    Slightly Mad Studios

    Hi Pheral,

    I would suggest to mail your findings above to E-Support of Fanatec. Their programmers should have a look at it and say whether the Fanatec application does something funny or that your Windows install is buggered-up in some way.


    E-mail:
    e-support@fanatec.com

    In order to help us to process your request quickly you will get a higher priority if you follow these rules:

    Please...
    ...include a copy of your invoice (pdf) or order confirmation (e-mail) so that we have all order data
    ...write down the product name (s) and serial number (s) (can be found on the bottom of the product)
    ...do not send to multiple e-mail addresses . The request will only be processed if e-support@fanatec.com is the only recipient
    ...make sure you always include the full email history with every e-mail you send to support.
    ...make a video of your problem. Please send it directly by Email or u pload the video to www.mediafire.com . Please try to keep it small! If we can verify the issue t his will allow us to send you a replacement unit without waiting for a return of the product. Please do not use youtube or a similar service – we will need to download the file easily!
    ...make sure you have a problem which is not described in the FAQ
    ...read the manual. Sounds trivial but 20% of requests could be avoided if the user reads the manual.
    ...list the following info
    Tested operating systems or game consoles on which the problem occurs
    Tested games which show the problem
     
  20. Thanks ReDi, will do.