1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My Thrustmaster / Amazon Experience

Discussion in 'Sim Racing Hardware' started by eSEA One, Mar 1, 2016.

  1. eSEA One

    eSEA One
    eSEA One

    The following is my Thrustmaster / Amazon Experience. It all started in September 2015 and hopefully a happy ending.
    I have been running a G27 set for a few years and had come into some "boys toys " available income. After some deliberation and finding the Fanatec beyond this budget, on the 22nd September I ordered the Thrustmaster TX base and the 599XX EVO Alcantara Edition rim from Amazon.fr (I live in France) for a total of €460 . I had been looking out for it for some time beforehand, unfortunately it said "available soon" September tuned to Dec, then Jan at that point I noticed in my Amazon account that it now told me that delivery was expected Dec 2020!!!
    I mediately contacted Amazon and they replied with:
    "Following a technical error, the estimated date of delivery of this item in "Your Account" is incorrect. We assure you that we take all necessary steps to correct this error.
    The wait continued and I lived my sim life on my trusty G27. I kept on looking at my order but the delivery date was never corrected. Then a bolt from the "Blue"! Amazon had a bundle for the PlayStation version of the TX the "T300 Ferrari Integral Racing Wheel Alcantara Edition" including the T3PA pedals. for €415. Since I am only on the PC, I had no affiliation to any of the consoles and I also needed a set of pedals as I was going to let my son have the G27 package. Out when the "Green" TX order.
    On the 10th Feb I purchased the T300 Ferrari Integral Racing Wheel Alcantara Edition for €415
    Not only cheaper it was available.!
    It arrived on Sat. 13th Feb. After un-mounting the G27 kit and replacing it with the T300 Wow! what a difference to the G27, had a grin from ear to ear. Low and behold I only had a short time on it before we had friends over for a lunch, by the time they left late afternoon my mates and the kid had more time on it then I.
    I was back on the wheel as soon as they had left and got the placed cleaned up (got to keep the +1 happy)
    On the Monday as soon as I was home from work I was back on that smooth suede like Alcantara.
    Unfortunately this time when I plugged it in there was a distinctive electrical buzzing coming from the left side (transformer) I then contacted Thrustmaster directly through there support page. there was the usual automatic conformation email and then the flowing day I got the following:

    We begin by thanking you for your interest in our products and apologizing for the inconvenience.

    As the issue you are describing is not a very common one, we would like a video recording in which we can hear the buzzing noise you are referring to.


    I made the recording and sent this
    Dear TM
    Thanks for your quick responce to my query.Apologies for my slow reply, work and trying to find a bit of quiet time in the the house to do the recording did not help. The first attempt I did there was a horrendous metallic clattering at the wheels calibration time, I realised it was not the wheel but my son putting away the cutlery ;) I certainly was not going to post that recording.
    This morning I have now made a clean one when the household was still asleep!
    Unfortunately I am having problems uploading to your cloud , (server connection timed out) I have it in my Google Drive where you can access the file with the following link https://goo.gl/photos/hXeez2bmNFi9vatg9 I will continue to try and upload it to your cloud service.

    • I have also measured the decibel level and the buzzing is at around 56dB to 57dB and when the wheel is off the sound level is around 41dB to 43dB ( Computer fans)
    • I also notice that during calibration the wheel hits the right stop much harder then the left stop! to me this is not how it should be.
    Other than theses two points I am very happy with this product, the feel of the FFB is a huge step up from my Logitech G27

    Thank you for your cooperation in this matter
    Regards

    Shortly after they replied with :

    After having watched your video, we have decided that an RMA procedure will have to be initiated for your wheel's base (if the product was not purchased as a second hand item) so that we can investigate the buzzing noise.
    Be aware though, that the wheel's calibration appears to be normal.


    Well after a bit of delay on my part , not giving all the info requested, I received RMA form for shipping. The base has been packed up and is on its way back to TM.

    Well I could put the G27 back but I have decided not too. Need to spend time to do more work on some textures and graphics for AC! I don't think anyone has spotted my name in the credits ;)
    More to follow!....
     
    Last edited: Mar 1, 2016
  2. I was about to do the same as you - order T300 Alcantara set to replace my G27 but I am now seriously discouraged from all the problems with TM products I read about. G27 is fine, lots of rattle with RF2 but pretty OK with AMS, GTR2, AC. Since I cannot compare to anything else G27 suits me fine apart from the RF2 rattle and nasty vibration from tire damage. There is also the deadzone but I kind of got used to it. I also have the brake pedal mod. I guess I should hold to my G27 for now.
     
  3. Shenmue_X

    Shenmue_X
    Premium Member

    I recently bought a second-hand T300RS with a six-month guarantee in the Thrustmaster shop. The wheel didn't work after failing the calibration step. The power supply was dead (I believe it's because I didn't install the firmware before). Their following mail instructions failed as well so I sent them my wheel. I got it back very quickly. It works well and fine but I get some problems then :
    • The wheel sometimes disconnects after 10 minutes of inactivity. I'm pretty sure the reason comes from my USB 2.0 port weakness (I use my PC's frontal USB port instead the back ones). Thrustmaster are aware of this issue since the user manual guide recommends not to connect the T300RS on 3.0 port (lot of radio interference I presume) and HUB USB port. The T300RS looks very sensitive.
    • I experimented the unfamous loss of FFB once because of overheating. It was after several playing sessions in a row and came during Dirt Rally, a game where you're constantly fighting with the steering wheel to perform.
    T300RS is superior to G27; it's not especially more powerful, spectacular or detailed but has much more finesse and precision. Everything becomes easy to drive and master. But aside from FFB accuracy and design, I have no confidence in my T300RS, in particular the power supply one.
    While I believe my old G27 could last at least 10 years more, I'm seriously expecting my T300RS to die after one year of usage, because of my issues, all these safety recommendations in the manual, the heating mechanics, the brutal default calibration at the plugging.
    Fantastic product but looks so fragile and experimental. As a very recent technology (or use of this technology), I guess you have to accept to step forward into something uncharted.
     
    Last edited: May 16, 2016
  4. What to do if your MB has only USB 3.0 ports?
     
    Last edited: Mar 16, 2016
  5. eSEA One

    eSEA One
    eSEA One

    Update: Received this the last week

    9 Mar
    Dear Customer,
    We announce the return of your product. You will receive within 10 working days.
    This email is an information email without tracking response.
    Sincerely

    The Guillemot after-sales service

    Ok only one week still no base!
     
  6. 10 working days normally mean 14 'real' days, including weekends. So that would be 23 March.
     
  7. Shenmue_X

    Shenmue_X
    Premium Member

    10 days is the maximum. I don't remember exactly but they returned my wheel very quickly.
     
  8. eSEA One

    eSEA One
    eSEA One

    :(Well! it still has not arrived !!!!:mad:
    OK! this is not Thrustmasters fault. It is a combination of things
    • I was not at home to receive the package.:(
    • The postal slip, we suspect, got tossed with some junk-mail.:confused:
    • I should have not waited till after the the "You will receive within 10 working days" to inquire where the package was. :O_o:
    • Thrustmaster should have given me a tracking number in the dispatched email and not the "This email is an information email without tracking response". :thumbsdown:
    On the positive side:
    When I did contact Thrustmaster yesterday (after hours when I got home) wondering where my package was, they responded first with the normal automatic response "
    "Thank you for contacting us again.
    We have received your message following up your query received on .........
    An agent will be getting back to you about this as quickly as possible.

    Kind regards,
    The Thrustmaster team"

    Then surprisingly unexpected at 23:37 last night Customer support agent Erika responded ::thumbsup:
    "Thank you for the follow up.
    The courier is ..................and the tracking number is................
    From what we have seen, the parcel was at your local postal office on the 12th of March.
    Please check if the parcel can still be picked up from the postal office and inform us as soon as possible.
    Thrustmaster Technical Support is at your disposal for any other information you may need. You can reach us online at the following addresses:
    http://ts.thrustmaster.com/eng for the latest updates and FAQs
    or by telephone at one of the numbers listed on the following page: http://ts.Thrustmaster.com/eng/index.php?pg=contact
    Kind regards,
    Your Thrustmaster Customer Support Agent, Erika


    As I can not get to the post office today:(, lets hope the postal service has waited till the end of the 15 days before they do as stated and send the goods back to the sender. The 15th day is tomorrow and I will be there at 09:00 when they open to make sure they don't send it back before the first mail drop-off/pick-up.:confused:

    If I step back from this ordeal and look at the bright side Thrustmaster was very efficient on the turnaround once I sent the base back to them on the 27th Febuary. They managed to fix it (well we will have to see tomorrow) and send it back to me by the 12th march.

     
  9. eSEA One

    eSEA One
    eSEA One

    Wheel base is back on my rig/desk No more buzzing and it is quiet. The fan does come on if the wheel is worked hard, I am not sure what all the fuss is with the fan noise that some folks complain about. When it comes on it is no louder than my PC fans and tends to blend in with them.

    Other than my stuff up with the postal slip I think I can rate TM service to be very good:thumbsup:. Every email sent from me was responded too in a pleasant and helpful way.
     
  10. eSEA One

    eSEA One
    eSEA One

    Sadly new troubles! my T300 base died last night while playing "Dirt Rally"
    This is the wheel I sent back just after getting it, back in February. It had a electrical buzzing.
    This time round it just stopped, unplugging re-plugging - nothing not even seen in the Windows Control panel/Devices and Printers
    Sent off an email to Support and now waiting on a reply.
     
    • Sad Sad x 1
  11. Shenmue_X

    Shenmue_X
    Premium Member

    Sad for you.
    Dirt Rally is certainly the most demanding game for the wheel btw, I always turn on manually the fan before the race.
     
  12. eSEA One

    eSEA One
    eSEA One

    Not counting the automatic reply, "We have received your message following up your query received on April 25, 2016. An agent will be getting back to you about this as quickly as possible........ " I got a response from the TM Customer service rep ( same one as last time round, I was surprised I got the email quite late in the evening) their recommendation was to connect the wheel in BOOT MODE and gave the appropriate links to the latest drivers and PDF instructions.
    I followed the instructions and responded with the following:

    "I see You are working late, I appreciate your help.
    I have followed your instructions but I do not get the "installing device
    driver software" or "Thrustmaster T300 Bulk Driver" messages.
    I just started to smell something ( the smell is like burning paint!) and
    immediately pulled both the power plug out the wheel and the USB out the PC."


    At no point did I see the wheel or any new USB device on the "Control
    Panel\All Control Panel Items\Devices and Printers"

    With this the response was:
    "Did you check if the wheel was seen in the Firmware Updater window?
    Only if it is seen there, and you manage to reload the firmware, will the device turn on.
    Please connect the device in boot mode and check the Firmware Updater window to see if the wheel appears there or not."

    Again I followed the instructions and my reply on the 28th april was :

    "Once again I followed your instructions until I got to step 3, once again I started smelling burning electronics, this time a lot stronger, so I did the logic thing of unplugging the wheel from both the USB and the power supply. I am afraid this is a lot more serious than just updating the software and the firmware. "
    Now the base has a distinctive burnt electronics odor!
    My son recons that the first time with the internal power supply unit troubles they had fixed the power unit but there might have been some damage to the electronic board and it would only be time before it would show up.

    After this the reply on the 29th was:

    Thank you for the follow up.
    We would like to inform you that we have started a repair procedure for your wheel’s base.
    You will receive in a few days a delivery slip with our address to send the base of your product (do NOT send the detachable wheel, the pedal set, the fixation system or the power cable) to our repair center. Once you receive this delivery slip, you need to print it and follow the instructions written on it.
    When you prepare the parcel it is preferred to use a box with better protection rather than the original one. The attached instructions will explain better how to pack the racing wheel.


    30th April 2016
    I am now waiting for the documents for the RMA procedure



     
  13. eSEA One

    eSEA One
    eSEA One

    Finally received the shipping documents. Well some took yesterday as a holiday so not surprising I did not get anything. Now it is on me to find the time to get to the Post Office
    Got my G27 back on my set-up. Hell! it is noisy and un-smooth
     
  14. eSEA One

    eSEA One
    eSEA One

    Got the RMA notice:"We announce the return of your product. You will receive within 10 working days. " Hopefully, this time, I will not throw out the postal slip with the junk mail. It should be here in 3 days.
     
  15. That shouldn't be so.
    Of course it's hard to predict how software will react when it finds no driver in place. But PSU failure? because firmware not in place? ** That strikes me as negligent design. If it's actually possible.

    * I'm surprised ... you have to do a manual installation of firmware? Update, yes, that I can understand. But install to initialize? Truly? I'm surprised.
     
  16. Shenmue_X

    Shenmue_X
    Premium Member

    @Dawks
    About the PSU failure, it's only a theory from mine. I didn't ask an explanation from Thrustmaster. The wheel works perfectly since they repaired it months ago. Now I rather do think it was an old PSU and they replaced it with a new one. That PSU failure is maybe the best thing that could happen for my wheel.

    Yes you have to install the firmware before using the wheel. During the installation, you will get an instruction to connect the wheel on the PC. Then you have to restart the PC. I don't know what happens if you skip all the step.
     
  17. Help please.

    Just want to clarify the procedure, as I'm not from the US (sending it through a relative travelling to the US soon, who will drop it off at UPS... to be shipped to Canada). They required me to print and attach on the package 1 Shipping label and 3 pages of an Invoice. Do I attach all 3 Invoices (as one stack, on top of each other), or separately so all are seen on top of the package?

    One more thing, the shipping label requires me to sign (Shippers signature) and shipping date. Is it critical to put an exact date? I'm asking as we don't know the exact date when my cousin will be able to drop the package to USP branch in the US (only have an estimate date when they'll get there). Thanks!
     
    Last edited: Sep 3, 2016
  18. eSEA One

    eSEA One
    eSEA One

    Sorry can't help you, have no idea the procedures in the US/Canada I live in france and I believe Thrustmaster is a French company. However I suggest you contact TM support and ask them.
     
  19. Azure Flare

    Azure Flare
    World's fastest mobile chicane Premium Member

    You do realize the T300, no matter what wheel is on it, is compatible with PS3, PS4 and PC right?
     
  20. Hello there!

    I am still on my logitech g25 ever since gt5 got out, been playing quite a lot - although a bit less often lately, fairly happy with it, but it's been a long time since I did something for myself, so I thought I'd give me the 'new wheel' treatment. I was almost ready to buy the t300rs and thought I'd ask here if it's worth the upgrade, but now I am discouraged by this thread - I can't image me being in Greece having to send this back and forth - does thrustmaster cover shipping expenses? Let alone I tend to get anxious and angry by exchanges of this kind...

    Have you received your wheel back? I wonder how common these issues are..