1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

MULTIPLAYER LOBBY HELP Please

Discussion in 'Racer' started by aadilf1, Jul 25, 2010.

  1. Somebody help me i got racer v6.3 and i want to join a race but no races pop up anyhelp? and i cant host it just says YOU ARE NOT CONNECTED and BTW

    sorry for my CRX thread it was alot of fun...
     
  2. KS95

    KS95
    RACER Moderator

    If there are no races in the lobby.. there are no races being hosted.
     
  3. Ruud

    Ruud
    RACER Developer

    Also, the lobby only accepts version from v0.8.8 something. I believe I even have to update it to accept v0.8.10 and up (now 0.8.14). It should hopefully say 'Please upgrade your Racer'. Hm.
     
  4. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Hello@all,
    Happy new year!
    Sorry to bump this old thread, but i think it's not needed to do a new one...
    To day i got the first race in racer's multiplayer working with no other tools...
    I host at my server a lobby for racer, no bot atm...
    I tested it with my son, we use racer 0.90rc10, i host a race via lobby and he join, we does some laps...and had a lot of fun...
    If some one is interested, enter the Multiplayerlobby in racer menue, put in this url:
    df-racing.ddns.net
    now you should be able to host races and others to join...
    If i get it working, i do a racerbot too...

    have more fun!

    regards
    Alex
     
  5. Hmmm interesting, so the multiplayer lobby only ever works as a system to join dedicated servers, not just help interconnect clients and client hosted games?

    Dave
     
  6. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Hai Dave,
    i think racer gets never a dedicated server version...
    The multyplayer lobby, only help interconnect clients to host a game or join, for my understanding...
    But some one got this a longe time agoo working, you can use racer as a (dedicated)server witch is able via racer Bot to host a game/race where clients can join...if they have the same content...
    I hope i understand you right, and you can understand my worst english...

    regards
    Alex

    Edit:
    Try it, i got a bot working...he restart every 30 sec. a race, for the mom only with default carswood and lambo...

    Alex
     
    Last edited: Jan 4, 2016
  7. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Moin,
    ok i tested it and for me it works...
    How to do:
    Start Racer, choose car (lambo from Dave, default racer car) and track (carlswood remix from Luthobu, default racer track), then go in to the Multiplayer Lobby, klick on the race hosted by DF Bot, join and start race or wait for the bot start the race...have Fun!
    It's for testing a 3 Laps race...
    After the race you are back in racer main menue...

    regards
    Alex
     
  8. Thanks for the effort, Alex! I managed to join and drive for a lap and a half, then found myself back in the main menu and the lobby empty now. Not sure if the server got stopped or crashed, but this is still more successful than most attempts at using the lobby that I remember ;)
     
  9. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Hai Cosmo°,
    yes he crashed...
    Message was...Filname, Function etc...
    For the mom i think it could happen because the server is at 99% blocked from the downloads PnGv3,2...there are 30 people who try to download all files at once...but the upload is only 6k, so they have to wait...
    Tomorrow i start him again and hope there are not so many downloaders ^^
    I have to figure out how this watchdog works...then the bot is able to restart it after a crash...

    regards
    Alex
     
  10. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Moin,
    i'm sorry, but the server "burns" the full night with PnG downloads...over 80GB of traffic...
    If they are lower the dl's i can try it again, the lobby can stay online, because it needs not a lot of power...

    regards
    Alex
     
  11. Im having the same problem... when i try to connect to lobby, it sits there and says connecting to lobby :/
     
  12. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    yes, did you change the lobby name or are you using the default racer lobby from ruud?
    Try my lobby...
    [​IMG]
    oh...and remember, first choose the default lambo and the default carlswood nt track!
     
  13. What version of racer, and i tried that too.
     
  14. what is the port also?
     
  15. GUYS IM HOSTING CLICK JOIN MULTIPLAYER AND TYPE IN 192.168.0.1 (use carlswood and lambo or baja truck)
     
  16. nvm it down nobody joined
     
  17. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Moin,
    i use racer 0.90 rc10, also for the server...i've not tried with older racer versions but maybe it works...no i tried the 065...no way...sorry...
    the latest version i can join with is the 0.90rc5d...
    The port gets added by racer, should be by default 28100, see racer.ini...
    It's normal no one joint...it's racer not AC, pC or LFS...

    Alex
     
  18. fyshstyx: 192.168.0.1 is your local IP, nobody can connect to it from the internet. You need to set up port forwarding in your router and then share your external IP if you want it to work.
     
  19. uh...wheres that...
     
  20. Try any web, google for "whats my ip" or similar and thats it.