1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Logitech profiler cannot detect device...

Discussion in 'Off Topic' started by Adam Bark, Aug 29, 2011.

  1. I just installed Vista 64 bit on my computer (7 wasn't working) and now when I try to get my wheel working using the profiler, it says it cannot detect the device at all. Windows is able to detect my wheel fine but the profiler just does nothing and closes after that error message. Anybody else had this problem before?
     
  2. Yes, a couple of times. I think just changing the USB port did the trick.
     
  3. Bah still not working. I can access 'Game controllers' and it show up there, then I click 'About' and it gives the option to open the profiler, but it still gives the error message.
     
  4. Have you double checked to be sure the main power is plugged in? This can sometimes cause this issue.
     
  5. Yeah, its a driving force GT so the centre button is lighting up as normal.
     
  6. The center button can light up from just the USB I believe, make sure your main power from the wall is working properly. Try plugging into a different outlet if needed.
     
  7. Hi

    I just got m g25 working again after using ps2 joypad for ages but i have a problem


    I know it is working now because the wheel is self-calibraing upon usb detection but every time I try running thhe logitech game controllers software im getting a no device detected message, and yes ive been reading this thread and tried it in another usb port still wont work. this is really p**** me .. as I can only use 2 of the pedals the leftmost pedal will not detect and only just over 1\4 turn to each side about 200 deg which is no good......

    I need some help here plz

    im running xp pro 64 bit edition


    I just found this link http://forums.logitech.com/t5/Steer...Logitech-Profiler-amp-G25-Problem/td-p/100221

    unfortunately thoughthe link which solves this issue has now been removed so how am I to fix this problem now plz???



    Dont u all rush at once now will you...


    anyways I got it working I did 4 things

    1 Deleted to Logitech registry folder

    2 Uninstalled the profiler driver software

    3 Re-installed the software

    4 changed the usb port


    Now the software is working properly.. hope this helps anybody who has had the same problem as the link on the page above doesn't work