• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Logitech G29 Setup

Discussion in 'Assetto Corsa' started by Jarhead{SRX}, Sep 11, 2017.

  1. Jarhead{SRX}

    Jarhead{SRX}

    Messages:
    4
    Ratings:
    +0
    Hello all!

    I have been a long time racing games/sim driver. I have changed several wheels over the last 2 decades.

    I have a Logitech G29. The wheel has a 900 degree turn. I can't find a way to setup the wheel with the game for it to work perfectly on each car.

    For example, if You take a new racing car like a Corvette C7R and setup the wheel for it (I put 360 degrees) it will work fabulous. If You take a normal car (not a race car) it will not work so good, because those cars have bigger turn degrees than race cars. I turn the car left on the wheel but the screen is showing me a different degree turn in?

    On some race cars the wheel feels perfect, turning in just like You are on the wheel. On some other cars, it feels like the wheel is too slow or some times too fast/sensitive to what are You doing with it.

    My question is, what wheel settings are You using in Your Logitech Gaming Software and ingame?

    Also, has anybody else noticed that in the allignment setup area for camber and toe in, it says some weird stuff. Like if You raise the value of camber (go +) You car will gain negative camber? I work with allignments everyday in my shop, and that is not how it works. If You lower the value (-) You gain negative camber and vice versa for the positive camber.

    Also, shouldn't the Logitech Gaming Software preset all the buttons on the wheel for the game?

    Thank You!
     
  2. ouvert

    ouvert

    Messages:
    1,515
    Ratings:
    +557
    Make sure than in profiler you have 900 degrees rotation and 'Allow game to change' checked and in game setting 900 degrees too ...


    Than standars: no dumper, no spring ...
     
  3. maacl

    maacl

    Messages:
    9
    Ratings:
    +2
    I belive you need to change the Wheel Operating Range in LGS.
    Whatever you select within LGS should correspond to the in-game setting.
    I'm not 100% sure, but if we set the rotation to lets say: 720 in LGS and in-game, then sit in the Lotus F1...
    You'd have to turn "twice as much" to get the desired effect in the game, therefor I think it may be car specyfic?

    You said: I turn the car left on the wheel but the screen is showing me a different degree turn in?
    Am I right in thinking that you turn the wheel 90deg left, but it turns "less" in game?

    Regarding the buttons assignment...you could use the LGS's predefined settings for AC via the profile list (Scan for new games icon just below the Profile search bar).
     
    Last edited: Sep 11, 2017
  4. cpt_gandy

    cpt_gandy
    Slower Than Time Premium

    Messages:
    81
    Ratings:
    +41
    All i did with my G29 is open the logitech gaming software and set the wheel sensitivity to 100% that way you get a 1 to 1 match with the wheel in the car you are driving, if you leave it at its default 50% they wont match up.
     
    • Agree Agree x 1
  5. Jarhead{SRX}

    Jarhead{SRX}

    Messages:
    4
    Ratings:
    +0
    Thanks for the help. I will try all the listed solutions after I come back from work today!

    I don't see this option: 'Allow game to change' ?? in the LGS

    Yes, You are right, for it to be realistic, You'd have to turn ''twice as much'' and I think it is car specyfic also. I turn the wheel 90 deg left, but it turns less ingame, that is correct.

    If I pick the LGS predefined settings, and go ingame, no buttons except the shifters work. If I pick the Predefined settings in AC for my wheel, the wheel is completely useless.

    I will try all the solutions listed here today, and will give You feedback!

    Thanks for the help!
     
  6. HypoToad

    HypoToad

    Messages:
    291
    Ratings:
    +50
    Make sure you select your Assetto Corsa game profile in LGS, then go to "Specific Game Settings" in the "Edit" menu, look at the bottom two check boxes, one is "Use Special Game Settings", so check that one and underneath it there is "Allow Game to Adjust Settings" and check that one.
     
  7. Jarhead{SRX}

    Jarhead{SRX}

    Messages:
    4
    Ratings:
    +0
    I really do not see this option!
     

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      174.8 KB
      Views:
      39
  8. XRRoy

    XRRoy
    Vintage Tin Can Roller Premium

    Messages:
    34
    Ratings:
    +15
    I don't think you even own a G29...

    You click the little gear icon in the bottom (the one located in between Overwolf and question mark,) then go to G29 tab and make sure that option is ticked.
     
  9. Jarhead{SRX}

    Jarhead{SRX}

    Messages:
    4
    Ratings:
    +0
    Hello,

    Sorry for not replying, a lot of work, no time to drive.

    I see an option: '' allow game to adjust force settings'' and that is already ticked.
     
  10. HypoToad

    HypoToad

    Messages:
    291
    Ratings:
    +50
    Sorry for trying to help out, I have a DFGT and I have Win 10 64bit with LGS 64bit, I think he has a different version of LGS as it's clear as a bell in the one I have:

    [​IMG]
     
    Last edited: Oct 7, 2017