• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Kunos Assetto Corsa CPU Occupancy > 99% Warning Advice

Discussion in 'Assetto Corsa' started by Paul Jeffrey, Feb 15, 2017.

  1. Paul Jeffrey

    Paul Jeffrey
    RaceDepartment Editor-in-Chief Staff Premium

    Messages:
    7,230
    Ratings:
    +12,343
    Assetto Corsa 99% Issue.jpg
    Kunos Simulazioni respond to recent CPU Occupancy > 99% issue with new advice for PC owners.

    Following the popular update to build 1.12 of Assetto Corsa on Windows PC, Kunos Simulazioni have quickly realised a small proportion of users are suffering from a return of the CPU Occupancy > 99% issue that plagued many players during early builds of the game.

    The return of the issue, attributed to amendments to the controls.ini file received in the latest build, has been acknowledged by the developers and advice has been issued on how to resolve this problem for the vast majority of players. With the update to the controls.ini file Kunos have brought to the game a more detailed FFB feeling for a number of wheel users, unfortunately this has caused problems for some players, especially those with older or home made wheel solutions. With the below advice issued today by Kunos the Italian team are confident any remaining CPU Occupancy issues will be resolved.

    It is advisable to contact the official Assetto Corsa PC support forum if you still experience this issue after following the below steps.

    FOR PC/WINDOWS USERS
    With the new v1.12 update, we have introduced a new section in the "controls.ini" file located in your "Windows Documents\Assetto Corsa\cfg" path called "[FF_SKIP_STEPS]", that manages the force feedback update rate. The default value is now "0" instead of "1" and it overrides the old value located in the "assetto_corsa.ini" file (in the Steam game folder). This brings a more detailed force feedback and a better driving feeling. If you experience "CPU OCCUPANCY > 99%" warnings, please tick "Half FFB Update Rate" in the the UI Options -> Controls -> Advanced and this will bring the value back to "1". Not all the steering wheels can manage the maximum update rate, so no worries.

    If you are using a very old steering wheel like the Microsoft Sidewinder or Saitek R440, or other hand-made ones, you need to open the "controls.ini" file, and set the "FF_SKIPS_STEPS" value to "4". It should look like this:

    [FF_SKIP_STEPS]

    VALUE=4

    This should solve any "CPU OCCUPANCY > 99%" warnings related to the force feedback refresh rate.

    Please always double check this value if you load controls profiles created before v1.12 update! In case, please create a new controls profile with the proper value!


    Assetto Corsa is a racing simulation built for PC, Xbox One and PlayStation 4. The game is available to purchase now with a number of additional DLC packages available depending on the chosen platform.

    Assetto Corsa 99% Issue 1.jpg Assetto Corsa 99% Issue 2.jpg
    Assetto Corsa 99% Issue 3.jpg

    The Assetto Corsa sub forum here at RaceDepartment is the place to go for Assetto Corsa news and community discussion. We have a whole bunch of mods to download, a specific area for modders to discuss their WIP projects and of course our epic Racing Club and League events. Head over and join in today.

    Have you experience the 99% Occupancy issue? Does the above suggestion resolve your issues? What do you think of the 1.12 update? Let us know in the comments section below!
     
    Last edited: Feb 15, 2017
    • Like Like x 7
    • Love Love x 1
  2. CptEinsicht

    CptEinsicht
    Premium

    Messages:
    46
    Ratings:
    +39
    I have it from time to time. But i think that this is a Hardware problem on my side because my cpu really sucks.
    Happens only with plenty opponents.
     
  3. Ricoow

    Ricoow
    RedShift Racing RDLMS #6 Premium

    Messages:
    3,538
    Ratings:
    +1,112
    I want to rage so much. Freaking snowbanks.
     
  4. Giorgos Kostis

    Giorgos Kostis

    Messages:
    267
    Ratings:
    +85
    I don't trust the assetto corsa fps counter.

    When i use MSI afterburner, it shows that only 18-20% of my CPU is used while Assetto corsa shows 3x as much.
     
  5. Mindo

    Mindo

    Messages:
    1
    Ratings:
    +0
    same here bro :D i have the same problem.with CPU...old q8300 is running hard and my 4gigs of memory ....its low, but i dont have a money :D
     
    • Haha Haha x 1
  6. Stereo

    Stereo

    Messages:
    2,459
    Ratings:
    +1,495
    CPU at >99% in AC just means a single core is completely occupied, other programs (like windows task manager) report all cores combined so it would be 25% on a 4-core or 12% on 8-core.
     
    • Like Like x 2
  7. xnorb

    xnorb
    Premium

    Messages:
    1,649
    Ratings:
    +506
    AFAIK Assetto Corsa, in contrary to most sims, uses actual physics calculation for AI, so the first advice should be to lower the number of AI drivers on the road.

    When i run AC with 24 AIs on my i5 3550, all cores are pretty much melting :)
     
    • Agree Agree x 3
    • Haha Haha x 2
  8. Epistolarius

    Epistolarius
    Premium

    Messages:
    574
    Ratings:
    +377
    Because the one in AC doesn't show total CPU load/occupancy in the first place...

    http://www.assettocorsa.net/forum/i...ics-and-ff-frequency.31453/page-4#post-667481
     
    • Like Like x 1
    • Love Love x 1
    • Agree Agree x 1
  9. MaXKiLLz911

    MaXKiLLz911

    Messages:
    40
    Ratings:
    +9
    Same here.
     
    • Angry Angry x 1
  10. aphidgod

    aphidgod
    Premium

    Messages:
    1,097
    Ratings:
    +1,278
    Read the post above yours.
     
    • Love Love x 1
    • Haha Haha x 1
  11. Alex72

    Alex72

    Messages:
    680
    Ratings:
    +268
    Thats the idea though. When you have more opponents the cpu is more stressed and the FFB calculation will take it over the top and give you a warning. So if you did what the article suggest you might get away with not having the warning even with many AI.
     
  12. Piero Favretti

    Piero Favretti
    Premium

    Messages:
    234
    Ratings:
    +159
    I'm getting the "CPU Occupancy > 99% issue" error using the AccuForce wheel, i7 6800K 8/16 core processor, GTX 1070 and 32gb of RAM. WTH?!
     
  13. mister dog

    mister dog
    Premium

    Messages:
    261
    Ratings:
    +188
    Yeah but that's all low grade material, you need beefier specs.
     
    • Haha Haha x 3
  14. Tobiman

    Tobiman
    Premium

    Messages:
    464
    Ratings:
    +171
    That's a 6core/12thread cpu btw. Regardless, that's really wierd. My i5 @ 4.5ghz is usually in the 60s even with a huge grid.
     
  15. PicoBp

    PicoBp
    #26 | HSRC - Banzaaaiii Touring Car Crew Premium

    Messages:
    792
    Ratings:
    +461
    If it's FFB related, the problem is not the game, but your wheel driver. If it can't process FFB refresh at full rate, it will bog down your CPU by constantly waiting for the driver to send data to the wheel.
     
  16. Terra21

    Terra21
    Premium

    Messages:
    283
    Ratings:
    +741
    i had the same question asked a while ago "may 2016" when my dated setup i5 3570,gtx680,16gb ram could run road america fine with 30 ai on the grid at 60 fps.and a fellow seeing my yt vid commented he could not get the same 60 fps results with better hardware a GTX 970 a, AMD 8350 OC and 16gb ram without the 99% warning always showing and the game slowing/stuttering.the solution i asked him to try which in the end fixed the problem was to manually enable multicore processing in windows 10.his reply was...
    "Wow, thanks. No one ever told me, or even mentioned on the forums that you have to "enable" multi core processors in Windows? found a video telling "how to enable multi core processors in Windows 10." Kind of begs the question though. Why do my other games work fine, and report all 8 cores being used in MSI Afterburner? 36 AI on road America now work smooth as glass.thanks However only in AC was it a problem?"

    so its just a suggestion to try out which has worked for someone in the past.. not sure if it was just because he had an 8 core amd or not..
    ...
     
    Last edited: Feb 18, 2017
  17. Joerg Baermann

    Joerg Baermann
    Premium

    Messages:
    61
    Ratings:
    +49
    Instead of giving an advice they could make a temporary patch that corrects the values upon which wheel the game finds until a permanent solution is found.
     
  18. McM

    McM

    Messages:
    44
    Ratings:
    +4
    WOW thanks from me to, didn't know that either... does that mean AC (and other games) can now use all 4 cores? Does that mean that having 4 cores enabled and I am just in windows, all 4 cores are running too and will kill my CPU faster? Some more explanations would be nice, very hard to understand what google is showing me as results. THX :)
     
  19. Joerg Baermann

    Joerg Baermann
    Premium

    Messages:
    61
    Ratings:
    +49
    Windows 10 detects all cores by itself, just check the performance tab in task manager, msconfig's advanced boot option is only there to disable core detection at boot.
    If anything you can disable core parking in Windows: https://bitsum.com/parkcontrol/ , and you can align their clock speeds via BIOS by letting them run synchronized at the expense of power-saving.
    I would recommend the whole process lasso suite, there is a free version for both 32 as 64 bit systems, it is advised to read the manual since not all settings are meant to be tweaked on a regular PC.
     
    • Like Like x 2
  20. Tobiman

    Tobiman
    Premium

    Messages:
    464
    Ratings:
    +171
    The 911 GT3 Cup used to be really chatty and skippy which I really liked. This new update has smoothened out the handling of the car. Could that be as a result of the now symmetric ARBs?