1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC Issue - Multiplayer: driver attitude & lag

Discussion in 'Assetto Corsa' started by Ian Cameron, Nov 2, 2014.

  1. Spent most of my time since early early access tweaking, adjusting this and that to get my wheel, fps, graphics etc. right and still probably got along way to go.
    So I thought I'd give online a try, joined a server, selected available car and away I went with 10 mins of qualifying left.
    Every time another car came up to me it slammed into me, spun me off the road while it just kept on going. Also all the other cars were stuttering one minute a few feet in front then a split second later it was 100 feet in front then it just kept appearing somewhere else. How can you race like that, thought these problems had been sorted.
    not really got a question, just an observation really so would appreciate any thoughts.
     
  2. William Wester

    William Wester
    Premium Member

    Lag can be attributed to AC net-code or the internet connection (latency issues) between your computer and the server. What was your PING?
     
  3. sorry that I didn't take note of

    Edit:
    so what is the rule of thumb with regards to selecting best server

    mod-edit: consolidated for you, please keep the forum tidy
     
    Last edited by a moderator: Nov 2, 2014
  4. Andy Jackson

    Andy Jackson
    Sponsored by BRUT Premium Member

    Race here, at the race club for AC.
     
  5. Have looked into that just seems at mo when a race is scheduled i can't seem to make it owing to work but will try to join one.
     
  6. I have similar issues online, with a 200ms ping. However, I have none of these issues with rFactor 2 and other Gmotor games. So it's really possible for them to make it more playable. Hope they can manage it.

    Funny thing is, I've had some long online races where it doesn't happen at all. And then others where it happens 100% of the time when and immediately after you join, with the same ping. Maybe there are other factors that play a role?
     
  7. Joao Alves

    Joao Alves
    Premium Member

    Most of the problems people have with AC's MP come from an improperly setup server. In the US club races we use a server based in the Netherlands and have a few Australians that join in with pings nearing 400 some times. It's always stable and we can race eachother without issue. There's one setting in particular that directly affects the quality of the netcode, and it takes some testing to find what's best on your server.

    [ShamelessPlug] If you have the time, check out the club races since we know the correct settings and make some fun races :rolleyes::D [/ShamelessPlug]
     
  8. As pointed out by others, your problems seem related to latency. The higher the ping, the worse. So as rule of thumb, when trying to join a MP race, sort the servers by ping (lower first) and join one of the servers with lower pings.

    That is no guarantee of a good MP experience, but it should be more likely.
     
  9. Thanks will try that